Уголок новичка
   339

В AUR отсутствует нужная версия Teamviewer(15), но есть tar.xz с оф. сайта. Нужна помощь в установке.

Система — Манджаро линукс, требуется связаться по тимвьюверу. Есть устанвленная с AUR версия — teamviewer14, при попытке соединения выдает ошибку несоответствия версий (у партнера 15 на винде стоит).
С оф. сайта скачал 15 версию teamviewer_15.17.6_amd64.tar.xz, как правильно ее установить?
По поиску похожей темы отправляют в AUR. В AUR максимальная версия — 14.
Буду очень признателен за помощь.
Уголок новичка: В AUR отсутствует нужная версия Teamviewer(15), но есть tar.xz с оф. сайта. Нужна помощь в установке.

6 комментариев

avatar
У тебя на скрине видно teamviewer 15.16.8-1
+2
avatar
Есть 15 версия
реально и на скрине есть на твоём :))
Последний раз редактировалось
+1
avatar
Что же он мне гад, такой, пишет? Поставил ему 15 версию…

Причем, на компьютере партнера точно 15 стоит.


Возможно, ему 15.17 именно нужна? Тогда точно с tar.xz ставить, там как раз такая и есть.
Последний раз редактировалось
0
avatar
Добудь не tar.xz а amd64.deb с офсайта нужной версии
Скачай её на комп в какую-нибудь папку, в неё же положи PKGBUILD скачанный с aur, например от 15й версии. Можешь файлом с сайта, а можешь просто выполнить в этой папке git clone aur.archlinux.org/teamviewer.git

Дальше подредактируй PKGBUILD, удали там ссылку на сайт, вместо неё впиши локальный адрес файла .deb который у тебя на компе (sha256 тоже отредактируй, узнать верные можно через sha256sums ИМЯФАЙЛА.amd64.deb). Название версии вверху тоже можешь исправить. Остальное не меняй

После того как отредактируешь в консоли в этой папке выполни makepkg -sri. Он соберет пакет нужной версии, и предложит «установить Y/N», всё.

Если не получится я не виноват, ещё значит чето поправить в PKGBUILD надо. Но он напишет на что ругается при сборке, там наглядно.
Последний раз редактировалось
+4
avatar
Спасибо большое, все удалось с 1 раза. Подключился, без проблем. Очень подробная и понятная инструкция. Плюс с меня.
0
avatar
Дальше подредактируй PKGBUILD
достаточно заменить версию на 15.17.6 и заменить sha256sum либо на правильные суммы(команда makepkg -g их выведет в терминал), либо поставить в кавычках SKIP
Последний раз редактировалось
?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
+1
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.