Управление пакетами
   402

Не обновляется пакет python2-urllib3

Вот такое мне все время выдаёт


lexa1@W360 ~ $ pacaur -Suuyy

:: Запускается обновление AUR...

:: разрешение зависимостей...
:: поиск конфликтов между пакетами...

AUR Packages  (1) python2-freezegun-0.3.15-8  

:: Приступить к установке? [Y/n] 
:: Получаем пакет(ы)...
update complete: /home/lexa1/.cache/pacaur/python2-urllib3
:: python2-urllib3 файлы сборки актуальны -- пропускаем
:: Проверка целостности python2-urllib3...
==> Сборка пакета python2-urllib3 1.26.11-1 (Чт 01 сен 2022 11:25:41)
==> Получение исходных файлов...
  -> Найден urllib3-1.26.11.tar.gz
==> Проверка файлов source с использованием sha256sums...
    urllib3-1.26.11.tar.gz ... Готово
:: Preparing python2-urllib3...
==> Сборка пакета python2-urllib3 1.26.11-1 (Чт 01 сен 2022 11:25:42)
==> ВНИМАНИЕ: Пропуск проверки зависимостей.
==> Получение исходных файлов...
  -> Найден urllib3-1.26.11.tar.gz
==> ВНИМАНИЕ: Пропуск всех проверок целостности исходных файлов.
==> Распаковка исходных файлов...
  -> Распаковка 'urllib3-1.26.11.tar.gz' с помощью bsdtar
==> Запускается prepare()...
Changing hashbangs in *.py files to refer to 'python2'... done
Changing 'setup.cfg': setting 'xfail_strict' from true to false... done
==> Исходные файлы готовы.
:: Сборка пакета(ов) python2-urllib3...
==> Сборка пакета python2-urllib3 1.26.11-1 (Чт 01 сен 2022 11:25:43)
==> Проверка зависимостей для запуска...
==> Проверка зависимостей для сборки...
==> Установка недостающих зависимостей...
ошибка: не найдена цель: python2-pytest-freezegun>=0.4.0
==> ОШИБКА: pacman: не удалось установить недостающие зависимости.
==> Недостающие зависимости:
  -> python2-pytest-freezegun>=0.4.0
==> ОШИБКА: Не удалось разрешить все зависимости.
:: Ошибка сборки пакета(ов) python2-urllib3


Пытался установить этот python2-pytest-freezegun — там длиннющий вывод с кучей ошибок INTERNAL ERROR.

Как это обойти?

3 комментария

avatar
pamac справился
pamac install python2-freezegun;pamac install  python2-pytest-freezegun 
Последний раз редактировалось
?
p5ql/epu q9300 clover,hackintosh,mint,void,manjaro,only kde
0
avatar
Не получается:
<code>
File "/var/cache/private/pamac/python2-freezegun/src/freezegun-0.3.15/freezegun/api.py", line 163, in _should_use_real_time
    if not ignore_lists[-1]:
IndexError: list index out of range
==> ОШИБКА: Произошел сбой в check().
    Прерывание...

</code>
Та же ошибка
0
avatar
Использовать фризган из третьего пихона не вариант?
Второй официально все, EOL.
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.