Управление пакетами
   2692

Ошибка mount: /new_root: can't find UUID= ...после обновления системы и перезапуска.

Прошу помощи друзья, возникает данная ошибка после обновления системы, даже если ставлю ос заново со свежего образа, причём DE результат не меняет.
Управление пакетами: Ошибка mount: /new_root: can't find UUID= ...после обновления системы и перезапуска.
Система всегда стояла на отдельном Nvme накопителе, пробывал разделы заного нарезать, не помогает.
Проблема именно с Manjaro, другие дистрибутивы ставятся нормально и обновляются, проблем нет.
Читал про эту ошибку, это связано с systemd 242, и его откат на 239 версию, а именно (systemd lib32-systemd libsystemd systemd-sysvcompat) решает проблему.

Прошу обьяснить подробнее решение данной проблемы.

41 комментарий

avatar
возникает данная ошибка после обновления системы
1так система стояла? обновлялось ядро?
Проблема именно с Manjaro,
2 как ставили, работает ли в live cd? 3 загрузчик grub стоит, что там? Можно загрузиться с live cd сделать sudo manjaro-chroot -a?
?
p5ql/epu q9300
0
avatar
bbs.archlinux.org/viewtopic.php?id=243253
вот тут вроде написано но не понятным для меня пока что языком
0
avatar
установите google или chromium, они переводят на понятный язык и возможно ваше решение описано
?
p5ql/epu q9300
0
avatar
Система стояла, обновился и вот результат, потом пробывал из образа установить всё с нуля, ставится но после обновления и рестарта такой же результат
0
avatar
Я, как обычный пользователь, сделал бы так:
1)Переустановил бы систему.
2)Сделал бы сразу бэкап системы с помощью timeshift. Для того, чтобы не переустанавливать каждый раз после попытки решить проблему или обновления.
3)Поправил бы pacman.conf внеся проблемные пакеты в игнор при обновлении.
4)И на работающей системе искал бы решение или бы тупо ждал следующего обновления.

И вообще проверьте сразу после установки сам UUID диска написанный в fstab с выводом после команды
sudo blkid
Они похоже не совпадают.
Если это так, то просто пропишите правильный в fstab. Перезагрузите систему.
Последний раз редактировалось
0
avatar
Вот ответ есть, и вот и тут упоминается
I take it that this means you cannot boot into prompt mode at all. Which means you have to chroot into the installed partition and make repairs to it. But the situation does not look promising. Chroot [1] from a live cd and perform these operations at chroot sudo pacman-mirrors -g sudo pacman -Syyu sudo mkinitcpio -P Good luck. [1] — I rarely use chroot and these are the steps I used. There are several (okay,2) simpler ways to chroot but I have never used them. Perhaps if others step …
простыми словами грузись с флешки, заходи в chroot, и пересобери mkinitcpio,
sudo mkinitcpio -P

ну и пакеты заодно обнови
sudo pacman -Syyu
?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
0
avatar
Читал про эту ошибку, это связано с systemd 242, и его откат на 239 версию
с какого образа устанавливаешься, что там до сиз пор системд 239?
?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
0
avatar
Как зайти в chroot?
При вводе sudo manjaro-chroot -a загрузившись с usb появляется меню с выбором моего диска с системой, но когда выбираю то ошибка.systemd 242 в 18.1 Gnome
0
avatar
Как зайти в chroot?
тыц
монтируешь свой диск с системой
mount /dev/sdaX /mnt

где Х — номер диска
если /boot находится на отдельном разделе, то его монтировать в /mnt/boot
mount /dev/sdaX /mnt/boot

переход в /mnt
cd /mnt

далее по очереди эти комнады
mount -t proc proc /mnt/proc

mount -t sysfs sys /mnt/sys

mount -o bind /dev /mnt/dev

mount -t devpts pts /mnt/dev/pts/

chroot /mnt

вы chroot
Последний раз редактировалось
?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
0
avatar
Ручной chroot показан выше, а это авто если прокатит
?
p5ql/epu q9300
0
avatar
Ничего не получается, не пойму почему, в ручном режиме тоже не хочет монтировать.
0
avatar
где /?
?
p5ql/epu q9300
0
avatar
как то так получилось
0
avatar
Корень у меня btrfs, его и пытался смонтировать
0
avatar
Почему то не обновляется sudo pacman -Syyu, хотя инет работает
0
avatar
в лайф потом опять chroot
?
p5ql/epu q9300
0
avatar
Не получается sudo pacman -Syyu
0
avatar
Систему сейчас заново поставил архитектом и попробывал снова, результат выше, попробую chroot из архитекта....4й день мучаюсь не могу поставить дистр, раньше всё ставилось, да и сейчас перепробывал минты всякие и всё отлично
0
avatar
Наверно ставили в одно время поставил в виртуалку через архитект,btrfs, пользую первый раз Загрузилось с первого раза-долго! Работает Что за образ?
Последний раз редактировалось
?
p5ql/epu q9300
0
avatar
Образы все самые свежие, качал с этого сайта вчера.Архитект пробывал тот что отдельно и тот что с дистром.Вот что получилось но это по ходу не решает проблему, один хер эти строки как вначале поста
0
avatar

И что, по-Вашему, это должно сделать?
Последний раз редактировалось
+1
avatar
Попробую ещё раз архитект, но что то долго он висел у меня при первом запуске, я подумал что он завис вообще, минут 5 висел.Потом пробывал chroot в него но тоже самое что и с дистром gnome,xfce и тд
0
avatar
А другие линуксы ставил тоже в btrfs
ради интереса форматни root раздел в ext4
Последний раз редактировалось
?
p5ql/epu q9300
0
avatar
После установки с архитекта висит это окно уже мин 15, это херня полная, накопитель быстрый,12 потоков… так быть не должно.
Попробую ради интереса всё в Ext4 форматнуть и накатить из образа, отпишусь.
0
avatar
Можно было в лайф проверить grarter-ом на ошибки и вот еще
Последний раз редактировалось
?
p5ql/epu q9300
0
avatar
Хорошая идея, хотя ему и пол года нет, да и это именно манжаро тупит, минт то поставился.Попробую проверить гпартетом
0
avatar
Не диск а manjaro
здесь свежие iso
Последний раз редактировалось
?
p5ql/epu q9300
0
avatar
В ощем в Ext4 все разделы сделал и тоже самое система ставится и запускается, но как только обновил то хана… причём я пробывал и KDE и XFCE и гном, всё одно и то же.
Как проверить, напиши чуть подробнее....ISO образ проверить?
Я качал образ по твоей ссылке, только гном, не помню что было сним, вроде он не обновлялся или не ставился, не помню.Да и должно всё как часы работать с этого сайта.
0
avatar
здесь образы.Посмотри сайт, разницы нет т.к.ставишь архитектом. Странно, после архитекта там и обновлять нечего
но как только обновил то хана…
при обновлении sudo pacman -Syu > log.txt что-бы потом посмотреть. И последнее а какие пакеты обновлял? Проверил образ рабочий Ставлю так разметка в лайф и дальше
Последний раз редактировалось
?
p5ql/epu q9300
0
avatar
Вот именно что после архитекта нечего обновлять… висит это окно что я линковал и всё.
Сейчас попробую как обычно накатить.Уменя 16 оперативы, я своп не делаю, и HOME всегда на отдельном разделе.
0
avatar
Уменя 16 оперативы, я своп не делаю, и HOME всегда на отдельном разделе.
это эксперимент
добавил аур и обновил…
зачем и в архитекте есть но yay
HOME всегда на отдельном разделе
а как разметку в архитекте делаешь и mount
?
p5ql/epu q9300
0
avatar
Попробую чуть позже поменять накопители местами, попробую накатить систему на тот где щас винда стоит.
0
avatar
Как какие пакеты обновлял… я как обычный рак в линуксе должен скачать с этого сайта образ и поставить, установил, добавил аур и обновил…
0
avatar
После архитекта просто то окно что я линковал и всё, система намертво висит, после установки с образа такая ошибка, попробую по ссылке 18.1.4
0
avatar
Образ 18.1.4 вообще не видит мой накопитель, в отличии от 18.1.0, я его форматировал в разные фс, не видит ни гпартед ни установка.
0
avatar
В общем сейчас попробую винду перекинуть с обычного sata3 MLC ссд на этот линуксовый Nvme а линукс поставить на виндовый.Больше ничего в голову не приходит.
0
avatar
Другие тоже в Btrfs ставил
0
avatar
а сразу после обновления mkinicpio пробовал пересобирать?
?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
0
avatar
Без результата, то же самое.
0
avatar
РЕШЕНО.Всё решилось путём смены ssd накопителя.Мигрировал на него виндовс на NvMe (который не дружит с линукс) и он отлично пашет, и минты всякие тоже пашут, использовал Paragon.Linux сейчас стоит на sata 3 Goodram MLC и всё отлично ставится и обновляется.
Видимо это магия NVME от узкоглазых KingSpek, хотя ему всего то месяца 4, состояние отличное.
+1
avatar
однако очень странно, у меня тоже китайский ссд, уже 2 года ни единого разрыва
?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.