Управление пакетами
   3778

Пакман творит какую-то дичь при обновлении [РЕШЕНО]

Не могу обновить ни систему, ни любой отдельный компонент. Даже при попытке обновления ТГ вылезает это
Текст ошибки
Ошибка подготовки транзакции:
не удалось удовлетворить зависимости:
— удаление kparts нарушает зависимость «kparts», необходимую для ark
— удаление kpty нарушает зависимость «kpty», необходимую для ark
— удаление kitemmodels нарушает зависимость «kitemmodels», необходимую для ark
— удаление baloo нарушает зависимость «baloo», необходимую для baloo-widgets
— удаление bluez-qt нарушает зависимость «bluez-qt», необходимую для bluedevil
— удаление kdeclarative нарушает зависимость «kdeclarative», необходимую для bluedevil
— удаление frameworkintegration нарушает зависимость «frameworkintegration», необходимую для breeze
— удаление kdesu нарушает зависимость «kdesu», необходимую для cervisia
— удаление knewstuff нарушает зависимость «knewstuff», необходимую для dolphin
— удаление kcmutils нарушает зависимость «kcmutils», необходимую для dolphin
— удаление kactivities нарушает зависимость «kactivities», необходимую для dolphin
— удаление kio нарушает зависимость «kio», необходимую для ffmpegthumbs
— удаление qqc2-desktop-style нарушает зависимость «qqc2-desktop-style», необходимую для filelight
— удаление kquickcharts нарушает зависимость «kquickcharts», необходимую для filelight
— удаление purpose нарушает зависимость «purpose», необходимую для gwenview
— удаление kconfigwidgets нарушает зависимость «kconfigwidgets», необходимую для kde-gtk-config
— удаление kdbusaddons нарушает зависимость «kdbusaddons», необходимую для kde-gtk-config
— удаление kwindowsystem нарушает зависимость «kwindowsystem», необходимую для kde-gtk-config
— удаление modemmanager-qt нарушает зависимость «modemmanager-qt», необходимую для kdeconnect
— удаление ki18n нарушает зависимость «ki18n», необходимую для kdecoration
— удаление kunitconversion нарушает зависимость «kunitconversion», необходимую для kdelibs4support
— удаление knotifyconfig нарушает зависимость «knotifyconfig», необходимую для kdevelop
— удаление ktexteditor нарушает зависимость «ktexteditor», необходимую для kdevelop
— удаление threadweaver нарушает зависимость «threadweaver», необходимую для kdevelop
— удаление karchive нарушает зависимость «karchive», необходимую для kemoticons
— удаление kservice нарушает зависимость «kservice», необходимую для kemoticons
— удаление kfilemetadata нарушает зависимость «kfilemetadata», необходимую для kfind
— удаление kdoctools нарушает зависимость «kdoctools», необходимую для khelpcenter
— удаление kdnssd нарушает зависимость «kdnssd», необходимую для kio-extras
— удаление syntax-highlighting нарушает зависимость «syntax-highlighting», необходимую для kio-extras
— удаление kpeople нарушает зависимость «kpeople», необходимую для kpeoplevcard
— удаление kcontacts нарушает зависимость «kcontacts», необходимую для kpeoplevcard
— удаление kcoreaddons нарушает зависимость «kcoreaddons», необходимую для kpipewire
— удаление kwidgetsaddons нарушает зависимость «kwidgetsaddons», необходимую для kpmcore3
— удаление kitemviews нарушает зависимость «kitemviews», необходимую для krita
— удаление kcompletion нарушает зависимость «kcompletion», необходимую для krita
— удаление kguiaddons нарушает зависимость «kguiaddons», необходимую для krita
— удаление kcrash нарушает зависимость «kcrash», необходимую для krita
— удаление plasma-framework нарушает зависимость «plasma-framework», необходимую для kscreen
— удаление kidletime нарушает зависимость «kidletime», необходимую для kscreenlocker
— удаление kwallet нарушает зависимость «kwallet», необходимую для ksshaskpass
— удаление kwayland нарушает зависимость «kwayland», необходимую для kwayland-integration
— удаление knotifications нарушает зависимость «knotifications», необходимую для kwrited
— удаление ktextwidgets нарушает зависимость «ktextwidgets», необходимую для libksane
— удаление kconfig нарушает зависимость «kconfig», необходимую для libkscreen
— удаление kauth нарушает зависимость «kauth», необходимую для manjaro-settings-manager
— удаление krunner нарушает зависимость «krunner», необходимую для milou
— удаление networkmanager-qt нарушает зависимость «networkmanager-qt», необходимую для plasma-nm
— удаление kholidays нарушает зависимость «kholidays», необходимую для plasma-workspace
— удаление prison нарушает зависимость «prison», необходимую для plasma-workspace
— удаление kactivities-stats нарушает зависимость «kactivities-stats», необходимую для plasma-workspace
— удаление kiconthemes нарушает зависимость «kiconthemes», необходимую для polkit-kde-agent


Вроде как, это выплевывает Арк, но обойти его зависимости я не могу никак. При обновлении любой программы, он ссылается на его зависимости. Все галки сняты при том. Это новый прикол такой в системе?

Решение:
Удаляем лишние зависимости, после обновляемся. У меня это kpmcore3; kpeople; kcontacts
sudo pacman -Rdd kpmcore3;sudo pacman -Rdd kpeople;sudo pacman -Rdd kcontacts;sudo pacman -Syu

29 комментариев

avatar
Описанное относится как к пакману, так и к памаку.

Методом тыка, удалось «обновить» телегу из-под ее странички в пакмане. Перестала запускаться
Вывод
telegram-desktop: error while loading shared libraries: libabsl_strings.so.2308.0.0: cannot open shared object file: No such file or directory


То есть, зависимость какую-то не подтягивает этим способом, или еще чего не так делает. Варианты иные существуют для обновлений?
Последний раз редактировалось
0
avatar
Покажите вывод
pacman -Syu
Последний раз редактировалось
?
p5ql/epu q9300 clover,hackintosh,mint,void,manjaro,only kde
0
avatar
В шапке есть. Будет тоже самое, ток на английском. Чуть позже опробую снова и при повторении скопирую
0
avatar
вывод
:: Обновление баз данных пакетов…
core is up to date
extra 8,6 MiB 2,70 MiB/s 00:03 [################################] 100%
community is up to date
multilib is up to date
:: Запускается полное обновление системы…
:: Заменить attica на extra/attica5? [Y/n] y
:: Заменить baloo на extra/baloo5? [Y/n] y
:: Заменить bluez-qt на extra/bluez-qt5? [Y/n] y
:: Заменить frameworkintegration на extra/frameworkintegration5? [Y/n] y
:: Заменить kactivities на extra/kactivities5? [Y/n] y
:: Заменить kactivities-stats на extra/kactivities-stats5? [Y/n] y
:: Заменить karchive на extra/karchive5? [Y/n] y
:: Заменить kauth на extra/kauth5? [Y/n] y
:: Заменить kbookmarks на extra/kbookmarks5? [Y/n] y
:: Заменить kcmutils на extra/kcmutils5? [Y/n] y
:: Заменить kcodecs на extra/kcodecs5? [Y/n] y
:: Заменить kcompletion на extra/kcompletion5? [Y/n] y
:: Заменить kconfig на extra/kconfig5? [Y/n] y
:: Заменить kconfigwidgets на extra/kconfigwidgets5? [Y/n] y
:: Заменить kcontacts на extra/kcontacts5? [Y/n] y
:: Заменить kcoreaddons на extra/kcoreaddons5? [Y/n] y
:: Заменить kcrash на extra/kcrash5? [Y/n]
:: Заменить kdbusaddons на extra/kdbusaddons5? [Y/n] y
:: Заменить kdeclarative на extra/kdeclarative5? [Y/n] y
:: Заменить kded на extra/kded5? [Y/n] y
:: Заменить kdesu на extra/kdesu5? [Y/n] y
:: Заменить kdnssd на extra/kdnssd5? [Y/n] y
:: Заменить kdoctools на extra/kdoctools5? [Y/n] y
:: Заменить kfilemetadata на extra/kfilemetadata5? [Y/n] y
:: Заменить kglobalaccel на extra/kglobalaccel5? [Y/n] y
:: Заменить kguiaddons на extra/kguiaddons5? [Y/n] y
:: Заменить kholidays на extra/kholidays5? [Y/n] y
:: Заменить ki18n на extra/ki18n5? [Y/n] y
:: Заменить kiconthemes на extra/kiconthemes5? [Y/n] y
:: Заменить kidletime на extra/kidletime5? [Y/n] y
:: Заменить kimageformats на extra/kimageformats5? [Y/n] y
:: Заменить kio на extra/kio5? [Y/n] y
:: Заменить kirigami-addons на extra/kirigami-addons5? [Y/n] y
:: Заменить kitemmodels на extra/kitemmodels5? [Y/n] y
:: Заменить kitemviews на extra/kitemviews5? [Y/n] y
:: Заменить kjobwidgets на extra/kjobwidgets5? [Y/n] y
:: Заменить knewstuff на extra/knewstuff5? [Y/n] y
:: Заменить knotifications на extra/knotifications5? [Y/n] y
:: Заменить knotifyconfig на extra/knotifyconfig5? [Y/n] y
:: Заменить kpackage на extra/kpackage5? [Y/n] y
:: Заменить kparts на extra/kparts5? [Y/n] y
:: Заменить kpeople на extra/kpeople5? [Y/n] y
предупреждение: kpeoplevcard: установленная версия (0.1+r38.32d50a9-1) новее, чем в extra (0.1-2)
:: Заменить kpty на extra/kpty5? [Y/n] y
:: Заменить kquickcharts на extra/kquickcharts5? [Y/n] y
:: Заменить krunner на extra/krunner5? [Y/n] y
:: Заменить kservice на extra/kservice5? [Y/n] y
:: Заменить ktexteditor на extra/ktexteditor5? [Y/n] y
:: Заменить ktextwidgets на extra/ktextwidgets5? [Y/n] y
:: Заменить kunitconversion на extra/kunitconversion5? [Y/n] y
:: Заменить kwallet на extra/kwallet5? [Y/n] y
:: Заменить kwayland на extra/kwayland5? [Y/n] y
:: Заменить kwidgetsaddons на extra/kwidgetsaddons5? [Y/n] y
:: Заменить kwindowsystem на extra/kwindowsystem5? [Y/n] y
:: Заменить kxmlgui на extra/kxmlgui5? [Y/n] y
:: Заменить modemmanager-qt на extra/modemmanager-qt5? [Y/n] y
:: Заменить networkmanager-qt на extra/networkmanager-qt5? [Y/n] y
:: Заменить plasma-framework на extra/plasma-framework5? [Y/n] y
:: Заменить prison на extra/prison5? [Y/n] y
:: Заменить purpose на extra/purpose5? [Y/n] y
:: Заменить qqc2-desktop-style на extra/qqc2-desktop-style5? [Y/n] y
:: Заменить solid на extra/solid5? [Y/n] y
:: Заменить sonnet на extra/sonnet5? [Y/n] y
:: Заменить syndication на extra/syndication5? [Y/n] y
:: Заменить syntax-highlighting на extra/syntax-highlighting5? [Y/n] y
:: Заменить threadweaver на extra/threadweaver5? [Y/n] y
разрешение зависимостей…
проверка конфликтов…
:: libgedit-amtk и amtk конфликтуют. Удалить amtk? [y/N] y
ошибка: не удалось подготовить транзакцию (не удалось удовлетворить зависимости)
:: installing jre-openjdk (21.u35-3) breaks dependency 'java-runtime-openjdk=20' required by java-openjfx
:: removing kpeople breaks dependency 'kpeople' required by kpeoplevcard
:: removing kcontacts breaks dependency 'kcontacts' required by kpeoplevcard
:: removing kwidgetsaddons breaks dependency 'kwidgetsaddons' required by kpmcore3
:: removing kcoreaddons breaks dependency 'kcoreaddons' required by kpmcore3
:: removing ki18n breaks dependency 'ki18n' required by kpmcore3
[tosha@ManjaroPC ~]$
0
avatar
предупреждение: kpeoplevcard: установленная версия (0.1+r38.32d50a9-1) новее, чем в
Пробуйте
pacman -Rdd amtk;pacman -Syyuu
Последний раз редактировалось
?
p5ql/epu q9300 clover,hackintosh,mint,void,manjaro,only kde
0
avatar
Три зависимости kpmcore3 остались на месте, не дают пройти дальше
0
avatar
pacman -Rdd kpmcore3;pacman -Syu
Последний раз редактировалось
?
p5ql/epu q9300 clover,hackintosh,mint,void,manjaro,only kde
0
avatar
sudo pacman -Rdd kpmcore3;sudo pacman -Rdd kpeople;sudo pacman -Rdd kcontacts;sudo pacman -Syu

Обновление сдвинулось, теперь жду
0
avatar
sudo pacman -Rdd kpmcore3;sudo pacman -Rdd kpeople;sudo pacman -Rdd kcontacts;sudo pacman -Syu

И норм все стало
0
avatar
Ага, новый прикол. Массовое переименование пакетов KDE5, например ki18n в ki18n5. Было в августе.
Открывай pamac-manager, обновляй зеркала и жмякай «Обновления».
+1
avatar
Попробую сначала зеркала
0
avatar
Все равно так
вывод
Разрешение зависимостей…
Проверка на взаимные конфликты…
Ошибка подготовки транзакции:
не удалось удовлетворить зависимости:
— невозможно удовлетворить зависимость «java-runtime-openjdk=20», необходимую для java-openjfx
— удаление kpeople нарушает зависимость «kpeople», необходимую для kpeoplevcard
— удаление kcontacts нарушает зависимость «kcontacts», необходимую для kpeoplevcard
— удаление kwidgetsaddons нарушает зависимость «kwidgetsaddons», необходимую для kpmcore3
— удаление kcoreaddons нарушает зависимость «kcoreaddons», необходимую для kpmcore3
— удаление ki18n нарушает зависимость «ki18n», необходимую для kpmcore3
Транзакция отменена.
0
avatar
Да, кеды по кругу требуют старые пакеты как зависимости, не давая их удалить. И в то же время, не дает ничего обновить без их удаления. Жопка
0
avatar
кусочек лога
[2023-11-08T08:45:48+0700] [PACMAN] Running 'pacman -R -d -d --config /etc/pacman.conf — kirigami-addons'
[2023-11-08T08:45:49+0700] [ALPM] transaction started
[2023-11-08T08:46:01+0700] [ALPM] removed kirigami-addons (0.11.0-2)
[2023-11-08T08:46:02+0700] [ALPM] transaction completed
[2023-11-08T08:53:49+0700] [PACMAN] Running 'pacman -Syyuu telegram-desktop'
[2023-11-08T09:14:10+0700] [ALPM] transaction completed
утреннего обновления.У меня с плазмой еще и тринити потому думал что из-за этого.
?
p5ql/epu q9300 clover,hackintosh,mint,void,manjaro,only kde
0
avatar
При этом яву то можно отменить, а кеды тянет практически всегда. Хоть ты что обновляй и хоть какие галки снимай. А если обойдешь — так зависимости не крутанет для программы и телега уже не стартует. Кеды решили быть гномом, скоро будет платный режим для натуралов
0
avatar
Все проще. Грядет KDE6 и короткие имена освобождают под них. Почему не сделать как в крысе, где куча пакетов зовется xfce4-$PACKAGENAME и никому это xfce4- в начале не мешает? Не знаю.
Но, что от чего pacman с pamac охреневали, у меня pikaur хорошо разруливал.
Еще можно загрузиться в другое DE и забить на кеды, WM либо вообще в TTY и так удалить и завново поставить KDE.
Последний раз редактировалось
0
avatar
Удаление kpmcore3 перед полным обновлением какие подводные имеет? Я нуб по этой части, а название пакета предостерегает. Кеды смогут без этой фигни стартовать? Как вариант — повторная установка сразу после обновления до перезагрузки
HargardMoroznyy тот же вопрос
0
avatar
Потому что нельзя на Манжаро пропускать обновления!
Это на Арче/Эндеворе можно по полгода не обновляться. (На убунте/бедиане вообще не нужно)
Ментейнеры Манжаро первое чем озадачены — стабильностью и простотой эксплуатации. А потому задежка «новейших» кривых пакетов и драйверов (йо, глиноМеса) на несколько месяцев, тотальное переименование (как с КДЕ) и даже даунгрейды проскочивших в stabble пакетов — дело житейское.
+1
avatar
Система обновлена полторы недели назад полностью. Коротковат срок для таких изменений
P.S. возможно, что конкретно мне прилетело не сразу
Последний раз редактировалось
0
avatar
Мой минус, как пользователя, в том, что я практически принципиально остаюсь на уровне «уверенный юзер» и не изучаю сверх необходимого. Чести ради, секса с манжаро у меня было меньше, чем с любой виндой кроме ХР. Даже уронить и поднять иксы было более легкой задачей, чем вычистить сраный эсет с семерки))))
Вот сейчас понял, что проворонил ядра и сижу на 510. Обновил до 515. Смотрю отзывы насколько важно уйти на 6+
Это вполне может быть причиной, почему я получил некоторые обновы позже и ошарашен не в августе, а спустя весьма малое время с полного обновления пакетов из памака/пакмана
Последний раз редактировалось
0
avatar
Решился на linux61 LTS. Ну его в сраку, еще провороню повторно. С обновой пакетов пока что воз там же. Сомневаюсь по своей задумке удалить kpmcore3 перед обновой
0
avatar
Linux510,515,61 LTS все работают по сей день.
kpmcore3
у меня в системе нет.Попробуй и покажи вывод
pacman -Qtdq | pacman -Rns -
предварительно
sudo -s</code
PS правильно говорит Gambit_VKM  yay -Syu  тоже хорошо зависимости разруливает
Последний раз редактировалось
?
p5ql/epu q9300 clover,hackintosh,mint,void,manjaro,only kde
0
avatar
Лол, yay не найдена)
0
avatar
<code>pacman -Syu yay</code>
установит yay
?
p5ql/epu q9300 clover,hackintosh,mint,void,manjaro,only kde
0
avatar
pacman -Qtdq | pacman -Rns -

вывод
[tosha@ManjaroPC ~]$ sudo pacman -Qtdq | sudo pacman -Rns — проверка зависимостей…
:: kdevelop опционально требует cmake: cmake integration

Пакеты (53) clang15-15.0.7-1 cmake-3.27.5-1 compiler-rt15-15.0.7-1 cppdap-1.58.0-1
faudio-23.09-1 http-parser-2.9.4-1 llvm15-libs-15.0.7-1 openimageio-2.4.12.0-3
pybind11-2.11.1-1 python-iniconfig-2.0.0-4 python-pluggy-1.3.0-1
python-pyproject-hooks-1.0.0-5 python-repoze.lru-0.7-9 re2-1:20230901-1
rhash-1.4.3-1 appstream-glib-0.8.2-3 asciidoc-10.2.0-3 boost-1.83.0-2
cython-3.0.2-1 debugedit-5.0-5 elfutils-0.189-3 extra-cmake-modules-5.110.0-1
gn-0.2119.cc56a0f9-1 gperf-3.1-5 gradle7-7.6-1 groovy-4.0.12-1 itstool-1:2.0.7-1
lib32-attr-2.5.1-1 lib32-faudio-23.07-1 lib32-lcms2-2.15-1 libgit2-1:1.7.1-1
libgnome-keyring-3.12.0+13+g4f8ab73-3 libindicator-gtk3-12.10.1-10
libsidplay-1.36.59-10 libvisual-0.4.2-1 noto-fonts-compat-20151217-1
openshadinglanguage-1.12.13.0-3 perl-parse-yapp-1.21-6 python-build-1.0.1-1
python-flit-core-3.9.0-1 python-grpcio-1.58.0-1 python-installer-0.7.0-3
python-pep517-0.13.0-1 python-polib-1.2.0-2 python-pytest-7.4.2-1
python-routes-2.5.1-6 python-testpath-0.6.0-2 qt6-5compat-6.5.2-1 rust-1:1.72.0-1
vamp-plugin-sdk-2.10.0-2 xmlto-0.0.28-4 xorg-server-xvfb-21.1.8-2 zip-3.0-10

Будет освобождено: 1245,01 MiB

:: Удалить эти пакеты? [Y/n]
0
avatar
Будет освобождено: 1245,01 MiB

:: Удалить эти пакеты? [Y/n]
сколь мусора, я бы удалил
?
p5ql/epu q9300 clover,hackintosh,mint,void,manjaro,only kde
0
avatar
Для понимания
1
Для удаления всех сирот:
смотрим Тут
2
Удаление неиспользуемых пакетов
смотрим Тут
?
p5ql/epu q9300 clover,hackintosh,mint,void,manjaro,only kde
0
avatar
Та я уже об откате подумываю. Они там баг с падающим networkmanager вернули, грею стул
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.