Управление пакетами
   802

После обновления перестали запускаться приложения

Привет. На днях обновил систему, выключил и лег спать. На следующий день перестали запускаться браузеры (opera, chrome) и другие приложения (atril, vs code, gvim (nvim работает), onlyoffice, даже manjaro hello и pamac). Я не все проверил. Некоторые работают, некоторые нет.
Переустановка пакетов не помогает.
Ker: 5.15.38-1
Plasma 5.24.5
Manjaro 21.2.6

23 комментария

avatar
Привет из будущего! Уже догадался выбрать при входе в систему Х11, вместо внезапно ставшим дефолтным waynand?
Последний раз редактировалось
0
avatar
Нет, у меня стоит x11. Дополнительно скачал plasma-wayland-session там тоже выбран x11. Несколько раз проделал, перезаходил, перезагружал.
0
avatar
LTS ядро стоит? если с ним загрузиться?

Мне кажется ядро криво встало. Лог не смотрел сразу после обновы?
Последний раз редактировалось
0
avatar
live cd > manjaro-chroot > reinstall plasma
Последний раз редактировалось
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
0
avatar
Достаточно сделать, как на скрине?
Достаточно сделать, как на скрине?
0
avatar
пробуйте

sudo pacman -Syu plasma
Последний раз редактировалось
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
0
avatar
Нет, не помогло. Мне уже говорили если через терминал не запускается, то дело не в плазме вероятно. Вот моя тема на оффоруме
0
avatar
pacman -Qo libicuuc.so.70
pacman-mirrors -G
покажите
Последний раз редактировалось
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
0
avatar
странно все ставится и открывается, не открывающиеся пакеты как ставились? пробуйте
yay -Syu
покажите
pamac checkupdates -a
Последний раз редактировалось
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
0
avatar
Я не помню как их ставил. Ставлю только через памак или пакман.
Yay смог обновить Anki, а проигрыватель нет. Pamac показал те же ошибки. Два раза проводил эти манипуляции.
0
avatar
yay -Rsn deadbeef;yay -S deadbeef

deadbeef
(1/1) установка deadbeef [#######] 100%
Дополнительные зависимости для 'deadbeef'
alsa-oss: for OSS output plugin [установлено]
cdparanoia: for cd audio plugin [установлено]
curl: for last.fm, vfs_curl (shoutcast/icecast), artwork
plugins [установлено]
dbus: for notification daemon support (OSD current song
notifications) [установлено]
faad2: for AAC plugin [установлено]
ffmpeg4.4: for ffmpeg plugin [установлено]
flac: for flac plugin [установлено]
imlib2: for artwork plugin [установлено]
libcddb: for cd audio plugin [установлено]
libcdio: for cd audio plugin [установлено]
libice: optional dependency for gtkui session client support
[установлено]
libmad: for mp3 plugin (mpeg1,2 layers1,2,3) [установлено]
libogg: for ogg vorbis plugin [установлено]
libsamplerate: for dsp_libsrc plugin (resampler)
[установлено]
libsidplay: for SID player plugin
libsm: optional dependency for gtkui session client support
[установлено]
libsndfile: for sndfile plugin [установлено]
libvorbis: for ogg vorbis plugin [установлено]
libx11: for global hotkeys plugin [установлено]
libzip: for vfs_zip plugin [установлено]
mpg123: for MP1/MP2/MP3 playback [установлено]
opusfile: for opus plugin [установлено]
pulseaudio: for PulseAudio output plugin [установлено]
wavpack: for wavpack plugin [установлено]
yasm: required to build assembly portions of ffap plugin
[установлено]
zlib: for Audio Overload plugin (psf, psf2, etc), GME (for
vgz) [установлено]
:: Запуск post-transaction hooks…
(1/3) Arming ConditionNeedsUpdate…
(2/3) Updating icon theme caches…
(3/3) Updating the desktop file MIME type cache…
[vit@pc ~]$ pacman -Qs deadbeef
local/deadbeef 1.9.1-1
Modular GTK audio player for GNU/Linux
Последний раз редактировалось
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
0
avatar
Нет, тоже самое, что и на скрине
0
avatar
sudo pacman -S base base-devel;reboot
пробуйте
Последний раз редактировалось
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
0
avatar
Нет, ничего. Подскажите что говорит zbe в последнем сообщении? Не понимаю его. Может это поможет.
0
avatar
Спойлер!
Не имеет значения, обновляется ли система. У этих ребят установлено огромное количество пакетов AUR.

Пример: вы устанавливаете пакет aur-X из AUR, который зависит от icu, а также этот пакет конфликтует и заменяет репозиторий пакета-X из репозитория manjaro.
Тогда любые официальные пакеты, которые зависят от repo-X, теперь не работают, потому что ВЫ. НЕОБХОДИМОСТЬ. К. ВОССТАНОВИТЬ. АУР. ПАКЕТЫ.: смайлик:
большими буквами вам необходимо восстановить пакеты из Аур
посмотреть пакеты не официальные
pacman -Qmqe > pac.txt
в домашней папке
Последний раз редактировалось
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
0
avatar
Мне нужно их все переустановить?
<code>anki
exercism-bin
fsearch
gnome-icon-theme
google-chrome
otf-code-new-roman
paru
rusty-man
sniprun
sublime-text-3
ttf-times-new-roman
visual-studio-code-bin
xiaomi-adb-fastboot-tools-bin
yandex-browser-beta
yandex-browser-ffmpeg-codecs-update-hook</code>
0
avatar
начать с удаления этих пакетов
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
0
avatar
Удалил их командой pamac remove, но пришлось удалить от кого они зависят, это gstreamer0.10-base и gnome-doc-utils для python2-libxml2. Перезашёл, проверил обновы. Не знаю, что ещё можно сделать.
0
avatar
смотрим
<code>pacman -Qs opera</code>
если отличается
Опера
pacman -Qs opera
local/coreutils 9.1-1
The basic file, shell and text manipulation utilities of the GNU operating system
local/imath 3.1.5-1
A C++ and python library of 2D and 3D vector, matrix, and math operations for computer
graphics
local/opera 86.0.4363.50-1
A fast and secure web browser
пробуем
<code>sudo pacman -Rdd opera;sudo pacman -S opera</code>
если отличий нет удаляем конфиг оперы
<code>sudo rm -r ~/.config/opera
</code>
пробуем запустить браузер
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
0
avatar
Не знаю это отличается или нет. Версии одинаковые, но у меня вывода больше. Попробовал два варианта. Удалил > установил > проверил. Удалил конфигурации > проверил. Не работает. Каждый раз перезагружаю сеанс.
0
avatar
в консоле
<code>opera</code>
вывод покажите
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
0
avatar
До того как переустановил сегодня, на двух строчках было Discarded=1, одна вместо строчки CrashID
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.