Блог им. va2tin
   204

Проблема с копированием в Libre Office

Добрый день. При копировании из одного документа libre office в другой документ libre office, и последующей вставке, из контекстного меню, вставляется не актуальный текст (текст скопированный перед последним копированием). Для того что бы скопировать текст, необходимо дважды нажать «копировать» из контекстного меню

9 комментариев

avatar
Наблюдаю эту проблему на протяжении полугода, на разных «машинах», неужели проблема проявляется только на моих компьютерах?
0
avatar
У меня все норм.
И никогда подобного бага не было.
Может мышь козлячит?
?
i3-3210/4GB/VGA на борту//Manjaro/5.4.*/x64/KDE Plasma 5.18.3/Chromium 80.*
0
avatar
Манипуляторы разные на всех машинах. Проблема проявляется на Manjaro Gnome и Manjaro LxQt, есть машины с Fedora — на них буфер обмена работает нормально. Пробовал разные варианты установки Libre Office (Flatpak, Snap пакеты; разные варианты из репозиториев: still, fresh, из AUR разные варианты пакетов) — не помогает. Пробовал установить parcellite, autocutsel, xcmenu и еще несколько менеджеров буфера обмена — не помогает, а даже добавляет проблем с работой буфера.
0
avatar
В сторону primary selection смотрели?
0
avatar
После установки autocatsel запускал в терминале и выполнял команды: для запуска — $ autocutsel, потом $ autocutsel -s PRIMARY (руководствуясь советами отсюда kompsekret.ru/q/how-can-i-merge-the-gnome-clipboard-and-the-x-selection-1576/) — не помогло, а наоборот, некорректное поведение буфера начало проявляться во всех приложениях
Последний раз редактировалось
0
avatar
Это не некорректное поведение, а два разных буфера и настройки их синхронизации. В parcellite чтобы содержимое primary не вставлялось по хоткеям clipboard в поведении должна быть отмечена только верхняя галка. Разумеется, другие менеджеры буфера обмена должны быть отключены.
autocutsel -s PRIMARY
Оно и будет автоматом пихать содержимое primary, то есть выделенный объект, в clipboard.
Для лучшего понимания механики работы буферов смотрите этот спойлер.
0
avatar
Попробую разобраться
0
avatar
Попробовал сессию на xorg — не помогло
0
avatar
Извиняюсь, думал, что manjaro использует по умолчанию Wayland. Включил сессию xorg в конфиге gdm, выбрал xorg сессию и был уверен, что до этого использовал wayland. После запустил сессию на Wayland и удивился что буфер работает как нужно). Но все же это не совсем решение проблемы, в сессии на Wayland наблюдаю фризы. Пользоваться не комфортно, хотелось бы починить xorg
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.