Блог им. zulkarnein

не работает звук Manjaro linux

Здравствуйте, установил на ноутбук HUAWEI MateBook D15 линукс manjaro

Нет звука, до этого мучался с fedora, но на 3-4 минуты звук было возможно вернуть через pulseaudio -k
На винде всё работало, но на сколько я помню там тоже надо было повозиться со звуком

вывод команды aplay -l: aplay: device_list:279: no soundcards found…
вывод команды ls /dev/snd: seq timer

третий день сижу не могу решить эту проблему с аудиокартой, многое пробовал, ядро менял, но я лишь новичок в linux, помоги не забросить эту ось в очередной раз
ситуация возможно не простая, но я надеюсь, что я ошибаюсь
Manjaro KDE Edition

[Решено] Появляется сообщение Ограниченное подключение, что с ним делать?

Доброго времени суток!

Стало появляться сообщение об ограниченном подключении и сайты иногда тупят при загрузке, при загрузки с флэшки тоже самое.

Сразу скажу, что тут я тупой, скажите по шагам, пожалуйста.

С винды на соседнем диске такого нет, ни каких ошибок или предупреждений.

У жены с винды вай фай иногда мог пропадать, но пока у нее все отлично.

Кабель идет в роутер, с роутера другой кабель в комп, у жены вай фай просто.

Можно было бы грешить на провайдера, но с винды все нормально.

Может, как то драйвер на сетевую обновить?

Как проверить? Кто сталкивался и что делать?

Пойду еще на флэшку какой ни будь образ linux запихну и загружусь, проверю.

Благодарю!
Уголок новичка

Не работает центр обновлений

В телеграмм попасть не получилось, везде статус «запрещено писать сообщения» поэтому придется здесь)

В общем, установил manjaro 24 & KDE, сразу после установки предложил установить обновы, и выдал ошибку «ошибка транзакции базы, неверная или поврежденная база данных», подскажите как лечить. И почему на чистой системе вообще такая ошибка может быть?
Уголок новичка

Boot repair Windows 11 и Manjaro - как чинить?

Приветствую.
Опишу суть проблемы:
Сжал раздел NTFS на 50ГБ и установил туда 'последнюю версию Manjaro. Все прекрасно работало
УТРОМ ВСТАЛ — ЗАГРУЖАЕТСЯ ТОЛЬКО WINDOWS. MANJARO НЕТ!
Переписал на флешку Boot repaire но он ничего не дал кроме info-файла — его приложу если необходимо.
в grub и linux я новичок поэтому просьба помочь посоветовать восстановить загрузку Manjaro

Алексей
antreln@mail.ru
Manjaro KDE Edition

[Решено] Шаблоны файлов в Manjaro, как создать свои?

Еще тупой вопрос от меня.

Бывает, что нужно создать файл JavaScript или CSS, да мало ли — Python.

И везде написано, зайдите в Домашнюю папку, там папка Шаблоны, далее там создавайте файл с нужным вам расширением. После чего в контекстном меню в разделе создать будут появляться нужные вам файлы.

Я так все и сделал, но там (в меню и соответствующем разделе) по прежнему можно создать только файлы по умолчанию — текстовый, пустой, офисные.

Самое то странное, что в Cinnamon все создается, в других оболочках не пробовал.

Как бы не критично, можно и из редактора создать, но по привычке создаю шаблоны.

Спасибо!
Manjaro KDE Edition

[Решено] Не отображается экранное уведомление при смене языка.

Доброго времени суток!

Извините за тупой вопрос, но у меня других нет… ))))

Не отображается экранное уведомление при смене языка, хотя галочка такая в настройках клавиатуры стоит.

Такая же настройка в BigLinux kde, возможно и еще где то, точно работает.

Не критично, но все таки, из интереса.

Из раза в раз это глюк не меняется.

Manjaro только-только поставленная с последнего образа из оф. сайта.

Спасибо.
Manjaro XFCE Edition

[РЕШЕНО (костыль)] Проблемы в новой Manjaro 24

Здравствуйте! Сидел до этого на 23 версии, все работало, поставил 24 и случились две проблемы.

1) Не подключается к VPN через GUI. Скачал несколько .ovpn файлов, которые 100% работают, но у значка WiFi (справа снизу) просто крутится кружок (мол, подключение) после чего пишет, что не удалось подключиться (timed out) (и так с каждым файлом). Раньше такой проблемы не было.

2) Не удаётся включить AUR в центре пакетов. Когда включил AUR, набрал в поиске «opera», после чего окно резко закрылось. При повторном запуске поиск работает, но нет репозитория AUR. Пробовал через терминал «sudo pacman -Syu» отображает только три репозитория (core, extra, multilib). После нескольких перезагрузок вообще пропал пункт включения/отключения поддержки AUR в центре пакетов.

Единственный плюс: пофиксили наконец глюк с WiFi, когда после ухода в спящий режим и выхода из него, он рандомно отваливался, в результате чего помогала только повторная перезагрузка устройства.

UPD (03:29): Ссылка на тему.

Потанцевал с бубном, ничего не понял, но как-то решил проблему, решение ниже. Способ кривой, парной, но хоть что-то, чем вообще без ничего.

РЕШЕНИЕ:

sudo su

vim /etc/NetworkManager/system-connections/<название впн>_openvpn.nmconnection

Добавляем строчку ниже cipher
data-ciphers=AES-256-CBC
или (в зависимости от конфигурации)
data-ciphers=AES-128-CBC
в раздел [VPN].
Manjaro XFCE Edition: 22
Перезагружаем NetworkManager.
sudo systemctl restart NetworkManager.service

Готово! Теперь подключение к VPN будет работать.

Еще один способ, более улучшенный:


Тык! Ссылка на тему.

pamac install manjaro-downgrade

Здесь выбираем версию ниже. Я ставил 2.5.8.
manjaro-downgrade openvpn

sudo systemctl restart NetworkManager.service

Готово! Теперь будет подключаться без необходимости постоянно редактировать файлы.

Начиная с 6 версии OpenVPN везде этот баг.
Блог им. vollodin61

Зависает при выключении

Здравствуйте! Столкнулся с проблемой — зависает ноутбук при выключении (но не каждый раз)

Нажимаю выключить, показывает загрузочный экран, потом черный экран, и всё. В таком состоянии больше часа проводить может.

При перезагрузке такого зависания нет.
Система обновлена sudo pacman -Syyuu

В других топиках искал ответ — не нашёл. В них там спрашивали вывод команды inxi -F, и ещё логи из /var/log/Xorg.0.log.old
Вот сразу, если нужны.

Логи https://pastebin.com/Lei9chKz

inxi -F
System:
Host: i-comp Kernel: 6.6.30-2-MANJARO arch: x86_64 bits: 64
Desktop: KDE Plasma v: 6.0.4 Distro: Manjaro Linux
Machine:
Type: Laptop System: LENOVO product: 82K2 v: IdeaPad Gaming 3 15ACH6
serial: Mobo: LENOVO model: LNVNB161216 v: No DPK serial: UEFI: LENOVO v: H3CN31WW(V2.01) date: 11/18/2021
Battery:
ID-1: BAT1 charge: 52.2 Wh (100.0%) condition: 52.2/60.0 Wh (87.1%)
CPU:
Info: 8-core model: AMD Ryzen 7 5800H with Radeon Graphics bits: 64
type: MT MCP cache: L2: 4 MiB
Speed (MHz): avg: 1175 min/max: 400/4463 cores: 1: 1426 2: 400 3: 400
4: 1413 5: 3391 6: 2054 7: 1556 8: 400 9: 1599 10: 400 11: 1514 12: 1430
13: 400 14: 400 15: 1620 16: 400
Graphics:
Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] driver: nvidia
v: 550.78
Device-2: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
driver: amdgpu v: kernel
Device-3: IMC Networks Integrated Camera driver: uvcvideo type: USB
Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 23.2.6 driver: X:
loaded: amdgpu,nvidia unloaded: modesetting,nouveau dri: radeonsi
gpu: amdgpu resolution: 1920x1080~120Hz
API: EGL v: 1.5 drivers: nvidia,radeonsi,swrast
platforms: x11,surfaceless,device
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: amd mesa v: 24.0.6-manjaro1.1
renderer: AMD Radeon Graphics (radeonsi renoir LLVM 17.0.6 DRM 3.54
6.6.30-2-MANJARO)
API: Vulkan v: 1.3.279 drivers: nvidia,radv surfaces: xcb,xlib
Audio:
Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: N/A
Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel
API: ALSA v: k6.6.30-2-MANJARO status: kernel-api
Server-1: PulseAudio v: 17.0 status: active
Network:
Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
driver: r8169
IF: enp2s0 state: down mac: 7c:8a:e1:c4:24:c2
Device-2: MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter
driver: mt7921e
IF: wlo1 state: up mac: 4c:d5:77:aa:9c:ff
IF-ID-1: br-0084ab9b04d4 state: down mac: 02:42:d4:a5:e9:b7
IF-ID-2: br-18c0f4ae620e state: up speed: 10000 Mbps duplex: unknown
mac: 02:42:39:4c:4c:8b
IF-ID-3: br-7c0c7b151640 state: up speed: 10000 Mbps duplex: unknown
mac: 02:42:3a:56:55:d4
IF-ID-4: br-970a6264b604 state: down mac: 02:42:c6:85:e0:39
IF-ID-5: docker0 state: down mac: 02:42:32:58:28:bd
IF-ID-6: veth97592cc state: up speed: 10000 Mbps duplex: full
mac: de:1c:c2:4a:69:5e
IF-ID-7: vetheab5845 state: up speed: 10000 Mbps duplex: full
mac: 5a:e8:9f:25:f7:99
Bluetooth:
Device-1: Foxconn / Hon Hai MediaTek Bluetooth Adapter driver: btusb
type: USB
Report: btmgmt ID: hci0 state: up address: 4C:D5:77:AA:9D:00 bt-v: 5.2
Drives:
Local Storage: total: 1.4 TiB used: 325 GiB (22.7%)
ID-1: /dev/nvme0n1 vendor: SK Hynix model: HFS512GDE9X084N
size: 476.94 GiB
ID-2: /dev/nvme1n1 vendor: AMD Radeon model: R5MP1024G8 size: 953.87 GiB
Partition:
ID-1: / size: 468.09 GiB used: 325 GiB (69.4%) fs: ext4 dev: /dev/nvme0n1p2
ID-2: /boot/efi size: 299.4 MiB used: 316 KiB (0.1%) fs: vfat
dev: /dev/nvme0n1p1
Swap:
ID-1: swap-1 type: file size: 32 GiB used: 0 KiB (0.0%) file: /swapfile
Sensors:
System Temperatures: cpu: 53.6 C mobo: 44.0 C gpu: amdgpu temp: 44.0 C
Fan Speeds (rpm): N/A
Info:
Memory: total: 28 GiB available: 27.26 GiB used: 5.97 GiB (21.9%)
Processes: 384 Uptime: 2h 24m Shell: Zsh inxi: 3.3.34
Блог им. garbagecollection

Plasma 6 в Manjaro KDE

Итак, прилетела обновка. По обыкновению выждал неделю и обновился вчера.

При обновлении потребовалось вручную зачистить файлы в /libs. Также Pacman ругался, что не может найти KRunner5 (удивился, что он вообще у меня есть, я же его сносил...). Отменил обновление КРаннера, потом обнаружил, что он почему-то поставлен из АУР. В остальном всё прошло благополучно, даже всё перезагрузилось ))

При перезагрузке появилась возможность выбрать сеанс в иксах или вяленом. У меня по умолчанию были выбраны иксы.

Из плюсов: пропали тормоза плазмы при старте, которые появились примерно полгода назад. На этом, пожалуй, всё.

Для начала отвалились виджеты: погодный, переключения рабочих столов, стороннее глобальное меню и что-то там ещё. Все панели стали плавающими, у некоторых изменились размеры и позиционирование.
Отвалилась переключалка раскладок вместе с виджетом. После пары перенастроек и перезагрузок заработало, но виджет флаги не показывает, при нажатии мышкой список раскладок не показывает.

Изменился набор иконок… значков, в смысле, для некоторых приложений (например, Дельфина). В системном лотке теперь показываются цветные, а не одноцветные значки. В лотке появилась настройка яркости экрана, но у неё значка вообще нет, вместо неё отображается белый листочек с загнутым уголком (или это он и есть ?).

В некоторых приложениях слетели настройки. Например, шрифт в Кате, сломалась настроенная мозаика в Квине.

А, и опять перетрАхнули все настройки. Добавили левый верхний угол экрана, настроенный на переключение окон и экранов.

В общем, на первый взгляд глобально ничего не упало, есть некоторые мелочи, но они именно что — мелочи.

ЗЫЖ: А кто знает, какому приложению нужен QT5-webkit из АУРа? Пока писал пост прилетело обновление на него.

Добавлю (18.05.2024 23:27) В настройках не видно гейпады, хотя в эмуляторе прекрасно работают.

Добавлю (19.05.2024 15:10) ВНИМАНИЕ! Изменился способ создания контекстных меню в Дельфине! Контекстные меню, созданные в Плазме 5, не работают.
Оформление и Скриншоты

Странный шрифт в Firefox

Не могу никак понять, почему в Firefox Manjaro такой шрифт в панели меню и в панели настроек. Интересно, что такое только в Manjaro. В других дистро Firefox имеет обычный шрифт, без скобок и одиночных заглавных букв. Пытался найти способы убрать эти аномалии, но в и-нете ничего не нашёл. В принципе, никак не мешает, браузер работает нормально, но хотелось бы привести эти надписи к обычному виду.

панель меню

панель настроек