Учебники (How-To & F.A.Q)

Установка и настройка nvidia-xrun

Решил написать свой первый гайд, сильно не пинайте.
Гайд написан для свежеустановленной manjaro с рабочим окружением KDE.
При установке manjaro выбираем проприетарные драйвера. Если система уже стоит, то устанавливаем проприетарные драйвера
sudo mhwd -i pci video-hybrid-intel-nvidia-bumblebee -f
или через mhwd. Читать дальше
Manjaro KDE Edition

Ошибки systemd (не знаю как описать точнее)

Недавно воткнул в ноут ssd и естественно переустанавливал систему. Два дня радовался, а потом заметил кое-что нехорошее

Точный момент когда полезли ошибки я отловить не сумел.
Собственно ошибки можно было и не заметить (поначалу), но меня чёрт дёрнул посмотреть логи:
journalctl -p3 -xb
-- Logs begin at Fri 2019-01-04 02:34:20 MSK, end at Sun 2019-01-06 22:25:04 MSK. --
янв 06 22:09:00 lol kernel: ACPI BIOS Error (bug): Could not resolve [\_SB.PCI0.GFX0.DD02._BCL], AE_NOT_FOUND (20180810/psargs-330)
янв 06 22:09:00 lol kernel: ACPI Error: Method parse/execution failed \_SB.PCI0.PEG0.PEGP.DD02._BCL, AE_NOT_FOUND (20180810/psparse-516)
янв 06 22:09:00 lol kernel: ACPI BIOS Error (bug): Could not resolve [\_SB.PCI0.GFX0.DD02._BCL], AE_NOT_FOUND (20180810/psargs-330)
янв 06 22:09:00 lol kernel: ACPI Error: Method parse/execution failed \_SB.PCI0.PEG0.PEGP.DD02._BCL, AE_NOT_FOUND (20180810/psparse-516)
янв 06 22:25:02 lol systemsettings5[2965]: This application failed to start because no Qt platform plugin could be initialized. Reinstalling the applica>
                                              
                                              Available platform plugins are: wayland-org.kde.kwin.qpa, dxcb, eglfs, linuxfb, minimal, minimalegl, offsc>
янв 06 22:25:02 lol systemd-coredump[2971]: Process 2965 (systemsettings5) of user 1000 dumped core.
                                               
                                               Stack trace of thread 2965:
                                               #0  0x00007eff6c6b2d7f raise (libc.so.6)
                                               #1  0x00007eff6c69d672 abort (libc.so.6)
                                               #2  0x00007eff6ca527fc _ZNK14QMessageLogger5fatalEPKcz (libQt5Core.so.5)
                                               #3  0x00007eff6d0a501a _ZN22QGuiApplicationPrivate25createPlatformIntegrationEv (libQt5Gui.so.5)
                                               #4  0x00007eff6d0a54ce _ZN22QGuiApplicationPrivate21createEventDispatcherEv (libQt5Gui.so.5)
                                               #5  0x00007eff6cc4f705 _ZN23QCoreApplicationPrivate4initEv (libQt5Core.so.5)
                                               #6  0x00007eff6d0a6c50 _ZN22QGuiApplicationPrivate4initEv (libQt5Gui.so.5)
                                               #7  0x00007eff6d6a6b6a _ZN19QApplicationPrivate4initEv (libQt5Widgets.so.5)
                                               #8  0x00005578b45cf66d n/a (systemsettings5)
                                               #9  0x00005578b45cf0ee n/a (systemsettings5)
                                               #10 0x00007eff6c69f223 __libc_start_main (libc.so.6)
                                               #11 0x00005578b45cf4ee _start (systemsettings5)
-- Subject: Процесс 2965 (systemsettings5) сбросил дамп памяти
-- Defined-By: systemd
-- Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- Documentation: man:core(5)
-- 
-- Процесс 2965 (systemsettings5) завершился из-за критической ошибки.
-- Записан дамп памяти.
-- 
-- Вероятно, это произошло из-за ошибки, допущенной в коде программы.
-- Рекомендуется сообщить её разработчикам о возникшей проблеме.



Как выяснилось чуть позже, отрубились некоторые хоткеи (заданные мною лично)

Собственно, лог ошибки выше — это моя попытка открыть настройки с помощью хоткея

Ах да, важное уточнение — конфигурация системы
inxi -v4
System:    Host: lol Kernel: 4.19.13-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: KDE Plasma 5.14.4 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: Hewlett-Packard product: HP ENVY 15 Notebook PC v: 0888100000305B00000310100 
           serial: <root required> 
           Mobo: Hewlett-Packard model: 1963 v: KBC Version 93.23 serial: <root required> UEFI: Insyde v: F.11 
           date: 04/19/2013 
Battery:   ID-1: BAT0 charge: 43.1 Wh condition: 43.1/43.1 Wh (100%) model: Hewlett-Packard Primary status: Full 
CPU:       Topology: Quad Core model: Intel Core i7-4700MQ bits: 64 type: MT MCP arch: Haswell rev: 3 L2 cache: 6144 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 38324 
           Speed: 2390 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 2390 2: 3226 3: 2474 4: 2469 5: 2431 6: 3105 7: 2402 
           8: 2483 
Graphics:  Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: Hewlett-Packard driver: i915 v: kernel 
           bus ID: 00:02.0 
           Device-2: NVIDIA GK208M [GeForce GT 740M] driver: N/A bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.3 driver: intel resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 18.3.1 direct render: Yes 
Network:   Device-1: Intel Centrino Wireless-N 2230 driver: iwlwifi v: kernel port: 6040 bus ID: 08:00.0 
           IF: wlo1 state: up mac: 68:17:29:37:3a:89 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: r8168 
           v: 8.045.08-NAPI port: 3000 bus ID: 0f:00.0 
           IF: eno1 state: down mac: 2c:44:fd:ae:40:62 
Drives:    Local Storage: total: 447.13 GiB used: 47.40 GiB (10.6%) 
           ID-1: /dev/sda vendor: Kingston model: SA400S37480G size: 447.13 GiB 
Partition: ID-1: / size: 66.79 GiB used: 33.85 GiB (50.7%) fs: ext4 dev: /dev/sda5 
           ID-2: /home size: 97.66 GiB used: 13.53 GiB (13.9%) fs: btrfs dev: /dev/sda6 
Info:      Processes: 292 Uptime: 31m Memory: 11.51 GiB used: 1.24 GiB (10.8%) Init: systemd Compilers: gcc: 8.2.1 Shell: zsh 
           v: 5.6.2 inxi: 3.0.28 


В чём ошибка понять не могу, переустановить всегда успею
P.S.: Появляются ошибки не сразу, а только через минут 5-10 (опять же зависимости от конкретного приложения или таймера нет)
Manjaro KDE Edition

Не стартует KDE на ядре 4.19.4-1

Добрый день! Столкнулся с проблемой. Работаю на ядре 4.14.83-1 решил перейти на ядро 4.19.4-1, загрузка доходит до экрана ввода пароля, ввожу пароль загружается обоина раб.стола и все дальше kde не загружается нет ни виджетов и курсора мыши. Загружаю на ядре 4.14.83-1 все хорошо. Что можно сделать? И еще второй вопрос имею два монитора, но при старте системы каждый раз меняется приоритетный монитор, хотя в параметрах системы установлен монитор по умолчанию
UPD: не судите строго не смог выделить самое важное поэтому вот полные логи с момента старта на ядре 4.19.4-1 (так как текст большой разместил на внешнем ресурсе)
journalctl
Xorg
Manjaro KDE Edition

Manjaro 18 kde telegram tray не отображается

Раньше я пользовался manjaro 17 kde (теперь 18) и проблем с треем телеграмма небыло, я обновился и теперь он (трей телеграмма) не работает (просто не отображаеться), при этом трей всех остальных приложений работает (например jetbrains toolbox), но если запустить телеграм из под root, все работает.

В чем может быть проблема, и как ее можно исправить?
Manjaro KDE Edition

Как вводить японские иероглифы в KDE (manjaro Linux)?

Японисты арчеводы кдешники, есть ли вы здесь?

Не могу настроить японский ввод в KDE в Manjaro Linux. Язык добавить могу, и всё. либо вводятся латинские буквы, либо катакана. А мне нужно, чтобы при вводе ромадзи (латиницей) по пробелу (как это было в венде) ввод преобразовывался в катакану/хирагану и кандзи. Для иероглифов с одинаковым звучанием была проверка по словарю, и выбор вариантов из списка.

Желательно настройка штатными методами, KDE вроде очень мощная система, в ней должна быть нормальная поддержка ввода.
Уголок новичка

Kernel Panic, после обновления системы.

Manjaro KDE.

После установки вчерашних обновлений, система больше не запускается. Во время загрузки возникает следующая ошибка: Kernel panic — not syncing: No working init found.

Весь день пытался разобраться с этой проблемой, но без особого успеха. Что успел попробовать: переустановил GRUB; под chroot переустановил udev, mkinitcpio, текущее ядро (linux419). Пробовал под chroot установить другие ядра: 414, 416, 418. Со всеми ядрами ошибка повторяется: Kernel panic — not syncing: No working init found.

Есть ли решение? Очень не охота ставить систему с ноля. До этого работала больше двух лет, без проблем.

pacman.log
[2018-10-25 03:33] [PACMAN] Running '/usr/bin/pacman -Sy'
[2018-10-25 03:33] [PACMAN] synchronizing package lists
[2018-10-25 03:34] [PACMAN] Running 'pacman -Su --noconfirm'
[2018-10-25 03:34] [PACMAN] starting full system upgrade
[2018-10-25 03:34] [ALPM] running '70-dkms-remove.hook'…
[2018-10-25 03:34] [ALPM] transaction started
[2018-10-25 03:34] [ALPM] upgraded tzdata (2018e-2 -> 2018f-2)
[2018-10-25 03:34] [ALPM] upgraded cairo (1.15.14-1 -> 1.16.0-1)
[2018-10-25 03:34] [ALPM] upgraded gtk-update-icon-cache (3.24.1+8+g220f77d8c1-1 -> 3.24.1+33+g615fa7cfb6-0)
[2018-10-25 03:34] [ALPM] upgraded mhwd-db (0.6.3-3 -> 0.6.3-4)
[2018-10-25 03:34] [ALPM] upgraded gtk3 (3.24.1+8+g220f77d8c1-1 -> 3.24.1+33+g615fa7cfb6-0)
[2018-10-25 03:34] [ALPM] upgraded electron (2.0.11-1 -> 2.0.12-1)
[2018-10-25 03:34] [ALPM] upgraded firefox-kde-opensuse (62.0.3-0 -> 63.0-1)
[2018-10-25 03:34] [ALPM] upgraded grub (2.03.0-8 -> 2.03.0-9)
[2018-10-25 03:34] [ALPM] upgraded linux419 (4.19rc8.1019.gc7b70a6-1 -> 4.19rc8.1021.g23469de-1)
[2018-10-25 03:34] [ALPM] upgraded linux419-headers (4.19rc8.1019.gc7b70a6-1 -> 4.19rc8.1021.g23469de-1)
[2018-10-25 03:34] [ALPM] upgraded linux419-nvidia (1:410.66-0.26 -> 1:410.66-0.27)
[2018-10-25 03:34] [ALPM] upgraded linux419-virtualbox-host-modules (5.2.20-0.26 -> 5.2.20-0.27)
[2018-10-25 03:34] [ALPM-SCRIPTLET] In order to use the new version, reload all virtualbox modules manually.
[2018-10-25 03:34] [ALPM] upgraded openssh (7.8p1-1 -> 7.9p1-1)
[2018-10-25 03:34] [ALPM] upgraded rust (1:1.29.0-2 -> 1:1.29.1-1)
[2018-10-25 03:34] [ALPM] transaction completed
[2018-10-25 03:34] [ALPM] running '60-linux419.hook'…
[2018-10-25 03:34] [ALPM] running '70-dkms-install.hook'…
[2018-10-25 03:34] [ALPM] running '90-linux419.hook'…
[2018-10-25 03:34] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux419.preset: 'default'
[2018-10-25 03:34] [ALPM-SCRIPTLET] -> -k /boot/vmlinuz-4.19-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.19-x86_64.img
[2018-10-25 03:34] [ALPM-SCRIPTLET] ==> Starting build: 4.19.0-1-MANJARO
[2018-10-25 03:34] [ALPM-SCRIPTLET] -> Running build hook: [base]
[2018-10-25 03:34] [ALPM-SCRIPTLET] -> Running build hook: [udev]
[2018-10-25 03:34] [ALPM-SCRIPTLET] -> Running build hook: [autodetect]
[2018-10-25 03:34] [ALPM-SCRIPTLET] -> Running build hook: [modconf]
[2018-10-25 03:34] [ALPM-SCRIPTLET] -> Running build hook: [block]
[2018-10-25 03:34] [ALPM-SCRIPTLET] -> Running build hook: [keyboard]
[2018-10-25 03:34] [ALPM-SCRIPTLET] -> Running build hook: [keymap]
[2018-10-25 03:34] [ALPM-SCRIPTLET] -> Running build hook: [filesystems]
[2018-10-25 03:34] [ALPM-SCRIPTLET] -> Running build hook: [fsck]
[2018-10-25 03:34] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2018-10-25 03:34] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.19-x86_64.img
[2018-10-25 03:34] [ALPM-SCRIPTLET] ==> Image generation successful
[2018-10-25 03:34] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux419.preset: 'fallback'
[2018-10-25 03:34] [ALPM-SCRIPTLET] -> -k /boot/vmlinuz-4.19-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.19-x86_64-fallback.img -S autodetect
[2018-10-25 03:34] [ALPM-SCRIPTLET] ==> Starting build: 4.19.0-1-MANJARO
[2018-10-25 03:34] [ALPM-SCRIPTLET] -> Running build hook: [base]
[2018-10-25 03:34] [ALPM-SCRIPTLET] -> Running build hook: [udev]
[2018-10-25 03:34] [ALPM-SCRIPTLET] -> Running build hook: [modconf]
[2018-10-25 03:34] [ALPM-SCRIPTLET] -> Running build hook: [block]
[2018-10-25 03:34] [ALPM-SCRIPTLET] -> Running build hook: [keyboard]
[2018-10-25 03:34] [ALPM-SCRIPTLET] -> Running build hook: [keymap]
[2018-10-25 03:34] [ALPM-SCRIPTLET] -> Running build hook: [filesystems]
[2018-10-25 03:34] [ALPM-SCRIPTLET] -> Running build hook: [fsck]
[2018-10-25 03:34] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2018-10-25 03:34] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.19-x86_64-fallback.img
[2018-10-25 03:34] [ALPM-SCRIPTLET] ==> Image generation successful
[2018-10-25 03:34] [ALPM] running '99-grub.hook'…
[2018-10-25 03:34] [ALPM-SCRIPTLET] Generating grub configuration file…
[2018-10-25 03:34] [ALPM-SCRIPTLET] Found background: /usr/share/grub/background.png
[2018-10-25 03:34] [ALPM-SCRIPTLET] Found linux image: /boot/vmlinuz-4.19-x86_64
[2018-10-25 03:34] [ALPM-SCRIPTLET] Found initrd image: /boot/intel-ucode.img /boot/initramfs-4.19-x86_64.img
[2018-10-25 03:34] [ALPM-SCRIPTLET] Found initrd fallback image: /boot/initramfs-4.19-x86_64-fallback.img
[2018-10-25 03:35] [ALPM-SCRIPTLET] Found Windows 10 on /dev/sdg1
[2018-10-25 03:35] [ALPM-SCRIPTLET] Found memtest86+ image: /boot/memtest86+/memtest.bin
[2018-10-25 03:35] [ALPM-SCRIPTLET] done
[2018-10-25 03:35] [ALPM] running 'glib-compile-schemas.hook'…
[2018-10-25 03:35] [ALPM] running 'gtk-query-immodules-3.0.hook'…
[2018-10-25 03:35] [ALPM] running 'gtk-update-icon-cache.hook'…
[2018-10-25 03:35] [ALPM] running 'systemd-daemon-reload.hook'…
[2018-10-25 03:35] [ALPM] running 'systemd-tmpfiles.hook'…
[2018-10-25 03:35] [ALPM] running 'systemd-update.hook'…
[2018-10-25 03:35] [ALPM] running 'texinfo-install.hook'…
[2018-10-25 03:35] [ALPM] running 'update-desktop-database.hook'…