Manjaro KDE Edition

Тормозит интерфейс при отключении дисплея ноутбука

Добрый день! Подключаю к ноутбуку 1 или 2 внешних монитора. Вхожу в учётную запись пользователя. Всё работает нормально, изображение на мониторе ноутбука и на внешних. Но если я в настройках отключаю показ изображения на встроенном дисплее ноутбука, или просто закрываю крышку ноутбука, то интерфейс начинает очень сильно тормозить. Можете подсказать в каком направлении копать, чтобы найти как это исправить?
Уголок новичка

[решено]Звук с динамиков проигрывается с порта с наушниками

Каждый раз при включении приходится переключать порт со Speaker на Headphones в настройках kde. Связано это с тем, что звук с динамиков проигрывается только если поставить порт Headphones. Пробовал мапить порты через hdajackretask, но он выдает ошибку «tee: /sys/class/sound/hwC0D0/reconfig».
Manjaro KDE Edition

Не удаётся восстановить ОС из гибернации (РЕШЕНО)

Добрый день! Прошу подсказать как настроить гибернацию в Manjaro KDE.

У ноутбука 16 GB оперативки. После создания swap на 20GB появилась кнопка гибернации. Когда нажимаю эту кнопку (или выполняю в консоли команду systemctl hibernate) система как будто уходит в гибернацию. Питание полностью отключает. Однако потом при запуске вход в учётку пользователя осуществляется как будто заново. И никакие из открытых на момент запуска гибернации приложений не появляются.

Пробовал установить pm-utils 1.4.1-8 из AUR с помощью pamac.

Нужно ли куда-то прописывать swap_device_uuid и/или править конфиг GRUB?
(На ноуте dual boot, и при включении сначала выбираю manjaro из списка)

Вывод команды swapon сейчас такой:
NAME TYPE SIZE USED PRIO
/swapfile file 20G 0B -2

htop показывает, что при заполнении оперативки swap используется.

Заранее благодарен за советы!

Система такая:
Manjaro Linux 23.0.4 Uranos

KDE Plasma 5.27.8
KDE Frameworks 5.110.0
Qt Version 5.15.11
Kernel Version 6.1.55-1-MANJARO (64-bit)
Graphics Platform X11

Hardware:
Processors: 12 × Intel® Core™ i7-9750H CPU @ 2.60GHz
Memory: 15,4 GiB of RAM
Graphics processor: Mesa Intel® UHD Graphics 630
Manufacturer: Dell Inc.
SSD: XPG Gammix S11 Pro 1.9 TiB
Manjaro KDE Edition

Внезапно перестала работать встроенная камера

Сижу на Manjaro KDE и где то три месяца назад после обновления перестала работать встроенная камера на ноутбуке Lenovo IdeaPad S340-14API. Уже много что перепробовал но результата ноль. Может кто-нибудь знающий поможет?
На самом деле проблем много, но эта сейчас у меня в приоритете т.к. учусь на дистанционке и нужен Zoom.
Уголок новичка

Не отображаются файлы на раб. столе + не запускаются приложения

Всем привет. Случилась неприятность: на рабочем столе перестали отображаться файлы и каталоги находящиеся в нём. Кнопка «Создать» в контекстном меню неактивна. Помимо этого, из главного меню и панели задач не запускаются никакие приложения. При запуске иконка появляется, «крутится» как при загрузке и благополучно гаснет обратно. Но, при этом, например, Pamac не запускается из главного меню, но работает с панели задач и из трея. Программы остаются доступны из консоли, файлы каталоги на рабочем столе видны с помощью «ls».
Из настроек доступно только то, что «по правому клику» на раб. столе — т.е. «Рабочий стол и обои» и «Параметры экрана». Окружение — KDE. Сам новичок, что делать — не понимаю.
Подробнее как поймал ошибку: спасал с полумёртвого HDD файлы. ~23к файлов, объёмом 50-60 Гб. Закинул для удобства на рабочий стол, а после перезагрузки вылезли эти симптомы. Файлы убрал вообще на другой жёсткий, сейчас их на рабочем столе нет. Убирал «перемещением» через Dolphin.
Гугление, по факту, дало только один способ решения проблемы — очистить /home/user/.cache/. Это было сделано, но результатов не дало. Прошу помощи.
Manjaro KDE Edition

Не удаётся подключиться к VPN

Добрый день!
Прошу дать совет по настройке VPN-соединения с помощью пользовательского интерфейса ОС.
Я могу подключиться из консоли командой типа такой(все значения ниже заменены на значения типа MyObject):
sudo openconnect MyVPNAddress

или
echo "MyPassword" | openconnect MyVPNAddress --servercert pin-sha256:MyServerCert --authgroup MyServerGroup -u MyUsername --passwd-on-stdin

Также удаётся подключиться из Windows 10 с помощью клиента Cisco AnyConnect Secure Mobility Client.
Но не удаётся подключиться с помощью графического интерфейса Manjaro. Я попробовал несколько вариантов. Например, если я использую vpnc без GroupPassword,
Manjaro KDE Edition: Не удаётся подключиться к VPN
он не подключается и возвращает в лог:
GDBus.Error:org.freedesktop.NetworkManager.VPN.Error.InvalidConnection: The request could not be processed because the requested “IPSec secret” information was not provided.
(Логи смотрю командой journalctl -f _COMM=NetworkManager)
Если я указываю GroupPassword то он отображает, что подключился, но веб-сайты недоступны и через 30 секунд отключается с сообщением
dbus: failure: connect-failed
Так же пробовал другие типы подключений — безуспешно. В списке VPN подключений у меня есть такие типы:
  • Array Networks Compatible VPN (openconnect)
  • Cisco AnyConnect Compatible VPN (openconnect)
  • F5 BIG_IP Compatible VPN (openconnect)
  • Fortinet Compatible VPN (openconnect)
  • Pulse Connect Secure (openconnect)
Manjaro KDE Edition: Не удаётся подключиться к VPN
Нужно ли мне использовать что-то из них, или установить какое-то другое?

У меня установлено:
  • Manjaro 22.0.5 Sikaris
  • KDE Plasma 5.26.5
  • KDE Frameworks 5.103.0
  • Qt Version 5.15.8
  • Kernel Version 5.15.102-1-MANJARO (64-bit)
  • Graphics Platform X11

Заранее благодарен за советы!

UPD. Удалось подключиться. Осталось разобраться как сохранить пароль, чтобы не приходилось его каждый раз вводить.
manjaro.ru/comments/33405
Уголок новичка

Подтормаживает графика Manjaro 22.0.0 KDE

Доброго времени!
Поставил Manjaro 22.0.0 KDE, стоят проприетарные драйвера на видео, конфиг следующий: i3-8100, 16Gb RAM, GTX 1660 Super 6Gb. Поставил пару игр, liftoff и Pine, во время игры возникают статтеры и микрофризы, при чем без разницы какие настройки графики стоят, максимальные или минимальные. Те же игры, когда устанавливал под Ubuntu таких нюансов не имели. Есть периодические подлагивания в интерфейсе KDE. Может кто сталкивался и есть решение?
Благодарю за внимание.
Уголок новичка

Не завершаются пользовательские процессы при завершении сеанса Manjaro KDE

У меня в автозапуске находится jar`ник с телеграм-ботом.
Проблема в том, что при завершении сеанса он продолжает работать, а при следующем логине срабатывает автозапуск и запускается второй экземпляр этого jar`ника. При третьем заходе, соответственно третий, потом чертвертый и т.д.
Мне нужно, чтобы при выполнении хоткея «Завершить сеанс без подтверждения» происходило то же, что при pkil -9 -username. Как это реализовать? Прописать pkil -9 -username в параметры выхода не вариант — перестаёт работать выключение и перезагрузка по хоткею, а мне они нужны.
Manjaro KDE Edition

Dolphin: Файл или папка smb://...local/ не существует

Здравствуйте! Не получается подключиться к виндоус10 машине по SMB2-3. Сделал всё как здесь: Dolphin — KDE/plasma
pamac install samba kdenetwork-filesharing manjaro-settings-samba
с учетом, что у меня KDE и Dolphin (pamac install gvfs-smb не нужен для установки). Однако Dolphin выдаёт сообщение об ошибке при попытке подключения в виндовой машине. Как оказалось, для SMB2-3 нужен avahi. Для подключения к винде, использование SMB1 там не планирую, отключил, на машине с Win10 оставил только Службу SMB Direct. Avahi запустил,

sudo systemctl enable avahi-daemon
sudo systemctl start avahi-daemon
sudo systemctl status avahi-daemon                                                             ✔  49m 43s  
● avahi-daemon.service - Avahi mDNS/DNS-SD Stack
     Loaded: loaded (/usr/lib/systemd/system/avahi-daemon.service; enabled; preset: disabled)
     Active: active (running) since Wed 2022-07-27 08:49:39 MSK; 4h 42min ago
TriggeredBy: ● avahi-daemon.socket
   Main PID: 301 (avahi-daemon)
     Status: "avahi-daemon 0.8 starting up."
      Tasks: 2 (limit: 4643)
     Memory: 1.4M
        CPU: 234ms
     CGroup: /system.slice/avahi-daemon.service
             ├─301 "avahi-daemon: running [user-plasma.local]"
             └─307 "avahi-daemon: chroot helper"

июл 27 08:49:39 user-plasma avahi-daemon[301]: Network interface enumeration completed.
июл 27 08:49:39 user-plasma avahi-daemon[301]: Registering new address record for ::1 on lo.*.
июл 27 08:49:39 user-plasma avahi-daemon[301]: Registering new address record for 127.0.0.1 on lo.IPv4.
июл 27 08:49:40 user-plasma avahi-daemon[301]: Server startup complete. Host name is user-plasma.local. Local service cooki>
июл 27 08:49:47 user-plasma avahi-daemon[301]: Joining mDNS multicast group on interface enp1s0.IPv4 with address 192.168.>
июл 27 08:49:47 user-plasma avahi-daemon[301]: New relevant interface enp1s0.IPv4 for mDNS.
июл 27 08:49:47 user-plasma avahi-daemon[301]: Registering new address record for 192.168.14.15 on enp1s0.IPv4.
июл 27 08:49:47 user-plasma avahi-daemon[301]: Joining mDNS multicast group on interface enp1s0.IPv6 with address fe80::19>
июл 27 08:49:47 user-plasma avahi-daemon[301]: New relevant interface enp1s0.IPv6 for mDNS.
июл 27 08:49:47 user-plasma avahi-daemon[301]: Registering new address record for fe80::1958:41ef:bffa:d119 on enp1s0.*.
lines 1-23/23 (END)

avahi-browse --all
+ enp1s0 IPv6 USER-PLASMA                                    Device Info          local
+ enp1s0 IPv4 USER-PLASMA                                    Device Info          local
+     lo IPv4 USER-PLASMA                                    Device Info          local
+ enp1s0 IPv6 USER-PLASMA                                    Microsoft Windows Network local
+ enp1s0 IPv4 USER-PLASMA                                    Microsoft Windows Network local
+     lo IPv4 USER-PLASMA                                    Microsoft Windows Network local
+ enp1s0 IPv6 HP LaserJet .....................             _scanner._tcp        local
+ enp1s0 IPv4 HP LaserJet .....................             _scanner._tcp        local
+ enp1s0 IPv6 HP LaserJet .....................             UNIX Printer         local
+ enp1s0 IPv4 HP LaserJet .....................             UNIX Printer         local
+ enp1s0 IPv4 HP LaserJet .....................             UNIX Printer         local
+ enp1s0 IPv6 HP LaserJet .....................             PDL Printer          local
+ enp1s0 IPv4 HP LaserJet .....................             PDL Printer          local
+ enp1s0 IPv4 HP LaserJet .....................             PDL Printer          local
+ enp1s0 IPv6 HP LaserJet .....................             Internet Printer     local
+ enp1s0 IPv4 HP LaserJet .....................             Internet Printer     local
+ enp1s0 IPv4 HP LaserJet .....................             Internet Printer     local
+ enp1s0 IPv6 HP LaserJet .....................             _print-caps._tcp     local
+ enp1s0 IPv4 HP LaserJet .....................             _print-caps._tcp     local
+ enp1s0 IPv6 HP LaserJet .....................             _http-alt._tcp       local
+ enp1s0 IPv4 HP LaserJet .....................             _http-alt._tcp       local
+ enp1s0 IPv6 HP LaserJet .....................             Web Site             local
+ enp1s0 IPv4 HP LaserJet .....................             Web Site             local
+ enp1s0 IPv4 HP LaserJet .....................             Web Site             local
+ enp1s0 IPv4 Canon ...........................             Web Site             local
+ enp1s0 IPv4 Canon ...........................             Internet Printer     local
+ enp1s0 IPv4 Canon ...........................             PDL Printer          local
+ enp1s0 IPv4 Canon ...........................             UNIX Printer         local
+ enp1s0 IPv4 Canon ...........................             _scanner._tcp        local
но ошибка не ушла. Подключения нет. Avahi видит только интерфейсы собственно своей KDE-машины и несколько сетевых устройств, виндовую же машину — нет, а Dolphin видит, но при этом при подключении к Win10 выдаёт то же сообщение:
Файл или папка smb://...local/ не существует
С виндой 10-ой проблем нет. Её прекрасно через окно доступа открывает машина с Win7 по SMB2-3 (используя только Службу SMB Direct). Как решить проблему? — найти не смог, к сожалению? Очевидно, что «гол» на нашей линуксоидной стороне)), а SMB1 в локальной сети с выходом в И-нет предпочитаю не использовать ввиду его низкого уровня безопасности. Возможно надо копатьcя в настройках avahi на арч-вики...?
sudo systemctl status systemd-resolved.service                                                                                                                                                                    
○ systemd-resolved.service - Network Name Resolution
     Loaded: loaded (/usr/lib/systemd/system/systemd-resolved.service; disabled; preset: enabled)
     Active: inactive (dead)
       Docs: man:systemd-resolved.service(8)
             man:org.freedesktop.resolve1(5)
             https://www.freedesktop.org/wiki/Software/systemd/writing-network-configuration-managers
             https://www.freedesktop.org/wiki/Software/systemd/writing-resolver-clients
systemd-resolved.service как и требуется отключен!
Или здесь… на их родном сайте?
Пока ничего не нашел. Кто-то может знает решение?
Ура, сам нашел!
[РЕШЕНО]Оказывается, вы не подключаетесь к своему общему ресурсу SMB в Dolphin — вам нужно настроить его через конфигурацию системы Manjaro.

Перейдите в «Настройки системы» → «Сеть» → «Настройки» → «Общие ресурсы Windows» и введите свое имя пользователя/PS.

Это решило мою проблему. Я признаю, что если у вас есть несколько общих ресурсов SMB с разными учетными данными, я не знаю, что вы будете делать. Но если он у вас есть, вышеизложенное работает. forum.manjaro.org/t/samba-unable-to-login-with-dolphin/65710/6

К сожалению, но это решение помогло не на долго. Вскоре при попытке зайти по сети на машину с Win10 опять та же ошибка Dolphin: Файл или папка smb://...local/ не существует!

Перед тем как всё опять сломалось появилось неожиданно впервые окно ввода имени пользователя и пароля. Ввел имя и пароль — успешно зашел на машину c вин.10 и вышел. При повторной попытке ошибка Dolphin: Файл или папка smb://...local/ не существует!