Manjaro KDE Edition

При установке пропhитарных драйверов Nvidia - черный экран

При последнем обновлении мне выдало ошибку — конфликт зависимостей связаный с обновлением видео драйвера (Видеокарта у меня GTX 750) и обновление не происходило. Тогда я установил всё кроме того что связано с Nvidia и процес пошол. После этого по очереди я обновлял компоненты Nvidia и увидел что ошибка про зависимости (к сожалению не сберёг описание) выдает при обновлении Cuda. Но так как это был последний компонент обновы то после предупреждение о зависимостях почему то обновление пошло дальше. В результате после перезагрузки получил черный экран.
С помощью этого сообщества я нашел похожую тему и потом с помощью команды mhwd -r pci video-nvidia я удалил драйвер и комп загрузился со свободным драйвером. Теперь я не могу поставить пропhитарный драйвер так как получаю либо ошибку установки либо (ставится только 340) снова черный экран. Пробовал удалить через менеджер приложений Cuda — ничего не меняется
Кто знает как установить закрытый драйвер?


Решено удалением Cuda и драйверов nvidia, а потом заново установил последний драйвер (450)
Manjaro KDE Edition

[Решено] Проблема с Pulseaudio

Захотелось попробовать виджет-визуализатор аудио — Panon.
Очень понравился, вот только звук он принимал исключительно с микрофона — какой бы источник аудио я не выбирал.
скрин
Manjaro KDE Edition: Проблема с Pulseaudio

Покопавшись в этих ваших ынтернетах, я немного разобрался в работе pulseaudio. Выходит так, что микрофон у меня стоял устройством по умолчанию
pacmd stat
Manjaro KDE Edition: Проблема с Pulseaudio

Вот только в Panon'е я не выбирал 'default', я выбирал конкретное устройство.
Выполнив
pacmd set-default-source alsa_output.usb-C-Media_Electronics_Inc._USB_Audio_Device-00.analog-stereo.monitor
я установил по умолчанию звук с наушников. Panon заработал как я хотел, вот только проверив микрофон в дискорде, я обнаружил ту же проблему: выбранное устройство просто игнорируется, вместо него используется то, что в пульсе выставлено по умолчанию.
Поставил микрофон обратно дефолтным.
Выполнил
pacmd set-log-level 4
в настройках Panon выбрал наушники, вот фрагмент лога:
лог
[pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Core1.Stream removed from object /org/pulseaudio/core1/record_stream122
D: [pulseaudio] source.c: PulseEffects_mic.monitor: state: RUNNING -> IDLE
I: [pulseaudio] source-output.c: Freeing output 122 "outputstream"
D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Core1.Client removed from object /org/pulseaudio/core1/client451
I: [pulseaudio] client.c: Freed 451 "Panon"
I: [pulseaudio] protocol-native.c: Connection died.
I: [pulseaudio] client.c: Created 454 "Native client (UNIX socket client)"
D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Core1.Client added for object /org/pulseaudio/core1/client454
D: [pulseaudio] protocol-native.c: Protocol version: remote 33, local 33
I: [pulseaudio] protocol-native.c: Got credentials: uid=1000 gid=1001 success=1
D: [pulseaudio] protocol-native.c: SHM possible: yes
D: [pulseaudio] protocol-native.c: Negotiated SHM: yes
D: [pulseaudio] protocol-native.c: Memfd possible: yes
D: [pulseaudio] protocol-native.c: Negotiated SHM type: shared memfd
D: [pulseaudio] log.c: Invalid UTF-8 string following below:
D: [pulseaudio] memblock.c: Using shared memfd memory pool with 1024 slots of size 64,0 Ки� each, total size is 64,0 Ми�, maximum usable slot size is 65472
D: [pulseaudio] srbchannel.c: SHM block is 65472 bytes, ringbuffer capacity is 2 * 32712 bytes
D: [pulseaudio] protocol-native.c: Enabling srbchannel...
D: [pulseaudio] module-augment-properties.c: Looking for .desktop file for python3.8
D: [pulseaudio] protocol-native.c: Client enabled srbchannel.
D: [pulseaudio] module-augment-properties.c: Looking for .desktop file for python3.8
D: [pulseaudio] module-intended-roles.c: Not setting device for stream outputstream, because already set.
D: [pulseaudio] source-output.c: Negotiated format: pcm, format.sample_format = "\"float32le\""  format.rate = "44100"  format.channels = "2"  format.channel_map = "\"front-left,front-right\""
I: [pulseaudio] source-output.c: Trying to change sample spec
I: [pulseaudio] source.c: Cannot update sample spec, this is a monitor source and the sink is running.
D: [pulseaudio] module-suspend-on-idle.c: Sink alsa_output.usb-C-Media_Electronics_Inc._USB_Audio_Device-00.analog-stereo becomes busy, resuming.
I: [pulseaudio] resampler.c: Forcing resampler 'copy', because of fixed, identical sample rates.
D: [pulseaudio] resampler.c: Resampler:
D: [pulseaudio] resampler.c:   rate 44100 -> 44100 (method copy)
D: [pulseaudio] resampler.c:   format s16le -> float32le (intermediate s16le)
D: [pulseaudio] resampler.c:   channels 2 -> 2 (resampling 2)
D: [pulseaudio] memblockq.c: memblockq requested: maxlength=33554432, tlength=0, base=4, prebuf=0, minreq=1 maxrewind=0
D: [pulseaudio] memblockq.c: memblockq sanitized: maxlength=33554432, tlength=33554432, base=4, prebuf=0, minreq=4 maxrewind=0
I: [pulseaudio] source-output.c: Created output 123 "outputstream" on alsa_output.usb-C-Media_Electronics_Inc._USB_Audio_Device-00.analog-stereo.monitor with sample spec float32le 2-канальный  and channel map front-left,front-right
I: [pulseaudio] source-output.c:     media.name = "outputstream"
I: [pulseaudio] source-output.c:     application.name = "Panon"
I: [pulseaudio] source-output.c:     native-protocol.peer = "UNIX socket client"
I: [pulseaudio] source-output.c:     native-protocol.version = "33"
I: [pulseaudio] source-output.c:     application.process.id = "20413"
I: [pulseaudio] source-output.c:     application.process.user = "android7890"
I: [pulseaudio] source-output.c:     application.process.host = "komputator"
I: [pulseaudio] source-output.c:     application.process.binary = "python3.8"
I: [pulseaudio] source-output.c:     application.language = "C"
I: [pulseaudio] source-output.c:     window.x11.display = ":0"
I: [pulseaudio] source-output.c:     application.process.machine_id = "59e7fb215cdb44bc8a90c15322348986"
I: [pulseaudio] source-output.c:     application.process.session_id = "1"
I: [pulseaudio] source-output.c:     module-stream-restore.id = "source-output-by-application-name:Panon"
D: [pulseaudio] memblockq.c: memblockq requested: maxlength=4194304, tlength=0, base=8, prebuf=1, minreq=0 maxrewind=0
D: [pulseaudio] memblockq.c: memblockq sanitized: maxlength=4194304, tlength=4194304, base=8, prebuf=8, minreq=8 maxrewind=0
I: [pulseaudio] protocol-native.c: Final latency 51,99 ms = 25,99 ms + 26,00 ms
D: [alsa-sink-USB Audio] alsa-sink.c: Latency set to 26,00ms
D: [alsa-sink-USB Audio] alsa-sink.c: hwbuf_unused=348216
D: [alsa-sink-USB Audio] alsa-sink.c: setting avail_min=87848
D: [alsa-sink-USB Audio] alsa-sink.c: Latency set to 26,00ms
D: [alsa-sink-USB Audio] alsa-sink.c: hwbuf_unused=348216
D: [alsa-sink-USB Audio] alsa-sink.c: setting avail_min=87848
D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Core1.Stream added for object /org/pulseaudio/core1/record_stream123
D: [pulseaudio] source.c: alsa_output.usb-C-Media_Electronics_Inc._USB_Audio_Device-00.analog-stereo.monitor: state: IDLE -> RUNNING
D: [pulseaudio] source-output.c: Starting to move source output 123 from 'alsa_output.usb-C-Media_Electronics_Inc._USB_Audio_Device-00.analog-stereo.monitor'
D: [alsa-sink-USB Audio] alsa-sink.c: Latency set to 26,00ms
D: [alsa-sink-USB Audio] alsa-sink.c: hwbuf_unused=348216
D: [alsa-sink-USB Audio] alsa-sink.c: setting avail_min=87848
D: [pulseaudio] source.c: alsa_output.usb-C-Media_Electronics_Inc._USB_Audio_Device-00.analog-stereo.monitor: state: RUNNING -> IDLE
I: [pulseaudio] source-output.c: Trying to change sample spec
I: [pulseaudio] source.c: Cannot update sample spec, this is a monitor source and the sink is running.
D: [pulseaudio] source.c: PulseEffects_mic.monitor: state: IDLE -> RUNNING
D: [pulseaudio] source-output.c: Successfully moved source output 123 to PulseEffects_mic.monitor.
D: [pulseaudio] module-suspend-on-idle.c: Sink PulseEffects_mic becomes busy, resuming.



Проблема решилась, когда потыкал настройки PulseEffects:
скрин
Manjaro KDE Edition: настройки PulseEffects

Теперь микрофон может спокойно оставаться устройством по умолчанию, остальные источники звука работают как должны и в дискорде не слышно звуков системы
Manjaro KDE Edition

Не работает Bluetooth на чипе rt3290

Крч, проблема в том что модуль ядра rt2800.pci видит только wifi, а с блютус наотрез отказывается работать, перепробовал все танцы с бубном описанные 5-6 лет назад, системный монитор адаптер видит но дрова на него ставить отказывается, вручную ставил rtbth-dkms через pamac пишет ошибку:
Настройка rtbth-dkms…
Error! The module/version combo: rtbth-3.9.6
Ошибка при настройке
is not located in the DKMS tree.
Ошибка: не удалось корректно выполнить команду
Переустановка rtbth-dkms (3.9.6-1)…
Error! Could not find module source directory.
Ошибка при настройке
Directory: /usr/src/rtbth-3.9.6 does not exist.
Ошибка: не удалось корректно выполнить команду
Работа обработчиков post-transaction…
Arming ConditionNeedsUpdate…
Install DKMS modules
==> Unable to install module rtbth-dkms/3.9.6 for kernel 5.8.6-1-MANJARO: Missing kernel headers.
==> Unable to install module rtbth-dkms/3.9.6 for kernel 5.4.64-1-MANJARO: Missing kernel headers.
Транзакция успешно завершена.

через консоль я хз как ставить ибо что не пиши то команда не найдена, то цель не найдена, вобщем не любит она рукожопых линуксоидов но блютус мне нужен так что не сдаемся, вобщем мне надо насильно впихнуть дрова в блютус и чтоб система не сопротивлялась этому, а ещ я немогу никак заставить систему что-то добавлять в корневой раздел типо конфигов и тд, хотя в системе сижу как администратор.
Manjaro KDE Edition

конфликт Nvidia драйвера

Привет всем, столкнулся с такой проблемой не могу заменить драайвер
Спойлер!
sudo mhwd -r pci video-hybrid-intel-nvidia-435xx-prime
> Removing video-hybrid-intel-nvidia-435xx-prime…
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/local/pci/video-hybrid-intel-nvidia-435xx-prime/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
checking dependencies…
error: failed to prepare transaction (could not satisfy dependencies)
:: removing linux58-nvidia-435xx breaks dependency 'linux58-nvidia-435xx' required by linux-latest-nvidia-435xx
:: removing nvidia-435xx-utils breaks dependency 'nvidia-435xx-utils=435.21' required by linux54-rt-nvidia-435xx
Error: pacman failed!
Error: script failed!

и удалить ядро
Спойлер!
sudo mhwd-kernel -r linux58
error: failed to prepare transaction (could not satisfy dependencies)
:: removing linux58 breaks dependency 'linux58' required by linux-latest
:: removing linux58-nvidia-435xx breaks dependency 'linux58-nvidia-435xx' required by linux-latest-nvidia-435xx

При попытке устоновить другой драйвер
Спойлер!
Waiting for user input…
Starting
Error: config 'video-hybrid-intel-nvidia-440xx-prime' conflicts with config(s): video-hybrid-intel-nvidia-435xx-prime

перерыл кучу инфы ничего не выходит, не хотелось бы положить систему
спасибо
Manjaro KDE Edition

после обновления всего по перестала загружаться (черный экран)

манджаро кде дуалбут с вин10, uefi, долго мучился с установкой маеджары, в итоге получилось запустить через system-boot, все ок работало до первого обновления пакетов, я сдуру обновил все и сразу и в итоге приплыл, получил в биосе строку с вин и манджаро, при выборе манджаро только черный экран с переходом на биос, секьюрити отключен, пробовал восстановить загрузчик с архитекта, по вики, и инсталировать другой (refind), пока не решил проблему запуска. Куда копать?

видюха интегрированная: [email protected] ~]$ lspci | grep -E «VGA|3D»
00:02.0 VGA compatible controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display (rev 0e)

[[email protected] ~]$ efibootmgr
BootCurrent: 0008
Timeout: 2 seconds
BootOrder: 0008,0007,0001,0000,0004
Boot0000* Windows Boot Manager
Boot0001* manjaro
Boot0004* Linux Boot Manager
Boot0007* UEFI: Built-in EFI Shell
Boot0008* UEFI: SanDisk Cruzer Fit 1.27

[[email protected] ~]$ sudo fdisk -l
Диск /dev/sda: 465,78 GiB, 500107862016 байт, 976773168 секторов
Disk model: WDC WD5000LPVX-8
Единицы: секторов по 1 * 512 = 512 байт
Размер сектора (логический/физический): 512 байт / 4096 байт
Размер I/O (минимальный/оптимальный): 4096 байт / 4096 байт
Тип метки диска: gpt
Идентификатор диска: 9E71E089-ADD2-294E-ACCB-FFB53A3CF2D7

Устр-во начало Конец Секторы Размер Тип
/dev/sda1 2048 923647 921600 450M Среда для восстановления Micr
/dev/sda2 923648 1128447 204800 100M EFI
/dev/sda3 1128448 1161215 32768 16M Зарезервированный раздел Micr
/dev/sda4 1161216 409602047 408440832 194,8G Microsoft basic data
/dev/sda5 409602048 462850047 53248000 25,4G Файловая система Linux
/dev/sda6 462850048 976773119 513923072 245,1G Домашний раздел Linux
Manjaro KDE Edition

ошибки

такие ошибки и пропадает батарея из трея постоянно, иногда не загружаеться.
подскажите где копать
Manjaro KDE Edition: ошибки
Manjaro KDE Edition

KDE перестала реагировать на управление мышкой

Доброго всем времени суток!
После последнего обновления и перезагрузки рабочая среда перестала вообще как-то реагировать на нажатия мышки, из клавиш работала только консоль по F12. После гугления на тему было решено снести весь кэш и конфиги от KDE в папке home/username/, после сноса действительно KDE стала грузится совершенно без всяких моих конфигов мыши/иконок итд., перестал работать терминал по F12, но рабочая среда как ни на что не реагировала так и ничего не поменялось. После дальнейшего гугления на тему переустановить KDE было найдено
sudo pacman -S plasma-meta kde-applications-meta manjaro-kde-settings manjaro-settings-manager-knotifier manjaro-settings-manager-kcm
Не помогло,
sudo pacman -S $(pacman -Qnq)
не помогло (точнее пишет ошибку).
Пожалуйста подскажите куда копать? Возможно надо как-то удалить вообще все иксы со всеми конфигурационными файлами и установить заново? Переустанавливать всю систему не могу — очнь много чего было настроенно для работы, ключей SSH куча, паролей разных итд :(

UPD: Клавиатура работает, не работают только клавиши мышки.
Manjaro KDE Edition

не работают airpods pro

Всем привет!
airpods pro подключение есть, появляется значок, что подключены, звук отсутствует. В панели bluetooth показывает, что подключены и сопряжены, в панели громкости показывает наушники, но звука нет. Захожу там же в настройки, показывает устройство A2DP и не работает.
Подключал китайские meizu, звук есть, микрофон не работает. В настройках тоже самое.
Подключал philips. В настройках можно выбрать A2DP или hfp/hsp. При A2DP работают только динамики, а на hfp/hsp работает и микрофон. Один раз при подключении meizu тоже появилось hfp/hsp и заработал микрофон, но при след подключении все по старому.
Подскажите пожалуйста как решить, как это дело побороть?
Manjaro KDE Edition

Проблема с rdesktop и KDE

Когда подключаюсь с помощью rdesktop в виндовой машине, то вижу мерцание окон, лаги, скорость обновления картинки низкая. Когда использовал XFCE такой проблемы не было, всё работало вполне гладко. Подключаюсь с ноута, 8 гб оперативы.