Manjaro KDE Edition

Тиринг на ноутбуке с nvidia и встройкой amd

Здравствуйте, я новичок в манджаро, да и вообще в Линукс. Недавно я установил manjaro kde plasma., У меня ноутбук Lenovo Gaming 3 с Amd ryzen 5 4600h со встроенной графикой и nvidia geforce gtx 1650. Для переключения между видеокартами я использую optimus manager. Драйвера установлены проприетарные через установщик манджаро. Когда я использую встроенную графику amd, все хорошо, плавно, никакого тиринга нет, но когда я переключаю на Nvidia появляется тиринг по всей системе. Я гуглил свою проблему, но все эти способы, описанные в интернете мне не подошли. Я знаю про способ с force (full) composition pipeline, но у меня такой опции в nvidia-settings нет, а если прописывать вручную, то оно просто игнорирует её, либо же она просто не работает. Мой mhwd conf файл пустой. Я также пытался использовать эту опции через терминал, но безрезультатно.
Manjaro GNOME

Wayland Gnome Intel+Nvidia

Добрый день, искал в гугле и тут на форуме, но ничего толком не нашёл.
Вопрос следующий, имеется Gnome 40 и графика Intel+Nvidia (ноутбук Intel HD 630 + NVidia GTX1060M 6Gb). В настройках layouts в Manjaro пункт Waylamd enable не активен, при вводе пароля, сессию справа снизу не выбрать, там только 2 на выбор: Gnome и Gnome Classic.
Нашел на форуме, что в файле /etc/gdm.custom.conf надо прописать:
WaylandEnable=true
Прописал, перезагрузил, сессия все равно на X11.
Через просмотр установленного софта отображается установленный Wayland 1.19.0-1 и Wayland-protocol 1.22-1

Как запустить wayland? Или какую статью посмотреть\почитать
Ядро & Оборудование

Через раз загружается графический менеджер

Ядро & Оборудование: Через раз загружается графический менеджер

Это бывает часто. На некоторых версиях ядра система загружается на 5-7 раз. На некоторых ошибка появляется при загрузке раз в 5-7 нормальных загрузок. Я пробовал проприетарные драйвера, возвращался на открытые. Менял видеокарты, вместо Vega 56 ставил Geforce 1060, но ничего не помогает. Ошибка появляется снова и снова, на разных версиях ядра и разных видеокартах.
Очень боюсь, что в один прекрасный момент система перестанет загруужаться. Сейчас использую ядро 5.10.60-1-MANJARO и на нём ошибка проявляется нечасто.
Пожалуйста помогите победить проблему?
Manjaro GNOME

Не запускается xserver nvidia

Всем привет. У меня такая проблема. Не запускается xserver nvidia и все такое. Игры не видят дисретку и сама ОС тоже. Показывает только встройку.
Мой пк:
Lenovo g580
Intel HD 3000
Nvidia 710m
Ядро & Оборудование

asus rog g752vsk brightness ярк...

Всем здорово. Имеется ноут i7 7700hq, gtx 1070.
Встройки интел НЕТ! После установки дров, любых ( 390xx или новейших ) не регулируется яркость. От слова совсем. Кнопки по fn работают, уровень ползунка меняют.

Что было сделано: Старые дрова 390хх + команды ядра в граб:
GRUB_CMDLINE_LINUX=“nvidia.NVreg_EnableBacklightHandler=1 acpi_backlight=vendor”

правка файла нвидиа в xorg.conf.d: Option “RegistryDwords” “EnableBrightnessControl=1”
Всё работает как надо.
Если установить последние дрова Nvidia, яркость хреначит на полную. И ни чем не меняется.
Вывод ls /sys/class/backlight/ nvidia_0 в “рабочем” состоянии с 390хх
wiki.archlinux.org/title/Backlight_(Русский) 1

Первый раз столкнулся с такой проблемой. Народ, помогайте ))
Так как 390хх уже древний, и вулкан на нём совсем не хочет работать. Как заставить последние дрова регулировать яркость?
forums.developer.nvidia.com/t/solus-nvidia-gtx-1070-brightness-control-not-working/54472/9
Уголок новичка

Установить предыдущий драйвер NVIdia

Добрый день!
Как известно, в драйверах NVIdia, начиная с версии 460, есть глюк, из-за которого невозможно играть в «Far Cry 5» и в «Far Cry New Down»

На форумах по игре просто советуют установить драйвер версии от 450 до 455. Но как это сделать, если доступного драйвера нет в списке?
Спасибо заранее.

P.S. версию 390xx ставить пробовал — с ней, в свою очередь, уже не дружит Vulkan, и игра уже просто не запускается вовсе.

[aaasashamgguaaaSashaMGGU ~]$ mhwd -l --pci
Спойлер!
> 0000:0b:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
         network-r8168            2016.04.20                true            PCI


> 0000:01:00.0 (0300:10de:1c82) Display controller nVidia Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
          video-nvidia            2020.11.30               false            PCI
    video-nvidia-390xx            2020.11.30               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI


> 0000:0d:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
         network-r8168            2016.04.20                true            PCI


Уголок новичка: Установить предыдущий драйвер NVIdia
Manjaro KDE Edition

Nvidia драйвер чёрный экран (РЕШЕНО)

Здравствуйте!

На днях прикупил ноутбук с GTX 1650 и Ryzen5 4600H.
После установки Manjaro автоматически встал video-hybrid-amd-nvidia-prime.
После его удаления и установки video-nvidia вылезает чёрный экран. После удаления video-nvidia все начинает отлично работать на video-modesetting.

Вопрос: как заставить работать video-nvidia?

Если с video-nvidia попробовать команду startx, то ноутбук намертво зависает, при этом начинает вертеться кулер.
Пытался добавлять в grub «nvidia-drm.modeset=1» — не помогло.
В uefi отключить встройку нельзя.
Linux 5.11.6-1
Manjaro GNOME

Проблема при загрузке с backlight:acpi_video1

Всем привет.
Насмотревшись новомодных видео, где все чаще сообщалось что манжаро вполне себе готова для нетребовательных пользователей и работает вполне стабильно, практически без багов, решил попробовать на свежекупленный Lenovo IdeaPad Gaming 3 15ARH05 (Ryzen 7 4800H, nVidia 1650Ti Mobile). В целом установка прошла гладко, после установил проприетарные драйвера (мне религия позволяет), и все вроде как работает, кроме как одного но — при включении ноута, высвечивается ошибка

[FAILED] Failed to start Load/Save ness of backlight:acpi_video1.
[FAILED] Failed to start Load/Save Screen Backlight Brightness of backlight:amdgpu_bl1.

и старт зависает. Если закрыть крышку и подождать когда он уйдет в спячку, и после открыть ноут, отображается скрин входа в систему, но с минимальной яркостью.
В просторах интернета все советы сводятся к правкам груба в /etc/default/grub и добавлении к GRUB_CMDLINE_LINUX_DEFAULT опции acpi_backlight одного из параметров video,vendor,native, none. Но ни один из вариантов не помогают, в лучшем случае ошибка не появляется, но процесс загрузки так и стопорится, и при открывании крышки, яркость уже на максимуме.
Так же предлагают отключать сервис backlight командой «sudo systemctl mask [email protected]», но это тоже не помогает.
Как то пользоваться в таком режиме очень неудобно, надеюсь что кто-то сталкивался с похожей проблемой, или хотя-бы понимает что там происходит, и сможет подсказать куда копать
inxi -Fazy
System:
Kernel: 5.10.2-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
root=UUID=563ace45-713a-49ff-ae29-7756ba455ccb rw quiet udev.log_priority=3
acpi_backlight=vendor
Desktop: GNOME 3.38.2 tk: GTK 3.24.24 wm: gnome-shell dm: GDM 3.38.2
Distro: Manjaro Linux
Machine:
Type: Laptop System: LENOVO product: 82EY v: IdeaPad Gaming 3 15ARH05
serial: Chassis: type: 10 v: IdeaPad Gaming 3 15ARH05
serial: Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: UEFI: LENOVO
v: FCCN13WW date: 06/29/2020
Battery:
ID-1: BAT0 charge: 46.2 Wh condition: 46.2/45.0 Wh (103%) volts: 12.9/11.4
model: SMP L19M3PF7 type: Li-poly serial: status: Full cycles: 2
CPU:
Info: 8-Core model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64
type: MT MCP arch: Zen 2 family: 17 (23) model-id: 60 (96) stepping: 1
microcode: 8600104 L2 cache: 4 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
bogomips: 92661
Speed: 1397 MHz min/max: 1400/2900 MHz boost: enabled Core speeds (MHz):
1: 1397 2: 1397 3: 1398 4: 1395 5: 1398 6: 1396 7: 1397 8: 1396 9: 1397
10: 1397 11: 1397 12: 1397 13: 1397 14: 1397 15: 1397 16: 1397
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: Lenovo
driver: nvidia v: 455.45.01 alternate: nouveau,nvidia_drm bus ID: 01:00.0
chip ID: 10de:1f95
Device-2: AMD Renoir vendor: Lenovo driver: amdgpu v: kernel bus ID: 05:00.0
chip ID: 1002:1636
Device-3: Syntek Integrated Camera type: USB driver: uvcvideo bus ID: 1-3:2
chip ID: 174f:244c serial: Display: x11 server: X.org 1.20.10 compositor: gnome-shell
driver: amdgpu,ati,nvidia unloaded: modesetting,nouveau
alternate: fbdev,nv,vesa resolution: <missing: xdpyinfo>
OpenGL: renderer: AMD RENOIR (DRM 3.40.0 5.10.2-2-MANJARO LLVM 11.0.0)
v: 4.6 Mesa 20.3.1 direct render: Yes
Audio:
Device-1: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Lenovo
driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus ID: 05:00.5
chip ID: 1022:15e2
Device-2: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel
v: kernel bus ID: 05:00.6 chip ID: 1022:15e3
Sound Server: ALSA v: k5.10.2-2-MANJARO
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Lenovo driver: r8169 v: kernel port: 2000 bus ID: 03:00.0
chip ID: 10ec:8168
IF: eno1 state: down mac: Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
vendor: Lenovo driver: ath10k_pci v: kernel port: 2000 bus ID: 04:00.0
chip ID: 168c:003e
IF: wlp4s0 state: up mac: Device-3: Qualcomm Atheros QCA61x4 Bluetooth 4.0 type: USB driver: btusb
bus ID: 3-3:3 chip ID: 0cf3:e300
Drives:
Local Storage: total: 1.03 TiB used: 35.72 GiB (3.4%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZALQ128HBHQ-000L2
size: 119.24 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 serial: rev: AL2QFXV7 temp: 30.9 C
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172
size: 931.51 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
serial: rev: LFM3
Partition:
ID-1: / raw size: 118.95 GiB size: 116.58 GiB (98.01%)
used: 35.72 GiB (30.6%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%)
used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:
Kernel: swappiness: 60 (default) cache pressure: 100 (default)
ID-1: swap-1 type: file size: 4 GiB used: 0 KiB (0.0%) priority: -2
file: /swapfile
Sensors:
System Temperatures: cpu: 52.0 C mobo: N/A gpu: amdgpu temp: 43.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 350 Uptime: 29m wakeups: 2 Memory: 7.21 GiB
used: 4.11 GiB (56.9%) Init: systemd v: 247 Compilers: gcc: N/A Packages:
pacman: 1207 lib: 369 flatpak: 0 Shell: Zsh v: 5.8
running in: gnome-terminal inxi: 3.2.01


UPD:
Загрузку получилось побороль вот этим способом medium.com/@aviezab/dual-gpu-amd-nvidia-setting-on-arch-linux-based-distro-a88f9874c2d (6й пункт не устанавливал, засомневался в актуальности). Проблема с подсветкой остается — изначально при загрузке подсветка на уровне где то половина, но при попытке ее отрегулировать, сбрасывается в ноль, и регулируется уже нормально. В настройках груба для GRUB_CMDLINE_LINUX_DEFAULT установил acpi_backlight=native. Еще позже попытаюсь сделать так, чтобы и подсветка устанавливала корректный уровень, но на данный момент уже лучше
Ядро & Оборудование

Смена видеокарты

При замене видеокарты с Geforce 1060 на Radeon RX VEGA 56 получаю чёрный экран и система не загружается. Картинки нет вообще. При этом видеокарта точно рабочая и в Windows работает. Пробовал удалять сначала драйвер nvidia потом менять карту, но не помогло. Подскажите пожалуйста как правильно поменять видеокарту в Manjaro, чтобы всё заработало правильно?
Уголок новичка

Вопрос по драверам Nvidia.

Доброго времени суток, столкнулся с проблемой при установке драйвера Nvidia, после долгого безрезультатного гугления, решил обратитса к вам Линуксоиди, Проблема следущая у меня ноутбук со следующеми характеристиками:
Камень: i3-4005U
Видюха: Nvidia GeForse 920m
Система: Mandjaro 20.2 KDE
Хочу на него установить 450-й драйвер Nvidia, если устанавливать через утилиту то там макс драйвей 418 humblebee, робота которого меня не устаиват + он не подерживает множество нових функций, установка с консоли sudo mhwd -i pci video-nvidia-450xx видает результат no matching device for config 'video-nvidia-450xx' found!
но драйвер все равно устанавливаетса, но не работает. Так от можна ли установить 450-й дравер на видюху 920m. Если да то как ето зделать?