Ядро & Оборудование

Через раз загружается графический менеджер

Ядро & Оборудование: Через раз загружается графический менеджер

Это бывает часто. На некоторых версиях ядра система загружается на 5-7 раз. На некоторых ошибка появляется при загрузке раз в 5-7 нормальных загрузок. Я пробовал проприетарные драйвера, возвращался на открытые. Менял видеокарты, вместо Vega 56 ставил Geforce 1060, но ничего не помогает. Ошибка появляется снова и снова, на разных версиях ядра и разных видеокартах.
Очень боюсь, что в один прекрасный момент система перестанет загруужаться. Сейчас использую ядро 5.10.60-1-MANJARO и на нём ошибка проявляется нечасто.
Пожалуйста помогите победить проблему?
Уголок новичка

[решено переустановкой] audio: видны не все устройства.

Привет! Переставил систему на новый ноут и словил траблы с аудио девайсами. В устрайствах нет девайса через hdmi (на старом ноуте есть) и у Behringer U-PHORIA UM2 только Analog output (На старом был еще и Digital output), и нет микрофона от неё (только интегрированный в ноут).
Может надо что-то доставить?
Уголок новичка

[решено] Драйвера для клавиатуры Open-Razer

Доброго времени суток!

Помогите установить пакет openrazer.github.io/ для клавиатуры BlackWidow Chroma V2 (1532:0221).
Совсем недавно на Linux, пробовал через aur — не находит пакета, а как правильно скомпилировать не знаю.

Заранее благодарю за помощь!
Уголок новичка

Хелпуйте, проблемы с драйверами nvidia

Доброго времени суток, у меня полетели драйвера от nvidia, я пытался найти решение довольно длительный срок, но все было не то, но если по моему рассказу вы знаете топик с решением проблемы, то не откажусь от ссылки. Итак, по порядку. Я отошёл по делам, а Manjaro вошла в спящий режим, после выхода из него слетело разрешение, в настройках дисплея нужного мне не стало, я, с испугу, пошёл перенакатывать систему, но я был сильно удивлён, что разрешение поменялось и в live версии. После установки системы проблема, конечно же не решилась, и я начинаю возиться с xrandr. Нашлась определённая закономерность, при «удалённых» драйверах (удаляю через hardware configuration) DVI-I-1 становится приоритетным(с установленными DVI-I-0) и с ним получается производить манипуляции с xrandr и с 10-monitor.conf и разрешение меняется, одноко, при установке дров разрешение слетает и становится невозможным им манипулировать(я пробывал делать приоритетным DVI-I-1 при дровах, но ничего не изменяется и ошибок тоже не выдаёт). Так же я устанавливал пакеты nvidia и nvidia-utils, тоже нет результатов. В xorg.conf тоже копался, это он просто игнорит. Сейчас дошло до того, что не могу поставить дрова от nvidia в hardware configuration. На системе ничего важного нет и при обходимости могу снести, но опять же будет проблема с драйверами. Я ещё новичок, поэтому будьте ко мне терпеливы, пожалуйста.
Уголок новичка

Установка драйвера для адаптера Wi-Fi RTL8723de. Отвалился после перезагрузки.

С горем пополам и помощью друга установил драйвер на адаптер RTL8723DE

git clone https://github.com/lwfinger/rtlwifi_new.git
git checkout origin/rtw88 -b rtw88
make
make install
reboot

После перезапуска все заработало. Увидел все доступные сети, подключился к ней. Вечером перезапустил ноутбук. Снова адаптер wi-fi не обнаружен.

Буду очень благодарен, если кто-нибудь подскажет в какую сторону копать.

PS Вскользь намекнули, что нужно подгрузить модуль. Если причина в этом, то как это делается?

Решение установки для драйвера на адаптер Wi-Fi RTL8723DE на 04.06.2020 года
Вбить в терминале
yay -S rtlwifi_new-rtw88-dkms

для корректного выполнения команды должны быть установлен помощник AUR yay

08.06.2020 Вылеты драйвера после перезагрузки продолжились. В AUR вышеуказанный драйвер Отмечен устаревшим (2020-06-05). Судя по всем мой периодически возникающий wi-fi держится за счет первых манипуляций с GIT. В следующий вылет драйвера попробую скачать github.com/smlinux/rtl8723de.
Блог им. junk92

Динамик и Наушники - сами постоянно переключаются. Как принудительно включить динамик ?

Всем привет. 5 дней назад установил Linux Manjaro KDE, до этого никогда не пользовался Линуксом.
На windows 10 у меня тоже переключались наушники и динами, решил это установкой классического драйвера Windows — аудио драйвер high definition audio (поставил его вместо Realtek). В классическом драйвере сам выбираешь Динамик или Наушники (и ничего не переключается).

У меня постоянно Динамик и Наушники сами меняются… это очень неудобно.

Как сделать так, что бы на Monjaro принудительно выбрать Динамик или же захочу — Наушники.
Manjaro Other

NON-FREE драйвер Radeon R5 230 на MANJARO DEEPIN

Добрый день!
При установке manjaro dde (deepin) и выборе несвободных драйверов вижу черный экран и курсор мыши.
При выборе свободных драйверов — все нормально
На других de — что свободных, что non-free — все ставятся нормально

Поделитесь советом куда копать — нужен dde и non-free драйвера на видеокарту Radeon r5 230
Уголок новичка

Проблемы с WiFi

Здравствуйте, товарищи, сразу скажу, что в мире Линукса я новичок. Суть проблемы: Не зависимо от дистрибутива(устанавливал Mint, Fedora) отключение wifi в случайном порядке, то есть он может работать день, а может и 20 минут. При попытке перезагрузки через графическую оболочку wifi, когда пропадает wifi, зависает иногда весь DE(sudo service lightdm restart не помогает) бывает пропадает связь с кликпадом. Драйвера не устанавливал, т.к. указано, что это последняя его версия, да и не нашел свежий вариант. Проблема на Minte решалась этим путем NetworkManager Wi-Fi powersaving configuration Но этого хватило примерно на месяц дальше все повторилось вновь.
Результат inxi выводит, что драйвер есть:
inxi

System:    Kernel: 4.19.16-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.14.5 Distro: Manjaro Linux 

Machine:   Type: Laptop System: ASUSTeK product: VivoBook 15 ASUS Laptop X570UD v: 1.0 
           Mobo: ASUSTeK model: X570UD

Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168 
           IF: enp2s0 state: down mac: 18:31:bf:42:40:bd 
           Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter driver: ath10k_pci


lspci:
Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)
	Subsystem: AzureWave QCA9377 802.11ac Wireless Network Adapter
	Flags: fast devsel, IRQ 129
	[virtual] Memory at ef200000 (64-bit, non-prefetchable) [size=2M]
	Capabilities: <access denied>
	Kernel driver in use: ath10k_pci
	Kernel modules: ath10k_pci


ifconfig -a
enp2s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 18:31:bf:42:40:bd  txqueuelen 1000  (Ethernet)
        RX packets 2888929  bytes 4276659243 (3.9 GiB)
        RX errors 0  dropped 2  overruns 0  frame 0
        TX packets 822555  bytes 65247528 (62.2 MiB)
        TX errors 0  dropped 136 overruns 0  carrier 0  collisions 0
        device interrupt 127  base 0x1000  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 447462  bytes 671226386 (640.1 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 447462  bytes 671226386 (640.1 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp3s0: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 80:c5:f2:43:cc:db  txqueuelen 1000  (Ethernet)
        RX packets 6325623  bytes 9291762752 (8.6 GiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1788568  bytes 219006001 (208.8 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


Через утилиту
ethtool
driver: ath10k_pci
version: 4.19.16-1-MANJARO
firmware-version: WLAN.TF.2.1-00021-QCARMSWP-1
expansion-rom-version: 
bus-info: 0000:03:00.0
supports-statistics: yes
supports-test: no
supports-eeprom-access: no
supports-register-dump: no
supports-priv-flags: no


В результате поисков понял, что падает интерфейс wlp3s0.
Попытка поднятия интерфейса путем sudo ip link set wlp3s0 up
Выводит: RTNETLINK answers: Input/output error

Вывод
ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
       valid_lft forever preferred_lft forever
       valid_lft forever preferred_lft forever
2: enp2s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 18:31:bf:42:40:bd brd ff:ff:ff:ff:ff:ff
3: wlp3s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
    link/ether 80:c5:f2:43:cc:db brd ff:ff:ff:ff:ff:ff

, после падения.
nmcli general status:
STATE                CONNECTIVITY  WIFI-HW  WIFI     WWAN-HW  WWAN    
подключен (на узле)  ограничено    включен  включен  включен  включен

, SATE через некоторое время поменяется на «отключено».
перезапуск Network managera :sudo systemctl restart networking.service
Failed to restart networking.service: Unit networking.service not found.

Переустановка модуля не помогает
sudo modprobe -r ath10k_pci
sudo modprobe ath10k_pci
Других утилит контролирующих wifi, вроде нет, кроме NM
systemctl list-units | grep -iE &#39;(&#39;net&#39;)&#39;
sys-devices-pci0000:00-0000:00:1c.4-0000:02:00.0-net-enp2s0.device   loaded active  plugged   RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller                    
sys-devices-pci0000:00-0000:00:1c.5-0000:03:00.0-net-wlp3s0.device   loaded active  plugged   QCA9377 802.11ac Wireless Network Adapter                                    
sys-subsystem-net-devices-enp2s0.device                              loaded active  plugged   RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller                    
sys-subsystem-net-devices-wlp3s0.device                              loaded active  plugged   QCA9377 802.11ac Wireless Network Adapter                                    
NetworkManager.service                                               loaded active  running   Network Manager                                                              
network.target                                                       loaded active  active    Network


dmesg | grep ath10k_pci
dmesg 2-ая
Ядро & Оборудование

Ошибка ACPI драйвера "ATK0110 ATK0110:00: hwmon_device_register() is deprecated. Please convert the driver to use hwmon_device_register_with_info()"

Привет, не бейте)

Похоже на то, что у меня живет вот этот баг драйвера ACPI.

Что вообще можно с этим сделать? Какие-нибудь обходные маневры? Вручную, мб, что-то хитрое прописать? Или я чего-то в гугле не нашел, и решение под это дело уже давно есть?