Manjaro KDE Edition

Снова про swap

Приветствую. Система Manjaro 21.3.0 только установленна. KDE. BTRFS. С правилами запуска swap знаком

wiki.archlinux.org/title/Swap
wiki.manjaro.org/index.php/Swap

Информацию выкладываю в скринах. Swap принципиально не запускается. Я не уверен как swap себя чувствует на логических разделах, но он там был всегда и до этого использовался системой с BTRFS

UUID

SysMonitor

fstab

PartManager
Уголок новичка

Монтирование дисков NTFS в виртуальной машине и SWAP

Приветствую сообщество Manjaro.
В этой ОС я новенькая и пока пробую на виртуальной машине из под Windows 10. Установила ОС, ПО и настроила всё под VMware 16.
Подскажите, пожалуйста, как смонтировать физический диск NTFS (пусть будет E: ) в виртуальной Manjaro так, чтобы им можно было пользоваться как физическим? Сразу поясню, что видела, как такое работает под др. ОС Linux, но как вот настроить?..
Второй вопрос. После изучения общих принципов работы и настройки, планирую установку уже основной ОС. Нужен ли SWAP при нормальной установке на SSD? Поясню, многие хостеры года 3-4 уже рекомендуют не использовать SWAP на таких ОС, как Ubuntu Server и Debian, при создании и настройке VDS. Но тут есть нюанс, на десктопе будут Steam и игры, довольно тяжёлые, вроде Witcher 3, Civ6 и др. Компьютер такой:
Ryzen R5 1600AF, ОЗУ 16Gb, SSD 480Gb (под ОС и ПО раздел 80Gb).
Заранее благодарна за помощь и советы.
Manjaro XFCE Edition

Черный экран после включения swap файла (файла подкачки)

Всем привет, после включения опции swap я получаю черный экран в момент загрузки системы.

Подключал swap по этому мануалу. Swap работал до перезагруки.

Я выключил опцию
quite
при загрузке, добавил
nomodeset
и вижу такую картину:

// [ OK ] banch of OK messages...
[    **] A start job is runnning for /dev/disk/by-uuid/d381f6c5-aa84-...{uuid} (1 min 2s / 1min 30s)
[ TIME ] Timed out waiting for device /dev/disk/by-uuid/d381f6c5-aa84-...{uuid}
[DEPEND] Dependency failled for /swapfile
[DEPEND] Dependency failed for Local File Systems
// [ OK ] banch of OK messages...


Насколько я понимаю, неправильно указал UUID вот здесь
/etc/fstab


Как мне поменять или закомментировать строку, которая вызывает ошибку? У меня установлена Windows 10, можно ли как-то безопасно изменить файл `/etc/fstab` через нее например? Нашел пока способ только прочитать этот файл.

Или возможно у Manjaro есть какая-то альтернатива Safe mode в Windows?

Или опять все переустанавалить?)

Данные системы, до этой ошибки:
System:
  Kernel: 5.10.56-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=f39d9866-5be6-4713-b625-36fb4ec289a4 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 7 
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
Machine:
  Type: Laptop System: ASUSTeK product: N552VW v: 1.0 serial: <filter> 
  Mobo: ASUSTeK model: N552VW v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: N552VW.300 date: 08/31/2016 
Battery:
  ID-1: BAT0 charge: 26.4 Wh (76.3%) condition: 34.6/48.2 Wh (71.7%) 
  volts: 14.4 min: 14.4 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A 
  status: Charging cycles: 354 
Memory:
  RAM: total: 15.53 GiB used: 2.77 GiB (17.9%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Info: Quad Core model: Intel Core i7-6700HQ bits: 64 type: MT MCP 
  arch: Skylake-S family: 6 model-id: 5E (94) stepping: 3 microcode: EA cache: 
  L2: 6 MiB bogomips: 41621 
  Speed: 800 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 800 2: 800 3: 802 
  4: 800 5: 800 6: 800 7: 800 8: 800 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr hle ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat 
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts 
  rdrand rdseed rdtscp rep_good rtm sdbg sep smap smep ss ssbd sse sse2 sse4_1 
  sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable 
Graphics:
  Device-1: Intel HD Graphics 530 vendor: ASUSTeK driver: i915 v: kernel 
  bus-ID: 00:02.0 chip-ID: 8086:191b class-ID: 0300 
  Device-2: NVIDIA GM107M [GeForce GTX 960M] vendor: ASUSTeK driver: nvidia 
  v: 470.57.02 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 
  chip-ID: 10de:139b class-ID: 0302 
  Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo 
  bus-ID: 1-4:3 chip-ID: 13d3:5666 class-ID: 0e02 serial: <filter> 
  Display: x11 server: X.Org 1.20.13 compositor: xfwm4 v: 4.16.1 driver: 
  loaded: modesetting,nvidia unloaded: intel,nouveau alternate: fbdev,nv,vesa 
  display-ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 3840x2160 s-dpi: 96 s-size: 1016x571mm (40.0x22.5") 
  s-diag: 1165mm (45.9") 
  Monitor-1: eDP-1 res: 3840x2160 hz: 60 dpi: 284 size: 344x194mm (13.5x7.6") 
  diag: 395mm (15.5") 
  OpenGL: renderer: Mesa Intel HD Graphics 530 (SKL GT2) v: 4.6 Mesa 21.1.6 
  direct render: Yes 
Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a170 
  class-ID: 0403 
  Device-2: Sennheiser Headset [PC 8] type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-6:4 chip-ID: 1395:0025 
  class-ID: 0300 
  Sound Server-1: ALSA v: k5.10.56-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.33 running: no 
Network:
  Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel port: e000 
  bus-ID: 02:00.0 chip-ID: 8086:095a class-ID: 0280 
  IF: wlp2s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: d000 bus-ID: 03:00.1 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp3s0f1 state: down mac: <filter> 
  WAN IP: <filter> 
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 
  bus-ID: 1-9:5 chip-ID: 8087:0a2a class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running 
  rfk-block: hardware: no software: yes address: see --recommends 
Logical:
  Message: No logical block device data found. 
RAID:
  Message: No RAID data found. 
Drives:
  Local Storage: total: 2.29 TiB used: 71.69 GiB (3.1%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: SK Hynix model: HFS512G39MND-3510A 
  size: 476.94 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  type: SSD serial: <filter> rev: 0P00 scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST2000LM003 HN-M201RAD 
  size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  type: HDD rpm: 5400 serial: <filter> rev: 0001 scheme: GPT 
  Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVDRAM GUE1N rev: AS00 
  dev-links: cdrom 
  Features: speed: 24 multisession: yes audio: yes dvd: yes 
  rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
Partition:
  ID-1: / raw-size: 98.81 GiB size: 96.7 GiB (97.86%) used: 71.66 GiB (74.1%) 
  fs: ext4 dev: /dev/sda5 maj-min: 8:5 label: N/A 
  uuid: f39d9866-5be6-4713-b625-36fb4ec289a4 
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) 
  used: 25.3 MiB (26.3%) fs: vfat dev: /dev/sda2 maj-min: 8:2 label: N/A 
  uuid: 7E48-4C5B 
Swap:
  Alert: No swap data was found. 
Unmounted:
  ID-1: /dev/sda1 maj-min: 8:1 size: 499 MiB fs: ntfs 
  label: \xd0\x92\xd0\xbe\xd1\x81\xd1\x81\xd1\x82\xd0\xb0\xd0\xbd\xd0\xbe\xd0\xb2\xd0\xb8\xd1\x82\xd1\x8c 
  uuid: CCBA479BBA478146 
  ID-2: /dev/sda3 maj-min: 8:3 size: 16 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-3: /dev/sda4 maj-min: 8:4 size: 377.53 GiB fs: ntfs label: N/A 
  uuid: 0434816F34816490 
  ID-4: /dev/sdb1 maj-min: 8:17 size: 16 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-5: /dev/sdb2 maj-min: 8:18 size: 878.89 GiB fs: ntfs label: N/A 
  uuid: 447C577C7C5767A6 
  ID-6: /dev/sdb3 maj-min: 8:19 size: 984.11 GiB fs: ntfs label: N/A 
  uuid: 1024636424634BB2 
USB:
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-1:2 info: A4Tech XL-730K / XL-750BK / XL-755BK Mice 
  type: Keyboard,Mouse driver: hid-generic,usbhid interfaces: 2 rev: 1.1 
  speed: 12 Mb/s power: 100mA chip-ID: 09da:9090 class-ID: 0301 
  Device-2: 1-4:3 info: IMC Networks USB2.0 HD UVC WebCam type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA 
  chip-ID: 13d3:5666 class-ID: 0e02 serial: <filter> 
  Device-3: 1-6:4 info: Sennheiser Headset [PC 8] type: Audio,HID 
  driver: hid-generic,snd-usb-audio,usbhid interfaces: 4 rev: 1.1 
  speed: 12 Mb/s power: 100mA chip-ID: 1395:0025 class-ID: 0300 
  Device-4: 1-9:5 info: Intel Bluetooth wireless interface type: Bluetooth 
  driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA 
  chip-ID: 8087:0a2a class-ID: e001 
  Device-5: 1-12:6 info: Atmel type: HID 
  driver: hid-generic,hid-multitouch,usbhid interfaces: 2 rev: 2.0 
  speed: 12 Mb/s power: 100mA chip-ID: 03eb:8a9c class-ID: 0300 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 8 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
Sensors:
  System Temperatures: cpu: 51.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 2000 
Info:
  Processes: 259 Uptime: 5m wakeups: 91 Init: systemd v: 248 tool: systemctl 
  Compilers: gcc: 11.1.0 alt: 10 clang: 12.0.1 Packages: 1311 pacman: 1307 
  lib: 345 flatpak: 0 snap: 4 Shell: Zsh v: 5.8 running-in: xfce4-terminal 
  inxi: 3.3.06 
Софт

Не включается swap на файле

Здравствуйте!

[W360 lexa1]# mkswap large/swapfile 
mkswap: large/swapfile: предупреждение: очистка старой сигнатуры swap.
Setting up swapspace version 1, size = 16 GiB (17196642304 bytes)
без метки, UUID=1707804e-661a-467c-9e30-4f6d5807151e
[W360 lexa1]# swapon  large/swapfile 
swapon: /mnt/large/swapfile: swapon failed: Недопустимый аргумент



А какой аргумент недопустимый?
Уголок новичка

[РЕШЕНО] Случайно изменил UUID swap раздела.

Я случайно в GParted тронул swap и поменял его UUID. После этого при загрузке меня встречали строчки
hibernation device «UUID=старый swap UUID» not found
[ TIME ] Timed out waiting for device бла бла бла
[ DEPEND ] Dependency failed for бла бла бла
[ DEPEND ] Dependency failed for бла бла бла
Я заменил в /etc/fstab старый swap UUID на новый, и это частично помогло — теперь при загрузке высвечивается только
hibernation device «UUID=старый swap UUID» not found
Как полностью решить проблему?
UPD: Заменил старый UUID на новый в /boot/grub/grub.cfg. Всё работает.
А ещё лучше отредачить /etc/default/grub, и прописать sudo update-grub.
Уголок новичка

Проблема со swap

Всем добрый день!
Для работы с Android studio катастрофически не хватает 4Г оперативки. ДЛя этой цели создал swap раздел диска на 8Г. Затем решил увеличчить его до 16.
Столкнулся с проблемой, что swap перестал работать. Запуск systemctl --failed показывает
UNIT LOAD ACTIVE SUB DESCRIPTION
● dev-disk-by\x2duuid-2467\x2d9EC5.swap loaded failed failed /dev/disk/by-uuid/>

LOAD = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB = The low-level unit activation state, values depend on unit type.

1 loaded units listed.
ESCOC

Гуглёж довел до bbs.archlinux.org/viewtopic.php?id=192792
Но далее столкнулся с тем, что не понимаю, как отредактировать fstab, да и нужно ли это в моем случае.

Используя journalctl -b -l, вижу
Nov 22 03:03:51 kanikita systemd-fstab-generator[2163]: Failed to create unit file /run/systemd/generator/dev-disk-by\x2duuid-b6881abb>

Прошу помочь разобраться. Заранее спасибо.
Уголок новичка

Не разметился раздел SWAP

Друзья, подскажите зелёному (неделю на линуксе).

Когда ставил образ начисто, размечалось автоматически три раздела, загрузочный, корень и своп.
Нужда заставила вернуть Вин10, сделал дуалбут, при том, что первой поставил Вин, на него Manjaro Deepin, так вот, загвоздка в том, что при таком раскладе SWAP не разметился. критично ли это и можно ли его как-то подсунуть через Gparted, например?
Manjaro XFCE Edition

[РЕШЕНО] Как заставить работать Swap?

Здравствуйте.
Прошу совета.
Исходные: Manjaro-XFCE
Запущен ФМ, Google-chrome c четырьмя открытыми вкладками, два прайс-листа в Gnumeric, Mousepad.
Расход памяти — 1,76 из 2,0.
Система жутко тормозит, иногда виснет. Подкачки -0.
При тех же исходных — даже более суровых (количество вкладок в браузере может варьироваться от десяти до двадцати) в окружении Plasma на том же компьютере Swap исправно выполняет свои функции, расход памяти стабильно около 1,5 и плавность работы изумительная..)
Вопрос: как заставить работать Swap в XFCE?
На всякий случай — содержимое /etc/fstab XFCE

# UUID=fee1fbc1-27cd-4bab-970e-e65736cf449b / ext4 defaults,noatime 0 1
UUID=54c00a97-d566-4c73-9afc-5bbf11bfbf31 swap swap defaults,noatime 0 2

Спасибо за
Уголок новичка

Жуткие тормоза при работе со swap

Доброго всем денечка! До недавнего времени не особо сталкивался с этим вопросом, но он меня начал убивать потихоньку… Как только в системе заканчивается ОЗУ, при использовании swap (штатного раздела) начинаются дикие тормоза… Даже мышь Читать дальше