Софт
   2251

EiskaltDC++

В комментах заметил проблему у пользователей с установкой данного ПО, посему запилю краткую инструкцию.
Устанавливаем с аура:
  1. eiskaltdcpp-core
  2. eiskaltdcpp-data
  3. Устанавливаем клиент соответствующий либам нашего ДЕ, например для кед eiskaltdcpp-qt
Пару слов о ПО
EiskaltDC++ — свободный кроссплатформенный клиент файлообменной сети Direct Connecт. Как по мне, так лучший DC клиент для Linux

20 комментариев

avatar
eiskaltdcpp-gtk стоит полагать
?
Когда-нибудь рак на горе свистнет, и начнет твориться адская херня
0
avatar
какая ошибка то?
?
Когда-нибудь рак на горе свистнет, и начнет твориться адская херня
0
avatar
Перед написанием мануала, я специально протестил у меня кеды поэтому ставил qt версию. Если бы ты перешел по моей ссылке(в комментах в том топике) в аур, то увидел бы, что для работы еще необходимо иметь qt4(что не надо указывать для qt based de — например кеды).
Но учитывая, что у тебя крыса, то рискну предположить что у тебя этих либ нет, а есть gtk2 либы(учитывая, что крыса gtk2 based de) поэтому предложу тебе поставить eiskaltdcpp-gtk
0
avatar
Подозреваю, что о настройке и функциональности этого ПО лучше выяснять в его сообществе, не?
0
avatar
Жесть, столько сопутствующих пакетов еще ни разу не устанавливал…
?
Свежие новости мира информационных технологий ТехноДжем
0
avatar
Автор аура ленив просто)
0
avatar
Мало того что накачало тонну зависимостей, минут 30 компилило всё, так ещё и в конце выдало:
==> Продолжить установку eiskaltdcpp-git ? Да/нет [Y/n]
==> [v]просмотреть содержимое пакета [c]проверить пакет при помощи namcap
==> ---------------------------------------------------------------------
==> 

загрузка пакетов...
разрешение зависимостей...
проверка конфликтов...
ошибка: обнаружен неразрешимый конфликт пакетов
ошибка: не удалось подготовить запрос (конфликтующие зависимости)
:: eiskaltdcpp-gtk2-git и eiskaltdcpp-gtk3-git конфликтуют
Последний раз редактировалось
?
Свежие новости мира информационных технологий ТехноДжем
0
avatar
удалил из yaourt папки eiskaltdcpp-gtk2-git, всё установилось
?
Свежие новости мира информационных технологий ТехноДжем
0
avatar
Ну если смотреть правде в глаза, то похоже кто то не очень внимательно смотрел какие зависимости тянулись и просто «Далее — Далее » жмякал blush
з.ы.
но PKGBUILD в ауре ужасный, действительно
0
avatar
я никогда толком не понимал и не пользовался DC++, вот и сейчас не задалось, посмотрел, начал искать файлы выкинуло из приложения, попробовал повторить, приложение тоже повторило «выкидыш», снёс приложение smiley
Последний раз редактировалось
?
Свежие новости мира информационных технологий ТехноДжем
0
avatar
Тоже выкидывает при поиске(gtk-версия), а DC-клиент нужен.
0
avatar
Вообще говоря, eiskaltdc- самая крутая программа для dcp-протокола. Лет этак 10 назад именно она была стандартом во всех московских кабельных сетях. С тех пор её ни разу не обновляли. Думаю, то что сейчас лежит в АУРе- это та самая десятилетней давности прога, для которой кто-то написал PKGBUILD.
Лучше не надо ее юзать- поищите что-нибудь поновее.
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
Подозреваю что ты путаешь.
доводы:
1. На данный момент это наверно единственный dc на линух который активно развивается(последний релиз 15 года)
2. Данному dc нет 10 лет около 5 максимум
3. Лет 10 назад (за Москву не скажу, но в целом сделаю вывод) самый популярный dc под линух был — LinuxDC++ о других многие и не знали
0
avatar
Неее, этой проге точно больше 10 лет. Я её ещё на винде и на фряхе юзал, а это было уж совсем давно. Я тогда еще в Москве жил.
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
В подтверждение моего мнения могу предложить только это
0
avatar
Ой, сейчас вспомнил те времена- это ведь бы рай для кулхацкера. вся москва была практически всего в двух сетях- нетбайнет и корбина. Между сетями был шлюз, и у всех пользователей- практически постоянно была запущена эта прога, причем в режиме сервера. И у половины- был по дефолту открыт весь «диск с». Заходи, кто хочешь, бери что хочещь.
ностальгия… вот ведь были времена…
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
в маленьких городках, где интернет всё еще роскошь, DC++ по прежнему активно используется smile
Последний раз редактировалось
?
Когда-нибудь рак на горе свистнет, и начнет твориться адская херня
0
avatar
Ну а что я про неё что-то плохое написал? Вроде-бы нет, очень неплохая программа для прямого файлообмена. И чат в ней замечательный.
Последний раз редактировалось
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
я и не имел ввиду ничего плохого об этой программе, имелось ввиду то, что давно прошедшие времена в Москве, в глубинке еще не прошли
?
Когда-нибудь рак на горе свистнет, и начнет твориться адская херня
0
avatar
пытаюсь установить eiskaltdcpp-core-git (2.3.0...) из AUR выдает ошибку
<code>
-> Распаковка 'Test-Time-0.04.tar.gz' с помощью bsdtar
==> Запускается build()...
Can't locate inc/Module/Install.pm in @INC (you may need to install the inc::Module::Install module) (@INC contains: /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl) at Makefile.PL line 2.
BEGIN failed--compilation aborted at Makefile.PL line 2.
==> ОШИБКА: Произошел сбой в build().
    Прерывание...
</code>
если устанавливать другой вариант программы (2.2.10) выдает другую ошибку
<code>
/usr/include/openssl/ossl_typ.h:104:16: замечание: forward declaration of «struct dh_st»
 typedef struct dh_st DH;
                ^~~~~
make[2]: *** [dcpp/CMakeFiles/dcpp.dir/build.make:327: dcpp/CMakeFiles/dcpp.dir/CryptoManager.cpp.o] Ошибка 1
make[1]: *** [CMakeFiles/Makefile2:303: dcpp/CMakeFiles/dcpp.dir/all] Ошибка 2
make: *** [Makefile:130: all] Ошибка 2
==> ОШИБКА: Произошел сбой в package_eiskaltdcpp-gtk().
    Прерывание...
</code>
в этом случае такое ощущение что что то требуется до установить в систему.
Подскажите пожалуйста как решить проблему.
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.