Софт
   567

Устанавливаем my-weather-indicator

Юзал я его когда-то на убунте, решил запилить в манджарке, но в ауре не нашел, немного погуглил и нашел PKGBUILD для старой версии, заменил в нём данные на новые, доустановил зависимости, и он таки заработал))
кому интересно, выкладываю билд
PKGBUILD
# Maintainer: Ner0

pkgname=my-weather-indicator
pkgver=0.7.0
pkgrel=1
pkgdesc=«A simple weather indicator»
arch=('any')
url=«www.launchpad.net/my-weather-indicator»
license=('GPL3')
depends=('hicolor-icon-theme' 'python2' 'libchamplain' 'lsb-release' 'gtk3' 'gdk-pixbuf2' 'libappindicator3' 'python2-lxml' 'python2-dateutil' 'python-geoip' 'python2-geoclue' 'python-pytz' 'python2-pytz' 'libnotify')
makedepends=('python2-distutils-extra' 'python2-polib')
#install=$pkgname.install
source=(«launchpad.net/~atareao/+archive/test/+files/${pkgname}_$pkgver-0extras15.10.0.tar.xz»)
md5sums=('173374a35613ec53731aec050a9928d5')

package() {
cd $pkgname

sed -i 's/-langpack//' setup.py src/comun.py
sed -i 's/python$/python2/;s/env\ python\ /env\ python2/' src/*.py bin/$pkgname

python2 setup.py install --root="$pkgdir/" --optimize=1
}

# vim:set ts=2 sw=2 et:

Ну, и естественно, картинка
Софт: устанавливаем my-weather-indicator
Зы. чтобы установить сохраняем текст под спойлером в файл PKGBUILD(ИМЕННО КАПСЛОКОМ), в папке с pkgbuild`ом запускаем терминал и в нем команду makepkg, если будет выдавать ошибку «неудовлетворенные зависимости» надо их доустановить командой yaourt -S имя_пакета

1 комментарий

avatar
Нормуль, спасибо, завтра в Гноме поставлю
?
Свежие новости мира информационных технологий ТехноДжем
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.