Софт
   1301

Утилита Downgrade

И снова из эгоистичных побуждений, то есть больше для себя, чем для других, но уверен многим, кто не знал о существовании этой утилиты, она придётся по вкусу, выкладываю этот пост.

Нередко бывает так, что новая версияя какого то приложения функционирует не так как хотелось бы, или принципиально необходима старая версия, в данном случае для облегчения жизни на помощь приходит маленькая утилита с незамысловатым названием downgrade.
Устанавливается:
sudo pacman -S downgrade

или
yaourt -S downgrade

Использование на примере firefox:
downgrade firefox

терминал ответит:
[manjarqo@manjarqo-pc ~]$ downgrade firefox
Available packages:

   1) firefox-43.0.1-2-i686.pkg.tar.xz (local)
   2) firefox-43.0.1-2-i686.pkg.tar.xz (remote)
   3) firefox-43.0.1-1-i686.pkg.tar.xz (remote)
   4) firefox-43.0-2-i686.pkg.tar.xz (remote)
   5) firefox-43.0-1-i686.pkg.tar.xz (remote)
   6) firefox-42.0-3-i686.pkg.tar.xz (remote)
   7) firefox-42.0-2-i686.pkg.tar.xz (remote)
   8) firefox-42.0-1-i686.pkg.tar.xz (remote)
   9) firefox-41.0.2-1-i686.pkg.tar.xz (remote)
  10) firefox-41.0.1-1-i686.pkg.tar.xz (remote)
  11) firefox-41.0-1-i686.pkg.tar.xz (remote)
  12) firefox-40.0.3-1-i686.pkg.tar.xz (remote)
  13) firefox-40.0.2-1-i686.pkg.tar.xz (remote)
  14) firefox-34.0.5-1-i686.pkg.tar.xz (remote)
  15) firefox-33.1.1-1-i686.pkg.tar.xz (remote)
  16) firefox-33.1-2-i686.pkg.tar.xz (remote)
  17) firefox-33.1-1-i686.pkg.tar.xz (remote)
  18) firefox-33.0.3-1-i686.pkg.tar.xz (remote)
  19) firefox-33.0.2-1-i686.pkg.tar.xz (remote)
  20) firefox-33.0.1-1-i686.pkg.tar.xz (remote)
  21) firefox-33.0-2-i686.pkg.tar.xz (remote)
  22) firefox-33.0-1-i686.pkg.tar.xz (remote)
  23) firefox-32.0.3-1-i686.pkg.tar.xz (remote)
  24) firefox-32.0.2-1-i686.pkg.tar.xz (remote)
  25) firefox-32.0.1-1-i686.pkg.tar.xz (remote)
  26) firefox-32.0-1-i686.pkg.tar.xz (remote)
  27) firefox-31.0-1-i686.pkg.tar.xz (remote)
  28) firefox-30.0-1-i686.pkg.tar.xz (remote)
  29) firefox-29.0.1-2-i686.pkg.tar.xz (remote)
  30) firefox-29.0.1-1-i686.pkg.tar.xz (remote)
  31) firefox-29.0-1-i686.pkg.tar.xz (remote)
  32) firefox-28.0-1-i686.pkg.tar.xz (remote)
  33) firefox-27.0.1-1-i686.pkg.tar.xz (remote)
  34) firefox-27.0-1-i686.pkg.tar.xz (remote)
  35) firefox-26.0-2-i686.pkg.tar.xz (remote)
  36) firefox-26.0-1-i686.pkg.tar.xz (remote)
  37) firefox-25.0.1-1-i686.pkg.tar.xz (remote)
  38) firefox-25.0-1-i686.pkg.tar.xz (remote)

предложив любую из ранних версий firefox, нам остаётся только ввести цифру соответствующую версии пакета и нажать enter, произойдёт понижение версии до необходимой. После установки старой версии пакета, утилита предложит внести изменения в /etc/pacman.conf чтобы «пониженное» приложение не обновлялось на более новую версию

2 комментария

avatar
Спасибо за наводку, хорошая весчь!
0
avatar
Следует отметить, что утилита помимо кэша системы, также ведет поиск в базе данных A.R.M., т.е. напрямую в репозитории Arch. Таким образом, существует вероятность, что такой пакет запросит новые зависимости, не предусмотренные собственным репозиторием Manjaro. Кроме того, если кэш системы вычищен, то снизить версию собственного пакета Manjaro (к примеру, mhwd) таким образом уже не получиться.
+2
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.