Ядро & Оборудование
   970

Перестал подключатся ntfs раздел

Доброго времени суток.
Может кто сталкивался с такой проблемой.
К системе подключен диск, на нем два раздела ntfs и один ext4.
В один не очень прекрасный момент один из разделов ntfs перестал подключаться.
Выводит:
«Error mounting /dev/sdb5 at /run/media/06D7AA2026559A28: wrong fs type, bad option, bad superblock on /dev/sdb5, missing codepage or helper program, or other error»
Остальные разделы работают нормально. Из винды этот раздел так же работает нормально.
Можете посоветовать как решить проблему?

15 комментариев

avatar
sudo ntfsfix /dev/sdb5
0
avatar
«Mounting volume… OK
Processing of $MFT and $MFTMirr completed successfully.
Checking the alternate boot sector… OK
NTFS volume version is 3.1.
NTFS partition /dev/sdb5 was processed successfully.»

И никаких результатов.
0
avatar
Опробуй это
sudo mount /dev/sdb5 /mnt 

Мне помогло. Буквально параллельно поймал подобный затык.
Это получается команда «монтировать» тупо, в обход файлового менеджера с его ошибками
Последний раз редактировалось
0
avatar
Да прямое монтирование работает.
0
avatar
Или даже в моем случае так, если нужен доступ программам. Я первой командой создал папку чтоб у нее был чисто адрес нужного раздела как раньше, а второй примонтировал именно туда

Спойлер!
sudo mkdir /run/media/tosha/Home

sudo mount /dev/sdb2 /run/media/tosha/Home


Может отпасть при перезагрузке, не проверял
Последний раз редактировалось
0
avatar
неа, это не работает
0
avatar
Я так понимаю, где-то должна висеть эта чертова ошибка, блокирующая доступ к разделу. Но где? И как ее вырезать?
0
avatar
Вот это и не понятно, потому что второй раздел ntfs монтируется нормально, да и этот раньше монтировался нормально. Если бы была проблема с ntfs в целом, то не монтировались бы оба.
0
avatar
Все монтируется вручную. Но одноразово. Вопрос, какого хрена оно отказывается подхватывать при старте? Какой-то новый баг мб. Пишет «там где-то есть ошибка», а чего за ошибка… Бред
0
avatar
Странно, что почти одновременно. У нас с тобой и еще двух знакомых. Даже без обнов самых свежих. Как по таймеру…
0
avatar
Прописал в fstab помогло. Но что за магия вопрос не покидает.
0
avatar
Покажи как сделал
0
avatar
Эээ… Говорю же прописал в fstab.
Но если детально то:
<code>sudo nano /etc/fstab</code>
И добавляем строчку вида:
<code>/dev/sdb5 /run/media/06D7AA2026559A28 ntfs-3g rw,nosuid,nodev,allow_other,default_permissions,blksize=4096 0 0</code>
Вообще это делается для автоматического монтирования, и мне не понятно, почему это работает, ручное монтирование работает, а монтирование через дельфин нет.
0
avatar
Это в целом баг либо дельфина, либо манджаро что то сделала с дельфинов. Так как запустил манджару лив, и ни один раздел нтфс не смог смонтировать. А вот через терминал все гуд.
Последний раз редактировалось
0
avatar
сымитировал вашу ситуацию…
может кому будет интересно…
покоцал в винде пару файлов на ntfs.
перешел на линь, опа проводником не монтируется, в ручную запросто. ну прям как у вас.
ну я то знаю какие покоцал — удалять давай — ни в какую не хочет, хотя бита лишнего нет, обычный rwx,
пошел обратно на винду и сделал обычную проверку файловой системы. потребовала восстановление.
и все, все неполадки закончились, линь спокойно подхватывает ntfs проводником.
а вы я так понимаю, просто костыль замутили :)
+1
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.