Manjaro KDE Edition
   526

Зависания и артефакты в KDE (РЕШЕНО)

Добрый день! Начались проблемы в поведении системы:
При переключении между окнами с панели задач появляются мерцающие артефакты. После перехода в ждущий режим система какое-то время тормозит. Особенно браузер google-chrome минут 5 вообще не реагирует. После восстановления из спящего режима (гибернация) система вообще не реагирует ни на что. Только мышь двигается и всё.
Прошу подсказать в чём может быть проблема. Нужно ли ставить другие драйвера видеокарты? Если да, то какие.

Заранее благодарен за советы!
Драйверы
mhwd -l
> 0000:01:00.0 (0300:10de:1f11) Display controller nVidia Corporation:
— NAME VERSION FREEDRIVER TYPE
— video-hybrid-intel-nvidia-prime 2023.03.23 false PCI
video-hybrid-intel-nvidia-470xx-prime 2023.03.23 false PCI
video-nvidia 2023.03.23 false PCI
video-nvidia-470xx 2023.03.23 false PCI
video-linux 2018.05.04 true PCI
video-modesetting 2020.01.13 true PCI
video-vesa 2017.03.12 true PCI

> 0000:00:02.0 (0300:8086:3e9b) Display controller Intel Corporation:
— NAME VERSION FREEDRIVER TYPE
— video-hybrid-intel-nvidia-prime 2023.03.23 false PCI
video-hybrid-intel-nvidia-470xx-prime 2023.03.23 false PCI
video-linux 2018.05.04 true PCI
video-modesetting 2020.01.13 true PCI
video-vesa 2017.03.12 true PCI

Информация о системе
System:
Host: pc Kernel: 6.1.69-1-MANJARO arch: x86_64 bits: 64 Desktop: KDE Plasma
v: 5.27.10 Distro: Manjaro Linux
Machine:
Type: Laptop System: Dell product: G5 5590 v: N/A
CPU:
Info: 6-core model: Intel Core i7-9750H bits: 64 type: MT MCP cache:
L2: 1.5 MiB
Speed (MHz): avg: 800 min/max: 800/4500 cores: 1: 800 2: 800 3: 800 4: 800
5: 800 6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800
Graphics:
Message: PCI device data requires root.
Device-1: Microdia Integrated_Webcam_HD driver: uvcvideo type: USB
Display: x11 server: X.Org v: 21.1.10 driver: X:
loaded: modesetting,nvidia unloaded: nouveau dri: iris gpu: N/A resolution:
1: 1920x1080~60Hz 2: 1920x1080~60Hz
API: EGL v: 1.5 drivers: iris,nvidia,swrast
platforms: gbm,x11,surfaceless,device
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 23.1.9-manjaro1.1
renderer: Mesa Intel UHD Graphics 630 (CFL GT2)
API: Vulkan v: 1.3.274 drivers: nvidia,intel surfaces: xcb,xlib
Drives:
Local Storage: total: 1.86 TiB used: 647.8 GiB (34.0%)
ID-1: /dev/nvme0n1 vendor: Seagate model: XPG GAMMIX S11 Pro
size: 1.86 TiB
Partition:
ID-1: / size: 1006.85 GiB used: 647.8 GiB (64.3%) fs: ext4
dev: /dev/nvme0n1p5
Swap:
ID-1: swap-1 type: file size: 20 GiB used: 0 KiB (0.0%) file: /swapfile
Sensors:
System Temperatures: cpu: 44.0 C pch: 45.0 C mobo: 39.0 C
Fan Speeds (rpm): cpu: 0 fan-1: 0
Info:
Processes: 324 Uptime: 16m Memory: total: 16 GiB available: 15.44 GiB
used: 5.82 GiB (37.7%) Shell: Zsh inxi: 3.3.31

1 комментарий

avatar
После проверки разных комбинаций драйверов установил
video-hybrid-intel-nvidia-470xx-prime
и похоже это решило проблему. По крайней мере пока не видел артефактов и зависаний, в т.ч. после ждущего режима и гибернации.
Сейчас конфигурация такая:
Драйвера
mhwd --listinstalled
> Installed PCI configs:
— NAME VERSION FREEDRIVER TYPE
— video-hybrid-intel-nvidia-470xx-prime 2023.03.23 false PCI
video-modesetting 2020.01.13 true PCI

inxi
inxi -aG
Graphics:
Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Dell
driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
ports: active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0
chip-ID: 8086:3e9b class-ID: 0300
Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: Dell
driver: nvidia v: 470.223.02 alternate: nouveau,nvidia_drm non-free: 545.xx+
status: current (as of 2023-11; EOL~2026-12-xx) arch: Turing code: TUxxx
process: TSMC 12nm FF built: 2018-2022 pcie: gen: 1 speed: 2.5 GT/s
lanes: 8 link-max: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.0
chip-ID: 10de:1f11 class-ID: 0300
Device-3: Microdia Integrated_Webcam_HD driver: uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:3 chip-ID: 0c45:671f
class-ID: 0e02
Display: x11 server: X.Org v: 21.1.10 compositor: kwin_x11 driver: X:
loaded: modesetting,nvidia alternate: fbdev,nouveau,nv,vesa dri: iris
gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1013x285mm (39.88x11.22")
s-diag: 1052mm (41.43")
Monitor-1: HDMI-1-0 pos: primary,right res: 1920x1080 hz: 60 dpi: 92
size: 531x299mm (20.91x11.77") diag: 609mm (23.99") modes: N/A
Monitor-2: eDP-1 pos: left res: 1920x1080 hz: 60 dpi: 142
size: 344x194mm (13.54x7.64") diag: 395mm (15.55") modes: N/A
API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
drv: nvidia device: 1 drv: iris device: 3 drv: swrast gbm: drv: iris
surfaceless: drv: iris x11: drv: iris inactive: wayland,device-2
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 23.3.3-manjaro1.1
glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics 630 (CFL
GT2) device-ID: 8086:3e9b memory: 15.08 GiB unified: yes
API: Vulkan v: 1.3.274 layers: 1 device: 0 type: discrete-gpu
name: NVIDIA GeForce RTX 2060 driver: nvidia v: 470.223.02
device-ID: 10de:1f11 surfaces: xcb,xlib
Последний раз редактировалось
0
Автор топика запретил добавлять комментарии