Уголок новичка
   1226

Помогите исправить ошибку removing samba breaks dependency

Здравствуйте! Установил Manjaro Kde. Первым начал установку приложений. Не могу ничего установить, ни chromium, ни telegram, вообще ничего, даже обновления не даёт скачать
Выдаёт ошибку:

Ошибка: Ошибка подготовки транзакции:
не удалось удовлетворить зависимости:
— удаление samba нарушает зависимость «samba», необходимую для kdenetwork-filesharing
(removing samba breaks dependency 'samba' required by kdenetwork-filesharing)

sudo pacman -S libreoffice-fresh libreoffice-fresh-ru выдало ошибку
разрешение зависимостей…
проверка конфликтов…
ошибка: не удалось подготовить транзакцию (не удалось удовлетворить зависимости)
:: installing icu (69.1-1) breaks dependency 'libicuuc.so=72-64' required by raptor

Что происходит? (я ничего не нажимал!!))))

Образ качал с официального сайта
Переустановил manjaro — ошибка сохранилась

2 комментария

avatar
Ошибка возникает не только с самбой, но и практически с любым другим пакетом. Я подобное решал удалением последовательно всех зависимостей, а потом, после того как удалится нужный мне пакет, без перезагрузки компьютера возвращал х обратно, т.к, большинство пакетов никак по идее не должны быть зависимостями, удаляемого.
sudo pacman -Rns имя пакета.
Но мне самому интересно, как решить эту проблему, чтобы эта ошибк больше не возникала без переустановки системы из свежего образа.
0
avatar
В общем я не знаю, что там происходило. Но последним я сделал

sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro
sudo pacman-mirrors -g
udo pacman -Syyuu

Сейчас приложения скачались
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.