Уголок новичка
   1095

Помогите обновить систему

Здравствуйте. У меня не получается обновить систему. Первый разкогда столкнулся с проблеммой просто забыл про нее, работает же все. Позже опять попробовал, было три конфликта, два я устранил удалив пакеты, а один не получилось. Ну и опять на пару месяцев забросил. Но проблемму то решать надо. Подскажите как вот с этим разобраться и обновить систему:
ошибка: не удалось подготовить транзакцию (не удалось удовлетворить зависимости)
:: installing pacman (6.0.1-2) breaks dependency 'pacman<5.3' required by package-query

6 комментариев

avatar
yay -R package-query  pamac remove package-query sudo pacman -R package-query
пробуйте любую из этих команд
Последний раз редактировалось
?
p5ql/epu q9300 clover,hackintosh,mint,void,manjaro,only kde
0
avatar
$ sudo pacman -R package-query
[sudo] пароль для zzplex:
проверка зависимостей…
ошибка: не удалось подготовить транзакцию (не удалось удовлетворить зависимости)
:: removing package-query breaks dependency 'package-query>=1.8' required by yaourt
0
avatar
sudo pacman -Rdd package-query
затем sudo pacman -Syu
Последний раз редактировалось
?
p5ql/epu q9300 clover,hackintosh,mint,void,manjaro,only kde
+1
avatar
ничего не понял
0
avatar
Все понял. Установил. Вроде пошло обновление. Спасибо.
0
avatar
Удачи.
?
p5ql/epu q9300 clover,hackintosh,mint,void,manjaro,only kde
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.