Ядро & Оборудование
   764

[Решено] Не работает WiFi после обновления ядра до 5.11

Всем доброго времени суток

Столкнулся с проблемой после обновлений Manjaro до версии ядра 5.11 — перестает работать WiFi. При этом, если загружаться на ядре 5.10, то все работает отлично со старта.
Использую ноутбук ASUS K50ij. Wifi модуль Qualcomm Atheros. Окружение XFCE

Ниже привожу вывод команды inxi -N:
Network:
Device-1: Qualcomm Atheros AR9285 Wireless Network Adapter driver: ath9k 
Device-2: Qualcomm Atheros AR8121/AR8113/AR8114 Gigabit or Fast Ethernet 
driver: ATL1E


При наборе в терминале sudo dmesg | grep -i ath получаю следующий вывод:
[    4.798929] systemd[1]: Reached target Paths.
[    8.597944] ath: phy0: Enable LNA combining
[    8.600519] ath: phy0: ASPM enabled: 0x42
[    8.600542] ath: EEPROM regdomain: 0x8283
[    8.600545] ath: EEPROM indicates we should expect a country code
[    8.600551] ath: doing EEPROM country->regdmn map search
[    8.600553] ath: country maps to regdmn code: 0x3d
[    8.600555] ath: Country alpha2 being used: RU
[    8.600556] ath: Regpair used: 0x3d
[    8.613468] ieee80211 phy0: Atheros AR9285 Rev:2 mem=0xffffa24fc0d80000, irq=17
[    8.628415] ath9k 0000:02:00.0 wlp2s0: renamed from wlan0


Быть может при загрузке ядра 5.11 необходимо что-то дополнительно донастраивать или где-то слетают какие-то параметры в системе? Подскажите, кто более компетентен в данной теме, буду благодарен за любую помощь ;)

17 комментариев

avatar
Ща придут два умника и будут вам тут втирать почему у Манжары постоянно какие то прыщи…
Если этим человек говорит — то они тебя обсирают — эти два чуда самые умные…

они никогда не подскажут новичку — они пошлют его читать арчвики
они до того охуели что сравняли форум Арча с дебилоидным этим Манжары,
хотя пиздят что для новичков манжара…

Да вы зайдите в форум — не этой задроченной манжары где постоянно что ломается
а хотя бы в дружественный EOS… — там люди как люди…

п.с. для тупорылых я забыл обьяснить одну хотя бы проблему у манжары
пакеты обновляются с задержкой — а в Ауре без задержки — вы два тупых тут долбаебов понимаете чем это грозит… и вы говорите о стабильности системы?

Да в арче такого НЕТ беспредела
два тупых сидят тут и доказывают — а что доказывать? — вы посмотрите у вас постоянно всё ломается а в арче такого нет…

Значит они обновляют пакеты с задержкой — а АУР то в реале обновлятся и получается что?
?
Satyan Nasti Paro Dharmah
0
avatar
Сидят два УМНЫХ и типа как в Арче всезх нахуй посылают в вику…
если у вас дружелюбная система — так и помогайте дружелюбно…

два идиота с манией величия
?
Satyan Nasti Paro Dharmah
0
avatar
Да если бы Манжара стабильнее была — у вас тут бы не было косяков…

зайдите на форум Арча… — а у вас постоянно какая то хуйня ))) — потому что вы тупые
вы даже человеку не можете сказать — почему у него поломалось в кде русификация, хотя об этом в Арче нет и в кде от арча…

почему я вам и говорил — криворукие… — вы блять всё ломаете и потом народ страдает
охуенно для новичков манжара
?
Satyan Nasti Paro Dharmah
0
avatar
Я не говорю что Манжара плохая — я говорю о том — если она дружелюбная
значит и люди такие быть должны, — а то это хамье (посмотри сколько у меня)

вы не должны этим кичится — вы не на форуме Арча где вас пошлют,
а здесь вы значит герои — сидите на детской манжаре и выёбываетесь как они…

Ты кто такой? — давай я к тебе приду и я тебя научу общаться по хорошему…
ты понимаешь — меня не должно волновать — твой хуй мелкий и ты… — я старше тебя и ты общайся с народом по хорошему
?
Satyan Nasti Paro Dharmah
0
avatar
Gambit_VKM
ты понял меня?
и щенка своего приструни
?
Satyan Nasti Paro Dharmah
0
avatar
У меня для тебя есть три слова. На картинке под спойлером.


И ты заебал поливать тут все собственной анальной кровью.
0
avatar
Не обижайся что я нафлудил — эти два уёбища специально не будут подсказывать…

У меня нет вайфая… — ну я уверен тебе подскажут и без них
?
Satyan Nasti Paro Dharmah
0
avatar
lsmod | grep ath9k
что говорит?
Последний раз редактировалось
0
avatar

$ lsmod | grep ath9k
ath9k                 180224  0
ath9k_common           40960  1 ath9k
ath9k_hw              520192  2 ath9k_common,ath9k
ath                    36864  3 ath9k_common,ath9k,ath9k_hw
mac80211             1171456  2 ath9k,ath9k_hw
cfg80211             1040384  4 ath9k_common,ath9k,ath,mac80211
Последний раз редактировалось
0
avatar
Модуль загружен.
ip address show 

В выводе данной команды карточка есть?
Rfkill пишет unblocked?
Последний раз редактировалось
0
avatar
Вот что выводят комманды:
rfkill
ID TYPE  DEVICE          SOFT      HARD
 0 wwan  asus-wwan  unblocked unblocked
 1 wimax asus-wimax unblocked unblocked
 2 wlan  phy0       unblocked unblocked

Все вроде бы unblocked

$ ip address show 
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp3s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 90:e6:ba:5c:12:25 brd ff:ff:ff:ff:ff:ff
3: wlp2s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
    link/ether fe:ae:95:5e:a3:e9 brd ff:ff:ff:ff:ff:ff permaddr 00:25:d3:80:f8:84

По wlp2s0 меня насторожили фразы NO-CARRIER и state DOWN, но когда пробую прогнать команду


sudo ifconfig wlp2s0 up

ничего не происходит :(
Последний раз редактировалось
0
avatar
ifconfig
Net-tools доставляли руками? Сейчас по дефолту ip из состава iproute2 идет и ifconfig в системе нет.
Вообще сети у Вас через NetworkManager рулятся?
Последний раз редактировалось
0
avatar
Да, Net-tools устанавливал руками отдельно и, все верно, рулится сеть через NetworkManager
0
avatar
ip при попытке поднять линк что-нибудь говорит или как и ifconfig завершается молча?
echo $? при манипуляциях с i(w|fconfig) возвращает 0? Если да, то получается что все отрабатывает и уже потом линк падает.
Последний раз редактировалось
0
avatar
При загрузке под ядром 5.10 вывод команды ip address show в части WiFi имеет следующий вид:

3: wlp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 00:25:d3:80:f8:84 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.17/24 brd 192.168.1.255 scope global dynamic noprefixroute wlp2s0
       valid_lft 27411sec preferred_lft 27411sec
    inet6 fe80::8f39:d98c:70dd:7f2b/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
Последний раз редактировалось
0
avatar
Gambit_VKM, спасибо большое за попытки помочь с моей проблемой! Получилось самостоятельно ее устранить после долгих поисков схожих случаев в интернет. Проблема была на стороне роутера. Что заставило меня «копать» в этом направлении — так то что вывод команды
sudo iw wlp2s0 scan | grep SSID
не отобразил в списке мою точку доступа вообще.
Оказывается, проблема была в том, что у меня в настройках роутера был выставлен самый незанятый канал, и им был канал №13. После смены канала на «Авто», система сразу же подключилась к сети. В чем именно был нюанс того, что на ядре 5.11 он автоматически не хотел подключаться, а на ядре 5.10 работало все без проблем, мне не понятно. Но факт на лицо — с автоматическим определением канала (а больше я ничего не менял) — все работает отлично.
Еще раз спасибо за помощь
Последний раз редактировалось
0
avatar
ЕМНИП, на atheros'ах была проблема с n-диапозоном. Возможно ноги растут оттуда.
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.