Уголок новичка
   1200

Черный экран при загрузке.

Доброго времени суток. Установлена манджаро последней версии, из официального источника, с ядром 5.2.11-1. После обновления системы (и ядра в том числе до версии 5.4… дальше не помню) при загрузке наблюдается черный экран, на нажатия кнопок нет реакции, на ctrl+alt+F2 в т.ч, перезагрузка только кнопкой питания. Такая же ситуация при загрузке с LTS ядра 4.19.4.94_rt39-1. Как быть? При загрузке с ядра 5.2.11-1 все работает хорошо.
Мне кажется, что тут может быть несовместимость с моим ноутбуком. Поэтому- можно ли не обновляя систему установить пару программ из репозитория? Пробовал ставить wine из терминала, начинает качать около 500 мб, но потом ругается на «ошибка: не удалось завершить транзакцию (не удалось запустить сценарии обработки)» и «Обнаружены ошибки, пакеты не обновлены.»

55 комментариев

avatar
Так же пробовал редактировать GRUB, как описано здесь zen.yandex.ru/media/mdex/chernyi-ekran-posle-zagruzki-linux-5d7ba053c7e50c00ad881a00
Но не получилось, хотя вероятно мог не туда дописывать «nomodeset», т.к. есть отличия в примере и моего загрузчика.
0
avatar
Если стоят драйвера на видеокарту, то удали, перезагрузись на новое ядро и установи заново. У меня было такое при обнове ядра 5.4, с видюхой nvidia.
Последний раз редактировалось
0
avatar
Какой из этих двух?

И еще- при обновлении ядро 5.2 пропадает, как его сохранить?
Последний раз редактировалось
0
avatar
Я думал у тебя стоят проприетарные. Хмм…
Тогда попробуй модули ядра 5.4 обновить и загрузится на нём.
sudo mkinitcpio -p linux54
И еще- при обновлении ядро 5.2 пропадает, как его сохранить?
То есть обновляешься появляется ядро 5.4, а 5.2 пропадает? В принципе логично ведь оно уже не поддерживается.
Поставь ядро не 4.19.4.94_rt39-1, а 4.19.99-1, с ним должно работать.
Одним словом сначала ставь 4.19.99-1 и грузись с него, потом пробуй обновляться.
Последний раз редактировалось
+1
avatar

Установлены ядра 4.19.99-1 и 5.4.15.2, но в менеджере ядер (не знаю как правильно его назвать) все еще доступна кнопка «установить». При ее нажатии выскакивает сообщение:

Жму «Да», вот что пишет в деталях:
The following packages will be installed:
linux419
linux419-rt

Starting
resolving dependencies…
warning: linux419-rt-4.19.94_rt39-1 is up to date — reinstalling
looking for conflicting packages…
Packages (2) linux419-4.19.99-1 linux419-rt-4.19.94_rt39-1
Total Installed Size: 249.94 MiB
Net Upgrade Size: 120.51 MiB
:: Proceed with installation? [Y/n]
checking keyring…
checking package integrity…
loading package files…
checking for file conflicts…
checking available disk space…
Errors occurred, no packages were upgraded.
error: hook /usr/share/libalpm/hooks/90-mkinitcpio-install.hook line 2: invalid value Path
error: hook /usr/share/libalpm/hooks/60-mkinitcpio-remove.hook line 2: invalid value Path
error: failed to commit transaction (failed to run transaction hooks)

Готово...
Ядро 4.19.4.94_rt39-1 удалил. Но оно есть в меню GRUB, оно и текущее 5.2. Но в GRUB так же нет установленных 5.4.15.2 и 4.19.99-1.
Команда sudo mkinitcpio -p linux54 выдает:
/usr/bin/mkinitcpio: строка 265: /etc/mkinitcpio.d/linux54.preset: Нет такого файла или каталога
==> ERROR: Failed to load preset: `/etc/mkinitcpio.d/linux54.preset'
Последний раз редактировалось
0
avatar
sudo update-grub сделай и посмотри.
0
avatar
делал, все так же
0
avatar
А ядра 4.19.99-1 и 5.4.15.2, ты не в менеджере ядер устанавливал?
0
avatar
А 5.4.15.2 без ошибок устанавливается, просто в grub не видно?
Последний раз редактировалось
0
avatar
The following packages will be installed:
linux54
linux54-rt

Starting
resolving dependencies…
looking for conflicting packages…
Packages (2) linux54-5.4.15-2 linux54-rt-5.4.13_rt7-1
Total Installed Size: 284.18 MiB
:: Proceed with installation? [Y/n]
checking keyring…
checking package integrity…
loading package files…
checking for file conflicts…
checking available disk space…
Errors occurred, no packages were upgraded.
error: hook /usr/share/libalpm/hooks/90-mkinitcpio-install.hook line 2: invalid value Path
error: hook /usr/share/libalpm/hooks/60-mkinitcpio-remove.hook line 2: invalid value Path
error: failed to commit transaction (failed to run transaction hooks)

Готово...
0
avatar
del
Последний раз редактировалось
0
avatar
Получилось установить ядра, после удаления этих 2-х файлов). Пробую дальше.
0
avatar
del и это сообщение)
Последний раз редактировалось
0
avatar
Не получилось загрузиться с новых ядер, нужных кстати в списке нет. Вот что есть:

Менеджер ядер (и в нем всё вроде ок):
0
avatar
может те что с приставкой rt нужно удалить?
0
avatar
Ты бэкапы делаешь? Таймшифтом например?
0
avatar
это что? наверное не делаю)
0
avatar
Почитай compizomania.blogspot.com/2017/10/timeshift-linux.html
Установить sudo pacman -S timeshift
Несколько минут и будет сделан снимок системы который можно за две минуты восстановить потом.
Если даже вообще систему угробишь, то можно с флешки загрузится и воостановить.
Последний раз редактировалось
+1
avatar
как в ручную ставить?
0
avatar
А попробуй ещё и в ручную установить.
А вообще странно конечно. Надо побеждать)
Последний раз редактировалось
0
avatar
тут по-моему нет нужного
$ mhwd-kernel -l
available kernels:
* linux316
* linux414
* linux419
* linux44
* linux49
* linux53
* linux54
* linux55
* linux419-rt
* linux54-rt
0
avatar
Всё есть, просто сокращённо написано) Это те которые можно установить.
А сделай sudo update-grub и вывод сюда скопируй.
Последний раз редактировалось
0
avatar
Ага, разобрался. вот так 5.4 установился:
Пакеты (1) linux54-5.4.15-2

Будет установлено: 139,53 MiB
Изменение размера: 0,00 MiB

:: Приступить к установке? [Y/n] y
(1/1) проверка ключей [####################################################################] 100%
(1/1) проверка целостности пакета [####################################################################] 100%
(1/1) загрузка файлов пакетов [####################################################################] 100%
(1/1) проверка конфликтов файлов [####################################################################] 100%
(1/1) проверка доступного места [####################################################################] 100%
:: Обработка изменений пакета…
(1/1) переустановка linux54 [####################################################################] 100%
:: Запуск post-transaction hooks…
(1/1) Arming ConditionNeedsUpdate…

А вот так 4.19:
Пакеты (1) linux419-4.19.99-1

Будет установлено: 120,51 MiB
Изменение размера: 0,00 MiB

:: Приступить к установке? [Y/n] y
(1/1) проверка ключей [####################################################################] 100%
(1/1) проверка целостности пакета [####################################################################] 100%
(1/1) загрузка файлов пакетов [####################################################################] 100%
(1/1) проверка конфликтов файлов [####################################################################] 100%
(1/1) проверка доступного места [####################################################################] 100%
:: Обработка изменений пакета…
(1/1) переустановка linux419 [####################################################################] 100%
:: Запуск post-transaction hooks…
(1/1) Arming ConditionNeedsUpdate...
0
avatar
Ты всё же timeshift установи. Я перед каждым обновление делаю снимок системы, обновляюсь и если всё норм делаю уже после обновы.
0
avatar
Я сейчас установить ничего не могу, т.к. вместе с установкой идет обновление всей системы, и потом черный экран).
Последний раз редактировалось
0
avatar
да и бэкапить нечего по сути
0
avatar
опять нет.
sudo update-grub
Generating grub configuration file…
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.4-rt-x86_64
Found initrd image: /boot/intel-ucode.img
Found linux image: /boot/vmlinuz-5.2-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.2-x86_64.img
Found initrd fallback image: /boot/initramfs-5.2-x86_64-fallback.img
Found linux image: /boot/vmlinuz-4.19-rt-x86_64
Found initrd image: /boot/intel-ucode.img
Found Windows 10 on /dev/sda1
Found memtest86+ image: /boot/memtest86+/memtest.bin
done
Последний раз редактировалось
0
avatar
Да уж…
Пробуй 5.5 тогда. Может с ним получится.
0
avatar
Ок, сейчас попробую. Вот если не получится- есть ли способ установить wine и qbittorrent минуя обновление всей системы?
0
avatar
Мне больше пока ничего не надо, весь замут с обновой только из-за этих двух прог.
0
avatar
Честно говоря не знаю.
Посмотри в /boot/ что у тебя есть.
0
avatar
А что там должно быть?
0
avatar
У тебя отсутствуют vmlinuz для 5.4 и 4.19, а также файлы .img этих ядер.
Последний раз редактировалось
0
avatar
А что делать?
0
avatar
Экспериментировать)
Я тебе сейчас файлы от ядра 5.4 скину, ты их туда и закинешь, сделаешь sudo update-grub и всё пойдёт. Добавлю сюда ссылку.
0
avatar
Держи drive.google.com/open?id=15khM8wgevi_t3us5klngW3s5fEvBW33D
Обязательно после копирования sudo update-grub
Тогда должно ядро появится.
+1
avatar
5.5 -то же самое… нет в списке
Последний раз редактировалось
0
avatar
Может grub.cfg (если не ошибаюсь) как то руками нужно править, и добавить новые ядра?
0
avatar
kasatik, ты там живой хоть)
0
avatar
я пытаюсь через консоль скопировать файлы)) т.к. dolphin под рутом не открывается почему то
0
avatar
Нажми завершить сеанс --> сменить пользователя
root
пароль
Тогда будешь в системе под рутом.
+1
avatar
Судя по обсуждению- здесь что-то изначально идёт неправильно. Прежде всего зачем ставить устаревший образ, да еще и с ядром поддержка которого прекращена, если доступен актуальный?
Бросьте это дело, скачайте отсюда manjaro-xfce-18.1.5-191229-linux54.iso
и ставьте его.
?
Правильные ответы начинаются с правильных вопросов.
+1
avatar
Судя по обсуждению- здесь что-то изначально идёт неправильно.

Тут ядра Шрёдингера.
Хоспадя, прочитал и понял как это звучит)
Последний раз редактировалось
+1
avatar
Так я с этого сайта скачивал образ дня три назад))) Блин) Торрент почему то был пустой, а с сервера manjaro.ru загрузился этот образ.
0
avatar
Вот как раз три дня назад и залили свежие образы.
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
а можно на KDE ссылку?
0
avatar
?
Правильные ответы начинаются с правильных вопросов.
+1
avatar
Значит так))) Если гружусь с 5.4.15.2 то появляется следующее:
mount: /new_root: can't find UUID= дальше много цифр и букв, как понял какой-то айди моего харда.
You are now being dropped into an emergency shell.
sh: can't access tty: job control turned off
[rootfs ]# _ тут можно вводить текст.
А если гружусь с того же ядра но в конце написано «fallback initframs», то загружаюсь, и все нормально работает, сейчас с этой загрузки сижу.
0
avatar
Сравни UUID диска с записанным в fstab исправь если нужно. sudo blkid
manjaro.org/download/
И попробуй переустановить ядро в менеджере настроек.
Последний раз редактировалось
+1
avatar
На этом думаю пока всё, поставлю позже свежую Манджаро, если будет то же самое, то продолжу эту ветку. Всем спасибо. Отдельное спасибо AlexGanter))).
Последний раз редактировалось
0
avatar
Kasatik, раз уж будешь переустанавливать, то очень рекомендую изучить это:
forum.manjaro.org/t/installation-with-manjaro-architect-iso/20429
С гуглопереводчиком без проблем можно понять.
Architect офигенная штука устанавливаешь сразу что надо, а ненужное не ставишь. Я осилил и теперь у меня сохранён список пакетов, если нужно будет переустановить. Там открываешь файл и просто вставляешь свой список. Ничего лишнего короче.
Самый кайф это то что с любого образа системы загружаешься и устанавливаешь архитектом. То есть можно лазать в интернете и прямо на ходу учится.
Ну и рад был хоть чем то помочь)

P.S.
Бэкапы в первую очередь приучайся делать. Timeshift просто бомба. Один раз делает полный бэкап, а все следующие снимки только изменённый файлы. Меньше минуты делов.
Последний раз редактировалось
+1
avatar
А если вдруг черный экран появится при перезагрузки системы, например после обновления.
Но есть снимок системы в таймшифте.
Возможно ли как-то с черного экрана, с краба2, с консоли tty1 восстановиться к предыдущему снимку системы?

В ОпенСусе есть такая возможность — там прямо в крабе отображаются предыдущие сохранения системы. Но там не таймшифт, там встроенная утилита есть для снимков системы.
?
Manjaro Linux 19; KDE Plasma: 5.17.5; Intel/Nvidia
0
avatar
Сдаётся мне, что вся суть в этих строках:

...Errors occurred, no packages were upgraded.
error: hook /usr/share/libalpm/hooks/90-mkinitcpio-install.hook line 2: invalid value Path
error: hook /usr/share/libalpm/hooks/60-mkinitcpio-remove.hook line 2: invalid value Path
error: failed to commit transaction (failed to run transaction hooks)…

Сам недавно мучился с установкой, благо что на виртуалку. Причина в том, что pacman на ISO установочном стар для свежих hooks. Можно установить pacman-static и пробовать обновиться с него.

wget https://pkgbuild.com/~eschwartz/repo/x86_64-extracted/pacman-static
chmod +x pacman-static 
sudo ./pacman-static -Syyu


Решение нашёл здесь.
Обновляться, понятно дело, через терминал в chroot, если не получается войти в систему.
Последний раз редактировалось
+1
avatar
Ну, для сборок от сообщества может так оно и есть. Вполне возможно.
Но в новых образах гнома, кед и крысы- pacman вполне свежий. Той же версии что и pacman-static.
Правда тот pacman что в репах еще новее, но так оно и должно быть.
?
Правильные ответы начинаются с правильных вопросов.
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.