Уголок новичка
   579

Не видит M.2 SSD

Пытаюсь установить Manjaro Gnome, при установке не видит ссд, только жёсткий. Посмотрел в системе, система тоже видит только жёсткий с флешкой. Запущен лайв режим, запускал и с KDE, тоже самое. Нуб чёртов я в линуксе ещё, но хочу осваиваться, не могу найти информацию в интернете.
Уголок новичка: Не видит M.2 SSD
Выглядит это так, в винде ссд отображается как надо

24 комментария

avatar
а тут?
0
avatar
не могу впечатлить это скриншотом, но там только жёсткий и флешка
0
avatar
я ставил сначала KDE, и когда установил, то понял что поставил на жёсткий диск, подумал что виновата винда, и снёс её. но ссд так и не видать
0
avatar
А БИОС что говорит про SSD?
Марка SSD какая?
Последний раз редактировалось
?
i3-3210 / 4GB / VGA на борту / HDD 160ГБ / Artix (runit) / 5.10.*-lts / KDE 5.80/Plasma 5.21.* / Brave
0
avatar
всё на картинке
первый жёсткий на 2тб, второй wd black на 1тб
Последний раз редактировалось
0
avatar
Попробуй DiskUtility
0
avatar
Gparted, разве не дисковая утилита?
0
avatar
sudo fdisk /dev/sd* что показывает?
0
avatar
fdisk: bad usage
0
avatar
1. Так как это NVME, то надо посмотреть вывод lspci.
2. Нашел любопытное инфо здесь, вкратце — что-то с энергосбережением, попробуйте выставить nvme_core.default_ps_max_latency_us=0 при загрузке в GRUB.
3. Надо обновить прошивку диска.
0
avatar
1.

2. честно говоря, не знаю ничего о загрузке в GRUB, и нуждаюсь в помощи)
UPD: не знаю, сделал ли правильно, но при загрузки, точнее при выборе там языка, способа загрузки драйверов, нажал на Е, попал в что-то вроде командной строки, и ввёл твои параметры, самым последним, нажал F10, загрузился, ничего не получилось
3. на SSD есть прошивка?! UPD: сейчас посмотрел в гугле, кроме ПО на винду, ничего не нашёл.
Последний раз редактировалось
0
avatar
1. В выводе lspci ничего про этот диск нет, следовательно система не находит устройство при загрузке.

2. По ссылке есть на английском, как применить параметры в GRUB при загрузке.
Как появилось меню GRUB нажимаете букву «е» на клавиатуре, сразу после «quiet splash» дописываете «nvme_core.default_ps_max_latency_us=0». Затем продолжаете загрузку, и смотрите что получилось.

3. SSD шьются из под Винды родным для них ПО, пишут можно прошивать и под Линукс, я не пробовал.

ПС. Оригинал на английском. Значение выставляют 5500, так как чуть другая модель и известен контроллер диска

In the GRUB boot menu, press e to edit startup parameter
Add nvme_core.default_ps_max_latency_us=5500 by the end of quiet splash
Ctrl-x to boot up, the installer should detect this disk in partition step.
After finishing finish installation, press shift while power on to enter GRUB again, add same kernel parameter nvme_core.default_ps_max_latency_us=5500, Ctrl-x to boot up.
You will see Ubuntu boot up successfully, edit /etc/default/grub, add parameter nvme_core.default_ps_max_latency_us=5500 again, execute sudo update-grub. so that every time boot up will contain this parameter in the grub automatically, no more manually edit.
Последний раз редактировалось
0
avatar
насчёт прошивки

а какие данные могут помочь, чтобы выбрать правильный латенси для команды? но я запускался с твой командой, и всё тоже самое
0
avatar
Судя по этому



стоит попробовать 5500, точнее в границах между 4000 и 10000
0
avatar

это ведь этот самый GRUB?
0
avatar

тут жё всё правильно написано? кроме значения разумеется.
я ввёл уже 5500, но результат тот же
0
avatar
Нет, надо эту строку вписать после слова «quiet», наверху.
И нажать Ctrl+x.
0
avatar
нет, не помогло(
0
avatar
Биос помог, спасибо большое)
0
avatar
Вы просто в BIOS отключите безопасную загрузки и включите поддержку устаревших устройств. И все диски появятся. Сам так намучился с nvme на ноутбуке HP при установке.
0
avatar
какие пункты, можете подсказать?)
UPD: загуглил, понял. он с безопасной загрузкой, только винду запускает, так что я с самого начала отключил
Последний раз редактировалось
0
avatar
спасибо за помощь)
0
avatar
не знаю что именно помогло, но покопался я в БИОСЕ, и завёлся ссд)
0
Автор топика запретил добавлять комментарии