Уголок новичка
   541

Не воспроизводится видео/аудио после нескольких часов работы

DE — GNOME
Мать — Gigabyte H81M-S2V
Видюха — Nvidia GeForce GTX 750 ti
Проц — Intel core i3-4170
Недавно переустановил систему. После нескольких часов работы любой аудио и видео контент не воспроизводится. Звуки в играх, системные звуки, скачанная музыка, музыка в спотифае, видео на ютубе — это все не воспроизводится. Решается простой перезагрузкой, но хотелось бы все таки это поправить

5 комментариев

avatar
посмотри, через какое устройство идет воспроизведение звука когда он работает, это можно посмотреть в pavucontrol во вкладках проигрывание и устройсва вывода. также посмотреть выхлоп команд
lsof /dev/snd/*

и
inxi -A

запомнить/записать/заскриншотить все это и потом сравнить с тем, что будет после того как звук пропадет. дальше уже можно думать
зы. ну и да, что бы гаданий не было, необходимо указывать свое DE и железо в части вопроса
Последний раз редактировалось
?
Всегда есть быстрое простое неправильное решение.
быстрые простые правильные (иногда) ответы здесь t.me/manjarolinux
0
avatar
Добавил железо и DE.
lsof /dev/snd/* до:
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
pulseaudi 1265 maks mem CHR 116,9 844 /dev/snd/pcmC1D0p
pulseaudi 1265 maks 16u CHR 116,13 0t0 852 /dev/snd/controlC1
pulseaudi 1265 maks 18u CHR 116,8 0t0 832 /dev/snd/controlC2
pulseaudi 1265 maks 19u CHR 116,20 0t0 916 /dev/snd/controlC0
pulseaudi 1265 maks 24u CHR 116,13 0t0 852 /dev/snd/controlC1
pulseaudi 1265 maks 25u CHR 116,13 0t0 852 /dev/snd/controlC1
pulseaudi 1265 maks 30u CHR 116,13 0t0 852 /dev/snd/controlC1
pulseaudi 1265 maks 43u CHR 116,9 0t0 844 /dev/snd/pcmC1D0p

lsof /dev/snd/* после:
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
pulseaudi 1265 maks 16u CHR 116,13 0t0 852 /dev/snd/controlC1
pulseaudi 1265 maks 18u CHR 116,8 0t0 832 /dev/snd/controlC2
pulseaudi 1265 maks 19u CHR 116,20 0t0 916 /dev/snd/controlC0
pulseaudi 1265 maks 25u CHR 116,13 0t0 852 /dev/snd/controlC1
pulseaudi 1265 maks 30u CHR 116,13 0t0 852 /dev/snd/controlC1
pipewire 5056 maks 44u CHR 116,1 0t0 554 /dev/snd/seq
pipewire 5056 maks 45u CHR 116,1 0t0 554 /dev/snd/seq
wireplumb 5057 maks 29u CHR 116,13 0t0 852 /dev/snd/controlC1
wireplumb 5057 maks 32u CHR 116,8 0t0 832 /dev/snd/controlC2
wireplumb 5057 maks 33u CHR 116,20 0t0 916 /dev/snd/controlC0

inxi -A до:
Audio:
Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
driver: snd_hda_intel
Device-2: Intel 8 Series/C220 Series High Definition Audio
driver: snd_hda_intel
Device-3: NVIDIA GM107 High Definition Audio [GeForce 940MX]
driver: snd_hda_intel
Sound Server-1: ALSA v: k5.15.19-1-MANJARO running: yes
Sound Server-2: PulseAudio v: 15.0 running: yes

inix -A после:
Audio:
Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
driver: snd_hda_intel
Device-2: Intel 8 Series/C220 Series High Definition Audio
driver: snd_hda_intel
Device-3: NVIDIA GM107 High Definition Audio [GeForce 940MX]
driver: snd_hda_intel
Sound Server-1: ALSA v: k5.15.19-1-MANJARO running: yes
Sound Server-2: PulseAudio v: 15.0 running: yes
Sound Server-3: PipeWire v: 0.3.45 running: yes
0
avatar
sudo systemctl disable --global pipewire
попробовал вот это и вроде как сработало. Вопрос к знатокам: правильно ли я сделал?
Последний раз редактировалось
0
avatar
я бы добавил еще
sudo systemctl mask pipewire

но честно скажу, это такое себе решение больше хирурга, а не терапевта))
Последний раз редактировалось
?
Всегда есть быстрое простое неправильное решение.
быстрые простые правильные (иногда) ответы здесь t.me/manjarolinux
+1
avatar
Ахаха, спасибо) На досуге почитаю про этот pipewire, может дополню решение
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.