Уголок новичка
   413

пакеты сироты

Добрый вечер
Мигрировал с мыши на кеды
Инсталил следующее
sudo pacman -S plasma-meta kde-applications-meta manjaro-kde-settings manjaro-settings-manager-knotifier manjaro-settings-manager-kcm
sudo pacman -S sddm sddm-kcm systemd-kcm sddm-breath-theme
sudo pacman -S octopi octopi-notifier-frameworks octopi-repoeditor octopi-cachecleaner


собственно сегодня обнаружил что pacman не подтянул часть и считает их не особо нужными
pacman -Qdt

вывод
akonadi-calendar-tools 19.12.3-1
akonadiconsole 19.12.3-1
ark 19.12.3-1
artikulate 19.12.3-1
audiocd-kio 19.12.3-1
blinken 19.12.3-1
dkms 2.8.1-1
filelight 19.12.3-1
grantlee-editor 19.12.3-1
k3b 1:19.12.3-1
kaddressbook 19.12.3-1
kalarm 19.12.3-1
kalgebra 19.12.3-1
kalzium 19.12.3-1
kamoso 19.12.3-1
kanagram 19.12.3-1
kbackup 19.12.3-1
kbruch 19.12.3-1
kcharselect 19.12.3-1
kde-gtk-config 5.18.3-1
kdeaccessibility-meta 19.12-1
kdeadmin-meta 19.12-1
kdebase-meta 19.12-1
kdebugsettings 19.12.3-1
kdegames-meta 19.12-1
kdegraphics-meta 19.12-1
kdenetwork-filesharing 19.12.3-1
kdenlive 19.12.3-1
kdeplasma-addons 5.18.3-1
kdesdk-meta 19.12-1
kdewebdev-meta 19.12-1
kdf 19.12.3-1
kfloppy 19.12.3-1
kgamma5 5.18.3-1
kgeography 19.12.3-1
kget 19.12.3-1
kgpg 19.12.3-1
khangman 19.12.3-1
khotkeys 5.18.3-1
kig 19.12.3-1
kinfocenter 5.18.3-1
kleopatra 19.12.3-1
klettres 19.12.3-1
kmix 19.12.3-1
kmplot 19.12.3-1
knotes 19.12.3-1
kontact 19.12.3-1
kopete 19.12.3-1
korganizer 19.12.3-1
krdc 19.12.3-1
krfb 19.12.3-3
kteatime 19.12.3-1
ktimer 19.12.3-1
ktouch 19.12.3-1
kturtle 19.12.3-1
kvantum-theme-matchama 20191118-1
kwallet-pam 5.18.3-1
kwave 19.12.3-1
kwayland-integration 5.18.3-1
kwordquiz 19.12.3-1
kwrited 5.18.3-1
lib32-openssl-1.0 1.0.2.u-1
libpng12 1.2.59-1
lv2 1.16.0-3
marble 19.12.3-1
mbox-importer 19.12.3-1
minuet 19.12.3-1
oxygen 5.18.3-1
papirus-maia-icon-theme 20190726-1
parley 19.12.3-1
pim-data-exporter 19.12.3-1
pim-sieve-editor 19.12.3-1
plasma-browser-integration 5.18.3-1
plasma-pa 5.18.3-1
plasma-sdk 5.18.3-1
plasma-thunderbolt 5.18.3-1
plasma-vault 5.18.3-1
pygtk 2.24.0-8
qt4 4.8.7-29.1
qt5-styleplugins 5.0.0.20170311-19
qt5ct 0.41-2
rocs 19.12.3-1
sddm-kcm 5.18.3-1
step 19.12.3-1
sweeper 19.12.3-1
syndication 5.68.0-1
telepathy-kde-approver 19.12.3-1
telepathy-kde-auth-handler 19.12.3-1
telepathy-kde-call-ui 19.12.3-1
telepathy-kde-contact-runner 19.12.3-1
telepathy-kde-desktop-applets 19.12.3-1
telepathy-kde-filetransfer-handler 19.12.3-1
telepathy-kde-integration-module 19.12.3-1
telepathy-kde-send-file 19.12.3-1
telepathy-kde-text-ui 19.12.3-1
user-manager 5.18.3-1
xcape 1.2-3
xcursor-breeze 5.11.5-1
zeroconf-ioslave 19.12.3-1

подскажите как элегантно их подтянуть(и подтянуть нужные)

т к вручную это немного мучительно
sudo  pacman -D --asexplicit "ХХХХ" 

спасибо всем не равнодушным

9 комментариев

avatar
список всех пакетов, которые выводит pacman -Qdt в файл ~/pacmanqdt без номера их версии:
pacman -Qdt | awk '{print $1}' >> ~/pacmanqdt

подкинет список пакетов из ~/pacmanqdt в команду pacman -D --asexplit. (список пакетов нужно бы откорректировать, перед тем как отдавать ее пакману).
pacman -D --asexplicit < ~/pacmanqdt

если уверены, что все пакеты, которые выводит Qdt вам нужны:
pacman -D --asexplicit $(pacman -Qdt | awk \{print\ \$1\})

по идее должно работать без обрезания нумерации, но я не уверен.
Последний раз редактировалось
+1
avatar
pacman -D --asexplicit < ~/pacmanqdt

почему то не подтягивался
0
avatar
подскажите как элегантно их подтянуть
sudo pacman -S kde-applications
Последний раз редактировалось
+2
avatar
Я тоже считаю половину из них не особо нужными.
SDDM — чем плох lightDM? Ни то ни другое к кедам ни одним боком.
DKMS — то есть до сего дня все работало без необходимости ставить оный и тут это случилось. Кстати что?
Всякие k3b кажутся довольно сомнительной идеей (хотя может Вы действительно режете диски) как и полный набор kde-(educations|games) (kalgebra, kalzium, kanagram, kturtle) с kfloppy (оно Вам точно нужно?) до кучи.
вручную это немного мучительно
Выбрать руками два десятка нужных аппликух, КМК, проще чем чистить систему от всего свистопердящего зоопарка, который притянет мета.
ИМХО, минус кед — они пытаются вобрать в себя все. Всякие koffice, dragon и попытки написать свой браузер не привели ни к чему. В первом случае krita покинула этот веселый карнавал, а в последнем после переименования qupzilla в falkon не происходит вообще ничего. Amarok, насколько помню, тоже заброшен.
Зато есть okular, прожевывающий тонны текстовых форматов и еще несколько хороших прилагух.
Последний раз редактировалось
+1
avatar
Осиротевшие пакеты удаляются простой командой.
sudo pacman -Rns (pacman -Qtdq)
Последний раз редактировалось
0
avatar
Осиротевшие пакеты удаляются простой командой.
на сколько я понял, цель ТС'а не удалить пакеты сироты, а чтобы пакман их таковым не считал, то есть чтобы он понимал эти самые пакеты(которые под спойлером) как явно установленные
?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
0
avatar
В первом комменте темы есть описание как скормить пакману список чтобы он пометил их в базе как явно установленные.
Последний раз редактировалось
0
avatar
да я видел
?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
0
avatar
решил сносом всего
спасибо
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.