Уголок новичка
   726

[РЕШЕНО] Ошибка при обновлении с фразой "нет файла или каталога"

Здравствуйте!
После команды pacman -Syyuu вот такое:
Запускается полное обновление системы...
:: Заменить ilmbase на extra/openexr? [Y/n] Y
:: Заменить kcalcore на extra/kcalendarcore? [Y/n] Y
ошибка: не удалось открыть файл /var/lib/pacman/local/manjaro-release-18.1.0-1/desc: Нет такого файла или каталога
:: Заменить spyder3 на community/spyder? [Y/n] Y
разрешение зависимостей...
проверка конфликтов...
предупреждение: не удалось загрузить все метаданные для пакета manjaro-release-18.1.0-1
ошибка: не удалось подготовить транзакцию (неверный или поврежденный пакет)

17 комментариев

avatar
Покажи вывод команды
ls -la /var/lib/pacman/local/manjaro-release-18.1.0-1
Последний раз редактировалось
0
avatar
итого 124
drwxr-xr-x    2 root root   4096 сен 26 23:10 .
drwxr-xr-x 2101 root root 110592 ноя 11 20:38 ..
-rw-r--r--    1 root root     30 сен 26 23:10 files
0
avatar
Попробуй перед обновлением.
sudo pacman -S manjaro-release
0
avatar
После команды так:
разрешение зависимостей...
проверка конфликтов...
ошибка: не удалось открыть файл /var/lib/pacman/local/manjaro-release-18.1.0-1/desc: Нет такого файла или каталога
предупреждение: не удалось загрузить все метаданные для пакета manjaro-release-18.1.0-1
ошибка: не удалось подготовить транзакцию (неверный или поврежденный пакет)
0
avatar
Покажите pacman -Qi manjaro-release
Пробуйте sudo mkdir -p /var/lib/pacman/local/manjaro-release-18.1.0-1/desc
потом sudo pacman -Syu
Последний раз редактировалось
0
avatar
Ответ на pacman -Qi manjaro-release:
ошибка: не удалось открыть файл /var/lib/pacman/local/manjaro-release-18.1.0-1/desc: Нет такого файла или каталога
Название             : manjaro-release
Версия               : 18.1.0-1
Описание             : Нет
Архитектура          : Нет
URL                  : Нет
Лицензии             : Нет
Группы               : Нет
Предоставляет        : Нет
Зависит от           : Нет
Доп. зависимости     : Нет
Требуется            : Нет
Опционально для      : Нет
Конфликтует с        : Нет
Заменяет             : Нет
Установленный размер : 0,00 B
Сборщик              : Нет
Дата сборки          : Нет
Дата установки       : Нет
Причина установки    : Явно установлен
Установочный скрипт  : No
Проверен             : Неизвестно 


Ответ на sudo pacman -Syu:
:: Обновление баз данных пакетов...
 core                                     147,7 KiB  2,15M/s 00:00 [####################################] 100%
 extra                                   1757,6 KiB  1398K/s 00:01 [####################################] 100%
 community                                  5,2 MiB  1116K/s 00:05 [####################################] 100%
 multilib                                 181,1 KiB  4,11M/s 00:00 [####################################] 100%
:: Запускается полное обновление системы...
:: Заменить ilmbase на extra/openexr? [Y/n] Y
:: Заменить kcalcore на extra/kcalendarcore? [Y/n] Y
:: Заменить linux52 на community/linux-latest? [Y/n] Y
:: Заменить python-qscintilla-qt5-common на extra/python-qscintilla-qt5? [Y/n] Y
:: Заменить spyder3 на community/spyder? [Y/n] Y
:: Заменить totem-plparser на extra/totem-pl-parser? [Y/n] Y
разрешение зависимостей...
проверка конфликтов...
предупреждение: не удалось загрузить все метаданные для пакета manjaro-release-18.1.0-1
ошибка: не удалось подготовить транзакцию (неверный или поврежденный пакет) 
0
avatar
:: Запускается полное обновление системы…
:: Заменить ilmbase на extra/openexr? [Y/n] Y
:: Заменить kcalcore на extra/kcalendarcore? [Y/n] Y
:: Заменить linux52 на community/linux-latest? [Y/n] Y
:: Заменить python-qscintilla-qt5-common на extra/python-qscintilla-qt5? [Y/n] Y
:: Заменить spyder3 на community/spyder? [Y/n] Y
:: Заменить totem-plparser на extra/totem-pl-parser? [Y/n] Y
поробуйте просто enter вместо y
и покажите вывод
0
avatar
Похоже, что также:
:: Обновление баз данных пакетов...
 core не устарел
 extra не устарел
 community не устарел
 multilib не устарел
:: Запускается полное обновление системы...
:: Заменить ilmbase на extra/openexr? [Y/n] 
:: Заменить kcalcore на extra/kcalendarcore? [Y/n] 
:: Заменить linux52 на community/linux-latest? [Y/n] 
:: Заменить python-qscintilla-qt5-common на extra/python-qscintilla-qt5? [Y/n] 
:: Заменить spyder3 на community/spyder? [Y/n] 
:: Заменить totem-plparser на extra/totem-pl-parser? [Y/n] 
разрешение зависимостей...
проверка конфликтов...
предупреждение: не удалось загрузить все метаданные для пакета manjaro-release-18.1.0-1
ошибка: не удалось подготовить транзакцию (неверный или поврежденный пакет 
0
avatar
разрешение зависимостей…
проверка конфликтов…
ошибка: не удалось открыть файл /var/lib/pacman/local/manjaro-release-18.1.0-1/desc: Нет такого файла или каталога
предупреждение: не удалось загрузить все метаданные для пакета manjaro-release-18.1.0-1
ошибка: не удалось подготовить транзакцию (неверный или поврежденный пакет)
попробуй создать этот файл
%NAME%
manjaro-release

%VERSION%
18.1.3-1

%BASE%
manjaro-release

%DESC%
Manjaro's release definition

%URL%
https://manjaro.org/

%ARCH%
any

%BUILDDATE%
1573671926

%INSTALLDATE%
1573753391

%PACKAGER%
Philip Mueller <philm@manjaro.org>

%SIZE%
108

%LICENSE%
GPL2

%VALIDATION%
pgp

%DEPENDS%
lsb-release

?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
0
avatar
похожая ситуация
Спойлер!
0
avatar
Здравствуйте, можно посмотреть uname -a
0
avatar
5.2.11-1-MANJARO #1 SMP PREEMPT Thu Aug 29 07:41:24 UTC 2019 x86_64 GNU/Linux
0
avatar
Покажите mirrorlist.
Попробуйте sudo rm -r /var/lib/pacman/local/manjaro-release-18.1.0-1/ удалит папку
Затем reboot
и sudo pacman -Syu
кстати пакман позволяет ставить пакеты?
Последний раз редактировалось
0
avatar
Сразу после справки в файле:
## Country: Russia
Server = mirror.truenetwork.ru/manjaro/stable/$repo/$arch

## Country: Russia
Server = mirror.yandex.ru/mirrors/manjaro/stable/$repo/$arch
0
avatar
Сразу после справки в файле:
## Country: Russia
Server = mirror.truenetwork.ru/manjaro/stable/$repo/$arch

## Country: Russia
Server = mirror.yandex.ru/mirrors/manjaro/stable/$repo/$arch

После sudo rm -r /var/lib/pacman/local/manjaro-release-18.1.0-1/ сделал перезагрузку.

После sudo pacman -Syu:
:: Обновление баз данных пакетов...
 core                                     147,7 KiB  2,53M/s 00:00 [####################################] 100%
 extra                                   1757,5 KiB  3,62M/s 00:00 [####################################] 100%
 community                                  5,2 MiB  4,36M/s 00:01 [####################################] 100%
 multilib                                 181,1 KiB  4,11M/s 00:00 [####################################] 100%
:: Запускается полное обновление системы...
:: Заменить ilmbase на extra/openexr? [Y/n] 
:: Заменить kcalcore на extra/kcalendarcore? [Y/n] 
:: Заменить linux52 на community/linux-latest? [Y/n] 
:: Заменить python-qscintilla-qt5-common на extra/python-qscintilla-qt5? [Y/n] 
:: Заменить spyder3 на community/spyder? [Y/n] 
:: Заменить totem-plparser на extra/totem-pl-parser? [Y/n] 
разрешение зависимостей...
проверка конфликтов...
предупреждение: обнаружена циклическая зависимость:
предупреждение: bashrc-manjaro будет установлен перед bash, как зависимость
предупреждение: обнаружена циклическая зависимость:
предупреждение: mesa будет установлен перед libglvnd, как зависимость
предупреждение: обнаружена циклическая зависимость:
предупреждение: python-ipykernel будет установлен перед python-jupyter_client, как зависимость
предупреждение: обнаружена циклическая зависимость:
предупреждение: python-ipywidgets будет установлен перед jupyter-notebook, как зависимость
предупреждение: обнаружена циклическая зависимость:
предупреждение: lib32-mesa будет установлен перед lib32-libglvnd, как зависимость


Дальше пошло нормальное обновление.

П.С. На сколько пробовал до этого, система не ставила пакеты через pamac.
Последний раз редактировалось
0
avatar
П.С. На сколько пробовал до этого, система не ставила пакеты через pamac
памак или пакман?
0
avatar
через обе программы: графически и через терминал.
Благодарю. Система работает. Даже немного лучше прежнего.
+1
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.