Уголок новичка
   694

Зависет система при использовании DRI_PRIME=1 на amd

OS: Manjaro Linux x86_64
Host: 20388 Lenovo B50-45
Kernel: 5.8.0-2-MANJARO
DE: GNOME 3.36.4
WM: Mutter
CPU: AMD A8-6410 APU with AMD Radeon R5 Graphics (4) @ 2.000GHz
GPU: AMD ATI Radeon R4/R5 Graphics (встройка)
GPU: AMD ATI Radeon HD 8550M / R5 M230 (дискретка)
$ uname -a                                                                                                                     
Linux potato-pc 5.8.0-2-MANJARO 1 SMP PREEMPT Sat Aug 8 17:55:27 UTC 2020 x86_64 GNU/Linux

Система видит обе видеокарты
$ lspci -k | grep -A 2 -E "(VGA|Display)"                                                                                           
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Mullins [Radeon R4/R5 Graphics] (rev 05)
	Subsystem: Lenovo Device 3819
	Kernel driver in use: radeon
--
01:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Sun LE [Radeon HD 8550M / R5 M230]
	Subsystem: Lenovo Device 3819
	Kernel driver in use: radeon

Когда я использую DRI_PRIME=1, и когда не использую, у меня показываются разные видеокарты
$ glxinfo | grep "OpenGL renderer"                                                                                                  
OpenGL renderer string: AMD KABINI (DRM 2.50.0, 5.8.0-2-MANJARO, LLVM 10.0.1)

$ DRI_PRIME=1 glxinfo | grep "OpenGL renderer"                                                                                      
OpenGL renderer string: AMD HAINAN (DRM 2.50.0, 5.8.0-2-MANJARO, LLVM 10.0.1)

$ inxi -SGC
System:    Host: potato-pc Kernel: 5.8.0-2-MANJARO x86_64 bits: 64 Desktop: GNOME 3.36.4 Distro: Manjaro Linux 
CPU:       Topology: Quad Core model: AMD A8-6410 APU with AMD Radeon R5 Graphics bits: 64 type: MCP L2 cache: 2048 KiB 
           Speed: 998 MHz min/max: 1000/2000 MHz Core speeds (MHz): 1: 1464 2: 1318 3: 1323 4: 1306 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Mullins [Radeon R4/R5 Graphics] driver: radeon v: kernel 
           Device-2: Advanced Micro Devices [AMD/ATI] Sun LE [Radeon HD 8550M / R5 M230] driver: radeon v: kernel 
           Device-3: Acer type: USB driver: uvcvideo 
           Display: x11 server: X.org 1.20.8 driver: ati,radeon unloaded: modesetting resolution: <xdpyinfo missing> 
           OpenGL: renderer: AMD KABINI (DRM 2.50.0 5.8.0-2-MANJARO LLVM 10.0.1) v: 4.5 Mesa 20.1.5 

$ mhwd -li                                                                                                                          
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI


Warning: No installed USB configs!

Но стоит мне запустить любую программу не текстового вида, например
$ DRI_PRIME=1 blender

И у меня сразу же зависает система (даже тту сменить невыходит), как сделать что бы система не зависала при DRI_PRIME=1?

0 комментариев

Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.